restore Releasing to upstream version debian/1.2.1-1
authorBdale Garbee <bdale@gag.com>
Tue, 21 May 2013 15:51:02 +0000 (09:51 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 21 May 2013 15:51:02 +0000 (09:51 -0600)
Releasing

index 4e76d791887235ddb2ca095ab7e65b7c95936ed1..ce4df7c279c177522437c4935271b295492af436 100644 (file)
--- a/Releasing
+++ b/Releasing
@@ -10,24 +10,22 @@ These are Bdale's notes on how to do a release.
          will be pulled in automatically)
 
        - update the version in configure.ac
-       - make absolutely sure checked-out tree is "clean" (commit as needed)
+        git log > ChangeLog
+       git commit -a
+       - make absolutely sure checked-out tree is "clean" 
        - if this is an x.y release, then:
                git checkout -b branch-<version>
+               git tag -a <version>
        - if this is an x.y.z release, then:
                git checkout branch-<version>           # the x.y parts only
                git merge master
+               git tag -a <version>                    # full x.y.z version
 
-        git log > ChangeLog
-       git commit -a
-
-       git tag -a <version>
+       - edit .git/gbp.conf to use branch-<version> as upstream if needed
 
        git checkout debian
        git merge branch-<version>
 
-       - edit .git/gbp.conf to use branch-<version> as upstream and debian
-         as packaging branch, if needed
-
        - verify debian/changelog is "clean" ending in last release version
        - craft a suitable debian/changelog entry, possibly using:
        git-dch --release --new-version=<version>-1 --multimaint-merge