Remove stale tools (ao-dumplog, ao-postflight, ao-view)
authorKeith Packard <keithp@keithp.com>
Wed, 24 Aug 2011 06:20:00 +0000 (23:20 -0700)
committerKeith Packard <keithp@keithp.com>
Wed, 24 Aug 2011 06:20:00 +0000 (23:20 -0700)
These tools have all been supplanted by altosui at this point, and
keeping them around increases the build dependencies by quite a lot.

Signed-off-by: Keith Packard <keithp@keithp.com>
ao-tools/Makefile.am
ao-tools/lib/Makefile.am
configure.ac
debian/control

index 2850e90..8144be1 100644 (file)
@@ -1 +1 @@
-SUBDIRS=lib ao-rawload ao-dbg ao-dumplog ao-bitbang ao-eeprom ao-list ao-load ao-postflight ao-view
+SUBDIRS=lib ao-rawload ao-dbg ao-bitbang ao-eeprom ao-list ao-load
index 79972f4..da355db 100644 (file)
@@ -2,6 +2,9 @@ noinst_LIBRARIES = libao-tools.a
 
 AM_CFLAGS=$(WARN_CFLAGS) $(LIBUSB_CFLAGS) $(GNOME_CFLAGS)
 
+libao_tools_a_uneeded = \
+       cc-log.c
+
 libao_tools_a_SOURCES = \
        ccdbg-command.c \
        ccdbg-debug.c \
@@ -17,7 +20,6 @@ libao_tools_a_SOURCES = \
        cc-analyse.c \
        cc-convert.c \
        cc-dsp.c \
-       cc-log.c \
        cc-integrate.c \
        cc-period.c \
        cc-process.c \
index 93f5311..0a6001b 100644 (file)
@@ -95,20 +95,6 @@ if test "x$GCC" = "xyes"; then
 fi
 AC_SUBST(WARN_CFLAGS)
 
-AC_CHECK_HEADERS(flite/flite.h,HAVE_FLITE_H=yes,HAVE_FLITE_H=no)
-AC_CHECK_LIB(flite, flite_init,HAVE_LIBFLITE=yes,HAVE_LIBFLITE=no,-lasound -lm)
-
-if test "x$HAVE_FLITE_H" = "xyes" -a "x$HAVE_LIBFLITE" = "xyes"; then
-       AC_DEFINE(HAVE_FLITE,1,[Define if the flite library is usable])
-       AC_SUBST(FLITE_LIBS,"-lflite_cmu_us_kal16 -lflite_usenglish -lflite_cmulex -lflite -lasound -lm")
-       AC_SUBST(FLITE_INCS,-Iflite)
-       save_LIBS="$LIBS"
-       LIBS="$LIBS $FLITE_LIBS"
-       AC_CHECK_FUNCS([register_cmu_us_kal16 register_cmu_us_kal],break)
-       LIBS="$save_LIBS"
-fi
-AM_CONDITIONAL(USE_FLITE,test "x$HAVE_FLITE_H" = "xyes" -a "x$HAVE_LIBFLITE" = "xyes")
-
 AC_CHECK_PROG([HAVE_SDCC], [sdcc], yes, no)
 if test "x$HAVE_SDCC" = "xno"; then
        AC_MSG_ERROR([Please install sdcc to build AltOs])
@@ -121,16 +107,8 @@ fi
 
 AC_CHECK_LIB(readline, readline)
 
-PKG_CHECK_MODULES([GNOME], [gtk+-2.0 libglade-2.0 gconf-2.0])
-
 PKG_CHECK_MODULES([LIBUSB], [libusb-1.0])
 
-PKG_CHECK_MODULES([ALSA], [alsa])
-
-PKG_CHECK_MODULES([PLPLOT], [plplotd])
-
-PKG_CHECK_MODULES([SNDFILE], [sndfile])
-
 AC_OUTPUT([
 Makefile
 altosui/Makefile
@@ -140,13 +118,10 @@ ao-tools/Makefile
 ao-tools/lib/Makefile
 ao-tools/ao-rawload/Makefile
 ao-tools/ao-dbg/Makefile
-ao-tools/ao-dumplog/Makefile
 ao-tools/ao-bitbang/Makefile
 ao-tools/ao-eeprom/Makefile
 ao-tools/ao-list/Makefile
 ao-tools/ao-load/Makefile
-ao-tools/ao-postflight/Makefile
-ao-tools/ao-view/Makefile
 ao-utils/Makefile
 src/Version
 ])
index fc70c8e..f784a70 100644 (file)
@@ -3,13 +3,13 @@ Section: otherosfs
 Priority: extra
 Maintainer: Bdale Garbee <bdale@gag.com>
 Uploaders: Keith Packard <keithp@keithp.com>
-Build-Depends: debhelper (>= 7), autoconf, automake, flite1-dev, gawk, libasound2-dev, libgconf2-dev, libglade2-dev, libgtk2.0-dev, libreadline-dev, libusb-1.0-0-dev, nickle, sdcc, libplplot-dev, xsltproc, fop, docbook-xml, docbook-xsl, libsndfile1-dev, swig, openjdk-6-jdk, freetts, libtool, libjfreechart-java, libbluetooth-dev
+Build-Depends: debhelper (>= 7), autoconf, automake, gawk, libreadline-dev, libusb-1.0-0-dev, nickle, sdcc, xsltproc, fop, docbook-xml, docbook-xsl, swig, openjdk-6-jdk, freetts, libtool, libjfreechart-java, libbluetooth-dev
 Standards-Version: 3.9.2
 Homepage: http://altusmetrum.org/AltOS
 
 Package: altos
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, default-jre | java2-runtime, freetts, nickle, plplot9-driver-cairo
+Depends: ${shlibs:Depends}, ${misc:Depends}, default-jre | java2-runtime, freetts, nickle
 Suggests: slim | gdm
 Replaces: altusmetrum-themes, slim-altusmetrum
 Conflicts: altusmetrum-themes, slim-altusmetrum