first cut at turnon scripts for EasyTimer v2
[fw/altos] / map-server / altos-mapd / Makefile.am
index 315a33d523c7ad9bb31c3a350e0b65ff96fa8a24..29ee65e85fcc5a07869f93c3f7e20a4cdec04811 100644 (file)
@@ -1,5 +1,5 @@
 JAVAROOT=classes
-AM_JAVACFLAGS=-target 1.6 -encoding UTF-8 -Xlint:deprecation -Xlint:unchecked -source 6
+AM_JAVACFLAGS=$(JAVAC_VERSION_FLAGS) -encoding UTF-8 -Xlint:deprecation -Xlint:unchecked
 
 altoslibdir=$(libdir)/altos
 
@@ -26,7 +26,7 @@ defaultsdir=$(sysconfdir)/default
 
 defaults_DATA=altos-mapd-default
 
-systemddir=$(libdir)/systemd/system
+systemddir=$(bindir)/../lib/systemd/system
 
 systemd_DATA=altos-mapd.service
 
@@ -60,6 +60,10 @@ altos-mapd: Makefile
        echo 'exec java -Djava.library.path="$(altoslibdir)" -jar "$(altosmapddir)/altosmapd.jar" "$$@"' >> $@
        chmod +x $@
 
+Manifest.txt: Makefile
+       echo 'Main-Class: altosmapd.AltosMapd' > $@
+       echo "Class-Path: $(ALTOSLIB_CLASS) $(ALTOSUILIB_CLASS)" >> $@
+
 altos-mapd-test: Makefile
        echo '#!/bin/sh' > $@
        echo 'dir="$$(dirname $$0)"' >> $@
@@ -77,3 +81,6 @@ $(ALTOSLIB_CLASS):
        -rm -f "$@"
        $(LN_S) ../../altoslib/"$@" .
 
+
+clean::
+       rm -f Manifest.txt