Merge branch 'upstream'
authorBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 17:47:52 +0000 (11:47 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 17:47:52 +0000 (11:47 -0600)
Conflicts:

Makefile.in
NEWS
config.guess
config.sub
configure
configure.in
diskdefs

1  2 
config.guess
config.sub
cpmrm.1.in
debian/copyright
diskdefs
fsck.cpm.1.in

diff --cc config.guess
index ad5281e66e9def96e03533881ed570a8a495ccd5,eeb9aef181ba679b68402ac61cbd529f13a7f895..f32079abda668e5fc8f8de6f226e7b26384e8a03
@@@ -1,9 -1,10 +1,10 @@@
  #! /bin/sh
  # Attempt to guess a canonical system name.
  #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
- #   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
 -#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 -#   Inc.
++#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
++#   Free Software Foundation, Inc.
  
- timestamp='2005-08-03'
 -timestamp='2006-11-15'
++timestamp='2008-01-23'
  
  # This file is free software; you can redistribute it and/or modify it
  # under the terms of the GNU General Public License as published by
@@@ -55,8 -56,8 +56,8 @@@ version="
  GNU config.guess ($timestamp)
  
  Originally written by Per Bothner.
--Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
--Free Software Foundation, Inc.
++Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
++2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
  
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@@ -325,7 -330,7 +330,7 @@@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:
      sun4*:SunOS:5.*:* | tadpole*:SunOS:5.*:*)
        echo sparc-sun-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
        exit ;;
--    i86pc:SunOS:5.*:*)
++    i86pc:SunOS:5.*:* | i86xen:SunOS:5.*:*)
        echo i386-pc-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
        exit ;;
      sun4*:SunOS:6*:*)
@@@ -527,7 -532,7 +532,7 @@@ EO
                echo rs6000-ibm-aix3.2
        fi
        exit ;;
--    *:AIX:*:[45])
++    *:AIX:*:[456])
        IBM_CPU_ID=`/usr/sbin/lsdev -C -c processor -S available | sed 1q | awk '{ print $1 }'`
        if /usr/sbin/lsattr -El ${IBM_CPU_ID} | grep ' POWER' >/dev/null 2>&1; then
                IBM_ARCH=rs6000
@@@ -769,7 -781,7 +781,7 @@@ EO
      i*:CYGWIN*:*)
        echo ${UNAME_MACHINE}-pc-cygwin
        exit ;;
--    i*:MINGW*:*)
++    *:MINGW*:*)
        echo ${UNAME_MACHINE}-pc-mingw32
        exit ;;
      i*:windows32*:*)
      i*:PW*:*)
        echo ${UNAME_MACHINE}-pc-pw32
        exit ;;
-     x86:Interix*:[34]*)
-       echo i586-pc-interix${UNAME_RELEASE}|sed -e 's/\..*//'
 -    x86:Interix*:[3456]*)
 -      echo i586-pc-interix${UNAME_RELEASE}
 -      exit ;;
 -    EM64T:Interix*:[3456]* | authenticamd:Interix*:[3456]*)
 -      echo x86_64-unknown-interix${UNAME_RELEASE}
--      exit ;;
++    *:Interix*:[3456]*)
++      case ${UNAME_MACHINE} in
++          x86)
++              echo i586-pc-interix${UNAME_RELEASE}
++              exit ;;
++          EM64T | authenticamd)
++              echo x86_64-unknown-interix${UNAME_RELEASE}
++              exit ;;
++          IA64)
++              echo ia64-unknown-interix${UNAME_RELEASE}
++              exit ;;
++      esac ;;
      [345]86:Windows_95:* | [345]86:Windows_98:* | [345]86:Windows_NT:*)
        echo i${UNAME_MACHINE}-pc-mks
        exit ;;
        echo ${UNAME_MACHINE}-pc-minix
        exit ;;
      arm*:Linux:*:*)
 -      echo ${UNAME_MACHINE}-unknown-linux-gnu
++      eval $set_cc_for_build
++      if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
++          | grep -q __ARM_EABI__
++      then
++          echo ${UNAME_MACHINE}-unknown-linux-gnu
++      else
++          echo ${UNAME_MACHINE}-unknown-linux-gnueabi
++      fi
+       exit ;;
+     avr32*:Linux:*:*)
        echo ${UNAME_MACHINE}-unknown-linux-gnu
        exit ;;
      cris:Linux:*:*)
@@@ -922,6 -951,6 +964,9 @@@ EO
      x86_64:Linux:*:*)
        echo x86_64-unknown-linux-gnu
        exit ;;
++    xtensa*:Linux:*:*)
++      echo ${UNAME_MACHINE}-unknown-linux-gnu
++      exit ;;
      i*86:Linux:*:*)
        # The BFD linker knows what the default object file format is, so
        # first see if it will tell us. cd to the root directory to prevent
      SX-6:SUPER-UX:*:*)
        echo sx6-nec-superux${UNAME_RELEASE}
        exit ;;
++    SX-7:SUPER-UX:*:*)
++      echo sx7-nec-superux${UNAME_RELEASE}
++      exit ;;
+     SX-8:SUPER-UX:*:*)
+       echo sx8-nec-superux${UNAME_RELEASE}
+       exit ;;
++    SX-8R:SUPER-UX:*:*)
++      echo sx8r-nec-superux${UNAME_RELEASE}
++      exit ;;
      Power*:Rhapsody:*:*)
        echo powerpc-apple-rhapsody${UNAME_RELEASE}
        exit ;;
@@@ -1424,9 -1462,9 +1484,9 @@@ This script, last modified $timestamp, 
  the operating system you are using. It is advised that you
  download the most up to date version of the config scripts from
  
--  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
++  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
  and
--  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
++  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD
  
  If the version you run ($0) is already up to date, please
  send the following data and any information you think might be
diff --cc config.sub
index 1c366dfde9ab35fe6474af49933455433951457f,7ccee7305792d4cb9ea0a088c371db3ac3884777..6759825a5b7fcf64476b4398dc0e30b3090b925c
@@@ -1,9 -1,10 +1,10 @@@
  #! /bin/sh
  # Configuration validation subroutine script.
  #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
- #   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
 -#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 -#   Inc.
++#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
++#   Free Software Foundation, Inc.
  
- timestamp='2005-07-08'
 -timestamp='2006-11-07'
++timestamp='2008-01-16'
  
  # This file is (in principle) common to ALL GNU software.
  # The presence of a machine in this file suggests that SOME GNU software
@@@ -71,8 -72,8 +72,8 @@@ Report bugs and patches to <config-patc
  version="\
  GNU config.sub ($timestamp)
  
--Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
--Free Software Foundation, Inc.
++Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
++2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
  
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@@ -235,11 -245,12 +245,12 @@@ case $basic_machine i
        | bfin \
        | c4x | clipper \
        | d10v | d30v | dlx | dsp16xx \
--      | fr30 | frv \
++      | fido | fr30 | frv \
        | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
        | i370 | i860 | i960 | ia64 \
        | ip2k | iq2000 \
-       | m32r | m32rle | m68000 | m68k | m88k | maxq | mcore \
+       | m32c | m32r | m32rle | m68000 | m68k | m88k \
 -      | maxq | mb | microblaze | mcore \
++      | maxq | mb | microblaze | mcore | mep \
        | mips | mipsbe | mipseb | mipsel | mipsle \
        | mips16 \
        | mips64 | mips64el \
        | clipper-* | craynv-* | cydra-* \
        | d10v-* | d30v-* | dlx-* \
        | elxsi-* \
--      | f30[01]-* | f700-* | fr30-* | frv-* | fx80-* \
++      | f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
        | h8300-* | h8500-* \
        | hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
        | i*86-* | i860-* | i960-* | ia64-* \
        | tron-* \
        | v850-* | v850e-* | vax-* \
        | we32k-* \
-       | x86-* | x86_64-* | xps100-* | xscale-* | xscalee[bl]-* \
-       | xstormy16-* | xtensa-* \
+       | x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
 -      | xstormy16-* | xtensa-* \
++      | xstormy16-* | xtensa*-* \
        | ymp-* \
        | z8k-*)
                ;;
-       m32c-*)
++      # Recognize the basic CPU types without company name, with glob match.
++      xtensa*)
++              basic_machine=$basic_machine-unknown
 +              ;;
        # Recognize the various machine names and aliases which stand
        # for a CPU type and a company and sometimes even an OS.
        386bsd)
                basic_machine=ns32k-sequent
                os=-dynix
                ;;
++      blackfin)
++              basic_machine=bfin-unknown
++              os=-linux
++              ;;
++      blackfin-*)
++              basic_machine=bfin-`echo $basic_machine | sed 's/^[^-]*-//'`
++              os=-linux
++              ;;
        c90)
                basic_machine=c90-cray
                os=-unicos
                basic_machine=craynv-cray
                os=-unicosmp
                ;;
--      cr16c)
--              basic_machine=cr16c-unknown
++      cr16)
++              basic_machine=cr16-unknown
                os=-elf
                ;;
        crds | unos)
                basic_machine=m68k-isi
                os=-sysv
                ;;
++      m68knommu)
++              basic_machine=m68k-unknown
++              os=-linux
++              ;;
++      m68knommu-*)
++              basic_machine=m68k-`echo $basic_machine | sed 's/^[^-]*-//'`
++              os=-linux
++              ;;
        m88k-omron*)
                basic_machine=m88k-omron
                ;;
                basic_machine=i386-pc
                os=-mingw32
                ;;
++      mingw32ce)
++              basic_machine=arm-unknown
++              os=-mingw32ce
++              ;;
        miniframe)
                basic_machine=m68000-convergent
                ;;
                basic_machine=i860-intel
                os=-osf
                ;;
++      parisc)
++              basic_machine=hppa-unknown
++              os=-linux
++              ;;
++      parisc-*)
++              basic_machine=hppa-`echo $basic_machine | sed 's/^[^-]*-//'`
++              os=-linux
++              ;;
        pbd)
                basic_machine=sparc-tti
                ;;
                basic_machine=tic6x-unknown
                os=-coff
                ;;
++      tile*)
++              basic_machine=tile-unknown
++              os=-linux-gnu
++              ;;
        tx39)
                basic_machine=mipstx39-unknown
                ;;
@@@ -1188,7 -1222,7 +1258,7 @@@ case $os i
              | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
              | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
              | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
-             | -skyos* | -haiku*)
 -            | -skyos* | -haiku* | -rdos* | -toppers*)
++            | -skyos* | -haiku* | -rdos* | -toppers* | -drops*)
        # Remember, each alternative MUST END IN *, to match a version number.
                ;;
        -qnx*)
@@@ -1377,6 -1417,6 +1453,9 @@@ case $basic_machine i
        m68*-cisco)
                os=-aout
                ;;
++        mep-*)
++              os=-elf
++              ;;
        mips*-cisco)
                os=-elf
                ;;
diff --cc cpmrm.1.in
Simple merge
index 1a780ce92f1984dc3e7a56fe7aaf1831b11dd73d,0000000000000000000000000000000000000000..6a4f224fbd080b00e97e5ac3a2c77981a66c2860
mode 100644,000000..100644
--- /dev/null
@@@ -1,23 -1,0 +1,26 @@@
-   Copyright 1997, 1998, 1999, 2000, 2001 Michael Haardt <michael@moria.de>
 +This package was debianized by Bdale Garbee <bdale@gag.com> on
 +Tue, 15 Jan 2002 02:23:43 -0700.
 +
 +It was downloaded from http://www.moria.de/~michael/cpmtools/
 +
 +Upstream Author: Michael Haardt <michael@moria.de>
 +
 +Copyright:
 +
- the Free Software Foundation; version 2 dated June, 1991.
++  Copyright 1997-2007 Michael Haardt <michael@moria.de>
 +
 +  The Windows port is copyright 2000, 2001 John Elliott
 +
 +  The getopt.[ch] and getopt1.c files are
 +    Copyright (C) 1989,90,91,92,93,94,96,97,98 Free Software Foundation, Inc.
 +
++  The install.sh file is Copyright (C) 1994 X Consortium
++
 +This program is free software; you can redistribute it and/or modify
 +it under the terms of the GNU General Public License as published by
++the Free Software Foundation; either version 3 of the License, or
++(at your option) any later version.
 +
 +On Debian GNU/Linux systems, the complete text of the GNU General Public 
 +License can be found in the `/usr/share/common-licenses' directory.
 +
diff --cc diskdefs
index a607c440a42abae3753e286c69c23a8a3c0da6fd,7d8a4442a80aa6e063e78bbec89ea94efb4ec2fb..020dfbf9f3eb494b36aca22fb7a0ee22168956a4
+++ b/diskdefs
@@@ -231,20 -231,30 +231,48 @@@ diskdef p11
    tracks 160
    sectrk 18
    blocksize 2048
++<<<<<<< HEAD:diskdefs
 +  maxdir 128
 +  skew 1
 +  boottrk 1
 +  os 3
 +end
 +
 +
 +diskdef p112a
++=======
+   maxdir 256
+   skew 1
+   boottrk 2
+   os 3
+ end
+ diskdef p112-old
++>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
    seclen 512
    tracks 160
    sectrk 18
    blocksize 2048
++<<<<<<< HEAD:diskdefs
 +  maxdir 256
++=======
+   maxdir 128
++>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
    skew 1
    boottrk 1
    os 3
  end
++<<<<<<< HEAD:diskdefs
++=======
+ diskdef kpii
+   seclen 512
+   tracks 40
+   sectrk 10
+   blocksize 1024
+   maxdir 32
+   skew 0
+   boottrk 1
+   os 2.2
+ end
++>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
diff --cc fsck.cpm.1.in
Simple merge