Merge branch 'upstream'
authorBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 17:47:52 +0000 (11:47 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 17:47:52 +0000 (11:47 -0600)
Conflicts:

Makefile.in
NEWS
config.guess
config.sub
configure
configure.in
diskdefs

1  2 
config.guess
config.sub
cpmrm.1.in
debian/copyright
diskdefs
fsck.cpm.1.in

diff --combined config.guess
index ad5281e66e9def96e03533881ed570a8a495ccd5,eeb9aef181ba679b68402ac61cbd529f13a7f895..f32079abda668e5fc8f8de6f226e7b26384e8a03
@@@ -1,9 -1,10 +1,10 @@@
  #! /bin/sh
  # Attempt to guess a canonical system name.
  #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
- #   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
 -#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 -#   Inc.
++#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
++#   Free Software Foundation, Inc.
  
- timestamp='2005-08-03'
 -timestamp='2006-11-15'
++timestamp='2008-01-23'
  
  # This file is free software; you can redistribute it and/or modify it
  # under the terms of the GNU General Public License as published by
@@@ -55,8 -56,8 +56,8 @@@ version="
  GNU config.guess ($timestamp)
  
  Originally written by Per Bothner.
--Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
--Free Software Foundation, Inc.
++Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
++2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
  
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@@ -106,7 -107,7 +107,7 @@@ set_cc_for_build=
  trap "exitcode=\$?; (rm -f \$tmpfiles 2>/dev/null; rmdir \$tmp 2>/dev/null) && exit \$exitcode" 0 ;
  trap "rm -f \$tmpfiles 2>/dev/null; rmdir \$tmp 2>/dev/null; exit 1" 1 2 13 15 ;
  : ${TMPDIR=/tmp} ;
-  { tmp=`(umask 077 && mktemp -d -q "$TMPDIR/cgXXXXXX") 2>/dev/null` && test -n "$tmp" && test -d "$tmp" ; } ||
+  { tmp=`(umask 077 && mktemp -d "$TMPDIR/cgXXXXXX") 2>/dev/null` && test -n "$tmp" && test -d "$tmp" ; } ||
   { test -n "$RANDOM" && tmp=$TMPDIR/cg$$-$RANDOM && (umask 077 && mkdir $tmp) ; } ||
   { tmp=$TMPDIR/cg-$$ && (umask 077 && mkdir $tmp) && echo "Warning: creating insecure temp directory" >&2 ; } ||
   { echo "$me: cannot create a temporary directory in $TMPDIR" >&2 ; exit 1 ; } ;
@@@ -160,6 -161,7 +161,7 @@@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:
            arm*) machine=arm-unknown ;;
            sh3el) machine=shl-unknown ;;
            sh3eb) machine=sh-unknown ;;
+           sh5el) machine=sh5le-unknown ;;
            *) machine=${UNAME_MACHINE_ARCH}-unknown ;;
        esac
        # The Operating System including object format, if it has switched
      *:ekkoBSD:*:*)
        echo ${UNAME_MACHINE}-unknown-ekkobsd${UNAME_RELEASE}
        exit ;;
+     *:SolidBSD:*:*)
+       echo ${UNAME_MACHINE}-unknown-solidbsd${UNAME_RELEASE}
+       exit ;;
      macppc:MirBSD:*:*)
-       echo powerppc-unknown-mirbsd${UNAME_RELEASE}
+       echo powerpc-unknown-mirbsd${UNAME_RELEASE}
        exit ;;
      *:MirBSD:*:*)
        echo ${UNAME_MACHINE}-unknown-mirbsd${UNAME_RELEASE}
      sun4*:SunOS:5.*:* | tadpole*:SunOS:5.*:*)
        echo sparc-sun-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
        exit ;;
--    i86pc:SunOS:5.*:*)
++    i86pc:SunOS:5.*:* | i86xen:SunOS:5.*:*)
        echo i386-pc-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
        exit ;;
      sun4*:SunOS:6*:*)
@@@ -527,7 -532,7 +532,7 @@@ EO
                echo rs6000-ibm-aix3.2
        fi
        exit ;;
--    *:AIX:*:[45])
++    *:AIX:*:[456])
        IBM_CPU_ID=`/usr/sbin/lsdev -C -c processor -S available | sed 1q | awk '{ print $1 }'`
        if /usr/sbin/lsattr -El ${IBM_CPU_ID} | grep ' POWER' >/dev/null 2>&1; then
                IBM_ARCH=rs6000
@@@ -764,12 -769,19 +769,19 @@@ EO
        echo ${UNAME_MACHINE}-unknown-bsdi${UNAME_RELEASE}
        exit ;;
      *:FreeBSD:*:*)
-       echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
+       case ${UNAME_MACHINE} in
+           pc98)
+               echo i386-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
+           amd64)
+               echo x86_64-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
+           *)
+               echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
+       esac
        exit ;;
      i*:CYGWIN*:*)
        echo ${UNAME_MACHINE}-pc-cygwin
        exit ;;
--    i*:MINGW*:*)
++    *:MINGW*:*)
        echo ${UNAME_MACHINE}-pc-mingw32
        exit ;;
      i*:windows32*:*)
      i*:PW*:*)
        echo ${UNAME_MACHINE}-pc-pw32
        exit ;;
-     x86:Interix*:[34]*)
-       echo i586-pc-interix${UNAME_RELEASE}|sed -e 's/\..*//'
 -    x86:Interix*:[3456]*)
 -      echo i586-pc-interix${UNAME_RELEASE}
 -      exit ;;
 -    EM64T:Interix*:[3456]* | authenticamd:Interix*:[3456]*)
 -      echo x86_64-unknown-interix${UNAME_RELEASE}
--      exit ;;
++    *:Interix*:[3456]*)
++      case ${UNAME_MACHINE} in
++          x86)
++              echo i586-pc-interix${UNAME_RELEASE}
++              exit ;;
++          EM64T | authenticamd)
++              echo x86_64-unknown-interix${UNAME_RELEASE}
++              exit ;;
++          IA64)
++              echo ia64-unknown-interix${UNAME_RELEASE}
++              exit ;;
++      esac ;;
      [345]86:Windows_95:* | [345]86:Windows_98:* | [345]86:Windows_NT:*)
        echo i${UNAME_MACHINE}-pc-mks
        exit ;;
        echo ${UNAME_MACHINE}-pc-minix
        exit ;;
      arm*:Linux:*:*)
 -      echo ${UNAME_MACHINE}-unknown-linux-gnu
++      eval $set_cc_for_build
++      if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
++          | grep -q __ARM_EABI__
++      then
++          echo ${UNAME_MACHINE}-unknown-linux-gnu
++      else
++          echo ${UNAME_MACHINE}-unknown-linux-gnueabi
++      fi
+       exit ;;
+     avr32*:Linux:*:*)
        echo ${UNAME_MACHINE}-unknown-linux-gnu
        exit ;;
      cris:Linux:*:*)
        #endif
        #endif
  EOF
-       eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
+       eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '
+           /^CPU/{
+               s: ::g
+               p
+           }'`"
        test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
        ;;
      mips64:Linux:*:*)
        #endif
        #endif
  EOF
-       eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
+       eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '
+           /^CPU/{
+               s: ::g
+               p
+           }'`"
        test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
        ;;
      or32:Linux:*:*)
      sparc:Linux:*:* | sparc64:Linux:*:*)
        echo ${UNAME_MACHINE}-unknown-linux-gnu
        exit ;;
+     vax:Linux:*:*)
+       echo ${UNAME_MACHINE}-dec-linux-gnu
+       exit ;;
      x86_64:Linux:*:*)
        echo x86_64-unknown-linux-gnu
        exit ;;
++    xtensa*:Linux:*:*)
++      echo ${UNAME_MACHINE}-unknown-linux-gnu
++      exit ;;
      i*86:Linux:*:*)
        # The BFD linker knows what the default object file format is, so
        # first see if it will tell us. cd to the root directory to prevent
        LIBC=gnulibc1
        # endif
        #else
-       #ifdef __INTEL_COMPILER
+       #if defined(__INTEL_COMPILER) || defined(__PGI) || defined(__SUNPRO_C) || defined(__SUNPRO_CC)
        LIBC=gnu
        #else
        LIBC=gnuaout
        LIBC=dietlibc
        #endif
  EOF
-       eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^LIBC=`
+       eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '
+           /^LIBC/{
+               s: ::g
+               p
+           }'`"
        test x"${LIBC}" != x && {
                echo "${UNAME_MACHINE}-pc-linux-${LIBC}"
                exit
      SX-6:SUPER-UX:*:*)
        echo sx6-nec-superux${UNAME_RELEASE}
        exit ;;
++    SX-7:SUPER-UX:*:*)
++      echo sx7-nec-superux${UNAME_RELEASE}
++      exit ;;
+     SX-8:SUPER-UX:*:*)
+       echo sx8-nec-superux${UNAME_RELEASE}
+       exit ;;
++    SX-8R:SUPER-UX:*:*)
++      echo sx8r-nec-superux${UNAME_RELEASE}
++      exit ;;
      Power*:Rhapsody:*:*)
        echo powerpc-apple-rhapsody${UNAME_RELEASE}
        exit ;;
      *:Darwin:*:*)
        UNAME_PROCESSOR=`uname -p` || UNAME_PROCESSOR=unknown
        case $UNAME_PROCESSOR in
-           *86) UNAME_PROCESSOR=i686 ;;
            unknown) UNAME_PROCESSOR=powerpc ;;
        esac
        echo ${UNAME_PROCESSOR}-apple-darwin${UNAME_RELEASE}
      i*86:skyos:*:*)
        echo ${UNAME_MACHINE}-pc-skyos`echo ${UNAME_RELEASE}` | sed -e 's/ .*$//'
        exit ;;
+     i*86:rdos:*:*)
+       echo ${UNAME_MACHINE}-pc-rdos
+       exit ;;
  esac
  
  #echo '(No uname command or uname output not recognized.)' 1>&2
@@@ -1424,9 -1462,9 +1484,9 @@@ This script, last modified $timestamp, 
  the operating system you are using. It is advised that you
  download the most up to date version of the config scripts from
  
--  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
++  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
  and
--  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
++  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD
  
  If the version you run ($0) is already up to date, please
  send the following data and any information you think might be
diff --combined config.sub
index 1c366dfde9ab35fe6474af49933455433951457f,7ccee7305792d4cb9ea0a088c371db3ac3884777..6759825a5b7fcf64476b4398dc0e30b3090b925c
@@@ -1,9 -1,10 +1,10 @@@
  #! /bin/sh
  # Configuration validation subroutine script.
  #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
- #   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
 -#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
 -#   Inc.
++#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
++#   Free Software Foundation, Inc.
  
- timestamp='2005-07-08'
 -timestamp='2006-11-07'
++timestamp='2008-01-16'
  
  # This file is (in principle) common to ALL GNU software.
  # The presence of a machine in this file suggests that SOME GNU software
@@@ -71,8 -72,8 +72,8 @@@ Report bugs and patches to <config-patc
  version="\
  GNU config.sub ($timestamp)
  
--Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
--Free Software Foundation, Inc.
++Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
++2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
  
  This is free software; see the source for copying conditions.  There is NO
  warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@@ -119,8 -120,9 +120,9 @@@ esa
  # Here we must recognize all the valid KERNEL-OS combinations.
  maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
  case $maybe_os in
-   nto-qnx* | linux-gnu* | linux-dietlibc | linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | \
-   kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | storm-chaos* | os2-emx* | rtmk-nova*)
+   nto-qnx* | linux-gnu* | linux-dietlibc | linux-newlib* | linux-uclibc* | \
+   uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | \
+   storm-chaos* | os2-emx* | rtmk-nova*)
      os=-$maybe_os
      basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
      ;;
@@@ -171,6 -173,10 +173,10 @@@ case $os i
        -hiux*)
                os=-hiuxwe2
                ;;
+       -sco6)
+               os=-sco5v6
+               basic_machine=`echo $1 | sed -e 's/86-.*/86-pc/'`
+               ;;
        -sco5)
                os=-sco3.2v5
                basic_machine=`echo $1 | sed -e 's/86-.*/86-pc/'`
                # Don't forget version if it is 3.2v4 or newer.
                basic_machine=`echo $1 | sed -e 's/86-.*/86-pc/'`
                ;;
+       -sco5v6*)
+               # Don't forget version if it is 3.2v4 or newer.
+               basic_machine=`echo $1 | sed -e 's/86-.*/86-pc/'`
+               ;;
        -sco*)
                os=-sco3.2v2
                basic_machine=`echo $1 | sed -e 's/86-.*/86-pc/'`
@@@ -231,15 -241,16 +241,16 @@@ case $basic_machine i
        | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
        | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
        | am33_2.0 \
-       | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
+       | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
        | bfin \
        | c4x | clipper \
        | d10v | d30v | dlx | dsp16xx \
--      | fr30 | frv \
++      | fido | fr30 | frv \
        | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
        | i370 | i860 | i960 | ia64 \
        | ip2k | iq2000 \
-       | m32r | m32rle | m68000 | m68k | m88k | maxq | mcore \
+       | m32c | m32r | m32rle | m68000 | m68k | m88k \
 -      | maxq | mb | microblaze | mcore \
++      | maxq | mb | microblaze | mcore | mep \
        | mips | mipsbe | mipseb | mipsel | mipsle \
        | mips16 \
        | mips64 | mips64el \
        | mipsisa64sr71k | mipsisa64sr71kel \
        | mipstx39 | mipstx39el \
        | mn10200 | mn10300 \
-       | ms1 \
+       | mt \
        | msp430 \
+       | nios | nios2 \
        | ns16k | ns32k \
        | or32 \
        | pdp10 | pdp11 | pj | pjl \
        | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
        | pyramid \
-       | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
+       | score \
+       | sh | sh[1234] | sh[24]a | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
        | sh64 | sh64le \
-       | sparc | sparc64 | sparc64b | sparc86x | sparclet | sparclite \
-       | sparcv8 | sparcv9 | sparcv9b \
-       | strongarm \
+       | sparc | sparc64 | sparc64b | sparc64v | sparc86x | sparclet | sparclite \
+       | sparcv8 | sparcv9 | sparcv9b | sparcv9v \
+       | spu | strongarm \
        | tahoe | thumb | tic4x | tic80 | tron \
        | v850 | v850e \
        | we32k \
-       | x86 | xscale | xscalee[bl] | xstormy16 | xtensa \
+       | x86 | xc16x | xscale | xscalee[bl] | xstormy16 | xtensa \
        | z8k)
                basic_machine=$basic_machine-unknown
                ;;
-       m32c)
-               basic_machine=$basic_machine-unknown
-               ;;
        m6811 | m68hc11 | m6812 | m68hc12)
                # Motorola 68HC11/12.
                basic_machine=$basic_machine-unknown
                ;;
        m88110 | m680[12346]0 | m683?2 | m68360 | m5200 | v70 | w65 | z8k)
                ;;
+       ms1)
+               basic_machine=mt-unknown
+               ;;
  
        # We use `pc' rather than `unknown'
        # because (1) that's what they normally are, and
        | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
        | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
        | arm-*  | armbe-* | armle-* | armeb-* | armv*-* \
-       | avr-* \
+       | avr-* | avr32-* \
        | bfin-* | bs2000-* \
        | c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
        | clipper-* | craynv-* | cydra-* \
        | d10v-* | d30v-* | dlx-* \
        | elxsi-* \
--      | f30[01]-* | f700-* | fr30-* | frv-* | fx80-* \
++      | f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
        | h8300-* | h8500-* \
        | hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
        | i*86-* | i860-* | i960-* | ia64-* \
        | ip2k-* | iq2000-* \
-       | m32r-* | m32rle-* \
+       | m32c-* | m32r-* | m32rle-* \
        | m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
        | m88110-* | m88k-* | maxq-* | mcore-* \
        | mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
        | mipsisa64sr71k-* | mipsisa64sr71kel-* \
        | mipstx39-* | mipstx39el-* \
        | mmix-* \
-       | ms1-* \
+       | mt-* \
        | msp430-* \
+       | nios-* | nios2-* \
        | none-* | np1-* | ns16k-* | ns32k-* \
        | orion-* \
        | pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
        | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
        | pyramid-* \
        | romp-* | rs6000-* \
-       | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | shbe-* \
+       | sh-* | sh[1234]-* | sh[24]a-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
        | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
-       | sparc-* | sparc64-* | sparc64b-* | sparc86x-* | sparclet-* \
+       | sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
        | sparclite-* \
-       | sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
+       | sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | strongarm-* | sv1-* | sx?-* \
        | tahoe-* | thumb-* \
        | tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
        | tron-* \
        | v850-* | v850e-* | vax-* \
        | we32k-* \
-       | x86-* | x86_64-* | xps100-* | xscale-* | xscalee[bl]-* \
-       | xstormy16-* | xtensa-* \
+       | x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
 -      | xstormy16-* | xtensa-* \
++      | xstormy16-* | xtensa*-* \
        | ymp-* \
        | z8k-*)
                ;;
-       m32c-*)
++      # Recognize the basic CPU types without company name, with glob match.
++      xtensa*)
++              basic_machine=$basic_machine-unknown
 +              ;;
        # Recognize the various machine names and aliases which stand
        # for a CPU type and a company and sometimes even an OS.
        386bsd)
                basic_machine=ns32k-sequent
                os=-dynix
                ;;
++      blackfin)
++              basic_machine=bfin-unknown
++              os=-linux
++              ;;
++      blackfin-*)
++              basic_machine=bfin-`echo $basic_machine | sed 's/^[^-]*-//'`
++              os=-linux
++              ;;
        c90)
                basic_machine=c90-cray
                os=-unicos
                basic_machine=craynv-cray
                os=-unicosmp
                ;;
--      cr16c)
--              basic_machine=cr16c-unknown
++      cr16)
++              basic_machine=cr16-unknown
                os=-elf
                ;;
        crds | unos)
                basic_machine=m68k-isi
                os=-sysv
                ;;
++      m68knommu)
++              basic_machine=m68k-unknown
++              os=-linux
++              ;;
++      m68knommu-*)
++              basic_machine=m68k-`echo $basic_machine | sed 's/^[^-]*-//'`
++              os=-linux
++              ;;
        m88k-omron*)
                basic_machine=m88k-omron
                ;;
                basic_machine=i386-pc
                os=-mingw32
                ;;
++      mingw32ce)
++              basic_machine=arm-unknown
++              os=-mingw32ce
++              ;;
        miniframe)
                basic_machine=m68000-convergent
                ;;
                basic_machine=i386-pc
                os=-msdos
                ;;
+       ms1-*)
+               basic_machine=`echo $basic_machine | sed -e 's/ms1-/mt-/'`
+               ;;
        mvs)
                basic_machine=i370-ibm
                os=-mvs
                basic_machine=i860-intel
                os=-osf
                ;;
++      parisc)
++              basic_machine=hppa-unknown
++              os=-linux
++              ;;
++      parisc-*)
++              basic_machine=hppa-`echo $basic_machine | sed 's/^[^-]*-//'`
++              os=-linux
++              ;;
        pbd)
                basic_machine=sparc-tti
                ;;
        pc532 | pc532-*)
                basic_machine=ns32k-pc532
                ;;
+       pc98)
+               basic_machine=i386-pc
+               ;;
+       pc98-*)
+               basic_machine=i386-`echo $basic_machine | sed 's/^[^-]*-//'`
+               ;;
        pentium | p5 | k5 | k6 | nexgen | viac3)
                basic_machine=i586-pc
                ;;
                basic_machine=i586-unknown
                os=-pw32
                ;;
+       rdos)
+               basic_machine=i386-pc
+               os=-rdos
+               ;;
        rom68k)
                basic_machine=m68k-rom68k
                os=-coff
        sb1el)
                basic_machine=mipsisa64sb1el-unknown
                ;;
+       sde)
+               basic_machine=mipsisa32-sde
+               os=-elf
+               ;;
        sei)
                basic_machine=mips-sei
                os=-seiux
                basic_machine=sh-hitachi
                os=-hms
                ;;
+       sh5el)
+               basic_machine=sh5le-unknown
+               ;;
        sh64)
                basic_machine=sh64-unknown
                ;;
                basic_machine=tic6x-unknown
                os=-coff
                ;;
++      tile*)
++              basic_machine=tile-unknown
++              os=-linux-gnu
++              ;;
        tx39)
                basic_machine=mipstx39-unknown
                ;;
        sh[1234] | sh[24]a | sh[34]eb | sh[1234]le | sh[23]ele)
                basic_machine=sh-unknown
                ;;
-       sparc | sparcv8 | sparcv9 | sparcv9b)
+       sparc | sparcv8 | sparcv9 | sparcv9b | sparcv9v)
                basic_machine=sparc-sun
                ;;
        cydra)
@@@ -1174,21 -1206,23 +1242,23 @@@ case $os i
              | -aos* \
              | -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
              | -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
-             | -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* | -openbsd* \
+             | -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* \
+             | -openbsd* | -solidbsd* \
              | -ekkobsd* | -kfreebsd* | -freebsd* | -riscix* | -lynxos* \
              | -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
              | -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
              | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
              | -chorusos* | -chorusrdb* \
              | -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
-             | -mingw32* | -linux-gnu* | -linux-uclibc* | -uxpv* | -beos* | -mpeix* | -udk* \
+             | -mingw32* | -linux-gnu* | -linux-newlib* | -linux-uclibc* \
+             | -uxpv* | -beos* | -mpeix* | -udk* \
              | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
              | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
              | -storm-chaos* | -tops10* | -tenex* | -tops20* | -its* \
              | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
              | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
              | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
-             | -skyos* | -haiku*)
 -            | -skyos* | -haiku* | -rdos* | -toppers*)
++            | -skyos* | -haiku* | -rdos* | -toppers* | -drops*)
        # Remember, each alternative MUST END IN *, to match a version number.
                ;;
        -qnx*)
  # system, and we'll never get to this point.
  
  case $basic_machine in
+         score-*)
+               os=-elf
+               ;;
+         spu-*)
+               os=-elf
+               ;;
        *-acorn)
                os=-riscix1.2
                ;;
        arm*-semi)
                os=-aout
                ;;
-     c4x-* | tic4x-*)
-         os=-coff
-         ;;
+         c4x-* | tic4x-*)
+               os=-coff
+               ;;
        # This must come before the *-dec entry.
        pdp10-*)
                os=-tops20
        m68*-cisco)
                os=-aout
                ;;
++        mep-*)
++              os=-elf
++              ;;
        mips*-cisco)
                os=-elf
                ;;
diff --combined cpmrm.1.in
index 85fb74fb244b0d025a3932311f9533dc668a3e16,9f9ed500ffcb4fa7194a43c8c2ca07ede75983dd..e8ec0310347aebd2f1799e0d11e0a9584ba00408
@@@ -4,7 -4,7 +4,7 @@@ cpmrm \- remove files on CP/M disk
  .\"}}}
  .SH SYNOPSIS \"{{{
  .ad l
 -.B cpmera
 +.B cpmrm
  .RB [ \-f
  .IR format ]
  .I image
@@@ -13,7 -13,7 +13,7 @@@
  .ad b
  .\"}}}
  .SH DESCRIPTION \"{{{
 -\fBcpmera\fP removes files from CP/M disks.
 +\fBcpmrm\fP removes files from CP/M disks.
  .\"}}}
  .SH OPTIONS \"{{{
  .IP "\fB\-f\fP \fIformat\fP"
@@@ -29,13 -29,13 +29,13 @@@ Any errors are indicated by exit code 1
  @DATADIR@/diskdefs    CP/M disk format definitions
  .\"}}}
  .SH AUTHORS \"{{{
- This program is copyright 1997, 1998, 1999, 2000, 2001 Michael Haardt
+ This program is copyright 1997\(en2007 Michael Haardt
  <michael@moria.de>.  The Windows port is copyright 2000, 2001 John Elliott
  <jce@seasip.demon.co.uk>.
  .PP
  This program is free software; you can redistribute it and/or modify
  it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
+ the Free Software Foundation; either version 3 of the License, or
  (at your option) any later version.
  .PP
  This program is distributed in the hope that it will be useful,
diff --combined debian/copyright
index 1a780ce92f1984dc3e7a56fe7aaf1831b11dd73d,0000000000000000000000000000000000000000..6a4f224fbd080b00e97e5ac3a2c77981a66c2860
mode 100644,000000..100644
--- /dev/null
@@@ -1,23 -1,0 +1,26 @@@
-   Copyright 1997, 1998, 1999, 2000, 2001 Michael Haardt <michael@moria.de>
 +This package was debianized by Bdale Garbee <bdale@gag.com> on
 +Tue, 15 Jan 2002 02:23:43 -0700.
 +
 +It was downloaded from http://www.moria.de/~michael/cpmtools/
 +
 +Upstream Author: Michael Haardt <michael@moria.de>
 +
 +Copyright:
 +
- the Free Software Foundation; version 2 dated June, 1991.
++  Copyright 1997-2007 Michael Haardt <michael@moria.de>
 +
 +  The Windows port is copyright 2000, 2001 John Elliott
 +
 +  The getopt.[ch] and getopt1.c files are
 +    Copyright (C) 1989,90,91,92,93,94,96,97,98 Free Software Foundation, Inc.
 +
++  The install.sh file is Copyright (C) 1994 X Consortium
++
 +This program is free software; you can redistribute it and/or modify
 +it under the terms of the GNU General Public License as published by
++the Free Software Foundation; either version 3 of the License, or
++(at your option) any later version.
 +
 +On Debian GNU/Linux systems, the complete text of the GNU General Public 
 +License can be found in the `/usr/share/common-licenses' directory.
 +
diff --combined diskdefs
index a607c440a42abae3753e286c69c23a8a3c0da6fd,7d8a4442a80aa6e063e78bbec89ea94efb4ec2fb..020dfbf9f3eb494b36aca22fb7a0ee22168956a4
+++ b/diskdefs
@@@ -231,20 -231,30 +231,48 @@@ diskdef p11
    tracks 160
    sectrk 18
    blocksize 2048
++<<<<<<< HEAD:diskdefs
 +  maxdir 128
 +  skew 1
 +  boottrk 1
 +  os 3
 +end
 +
 +
 +diskdef p112a
++=======
+   maxdir 256
+   skew 1
+   boottrk 2
+   os 3
+ end
+ diskdef p112-old
++>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
    seclen 512
    tracks 160
    sectrk 18
    blocksize 2048
++<<<<<<< HEAD:diskdefs
 +  maxdir 256
++=======
+   maxdir 128
++>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
    skew 1
    boottrk 1
    os 3
  end
++<<<<<<< HEAD:diskdefs
++=======
+ diskdef kpii
+   seclen 512
+   tracks 40
+   sectrk 10
+   blocksize 1024
+   maxdir 32
+   skew 0
+   boottrk 1
+   os 2.2
+ end
++>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
diff --combined fsck.cpm.1.in
index e6d429c90a3381f3d848c6d02f7632707cde66b2,068b4b9a6385e95bd21ab4fbe28e8015f1656746..e6fa5a7356c114a9008b93a6fcc0e4a8b77c904e
@@@ -38,11 -38,10 +38,11 @@@ Any errors are indicated by exit code 1
  @DATADIR@/diskdefs    CP/M disk format definitions
  .\"}}}
  .SH DIAGNOSTICS .\"{{{
 -.IP "\fIimage\fP: \fIused\fP/\fItotal\fP files (\fIn\fP.\fIn\fP% non-contiguos), \fIused\fP/\fItotal\fP blocks"
 +.IP "\fIimage\fP: \fIused\fP/\fItotal\fP files (\fIn\fP.\fIn\fP% 
 +non-contiguous), \fIused\fP/\fItotal\fP blocks"
  No inconsistencies could be found.  The number of used files actually
  is the number of used extents.  Since a file may use more than
 -one extent, this may be greather than the actual number of files, but a
 +one extent, this may be greater than the actual number of files, but a
  correct measure would not reflect how many files could still be created
  at most.  A file is considered fragmented, if sequential data blocks
  pointed to by the same extent do not have sequential block numbers.
@@@ -50,13 -49,13 +50,13 @@@ The number of used blocks includes the 
  and the directory.
  .\"}}}
  .SH AUTHORS .\"{{{
- This program is copyright 1997, 1998, 1999, 2000, 2001 Michael Haardt
+ This program is copyright 1997\(en2007 Michael Haardt
  <michael@moria.de>.  The Windows port is copyright 2000, 2001 John Elliott
  <jce@seasip.demon.co.uk>.
  .PP
  This program is free software; you can redistribute it and/or modify
  it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
+ the Free Software Foundation; either version 3 of the License, or
  (at your option) any later version.
  .PP
  This program is distributed in the hope that it will be useful,