Merge branch 'upstream'
authorBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 17:47:52 +0000 (11:47 -0600)
committerBdale Garbee <bdale@gag.com>
Thu, 5 Jun 2008 17:47:52 +0000 (11:47 -0600)
Conflicts:

Makefile.in
NEWS
config.guess
config.sub
configure
configure.in
diskdefs

14 files changed:
.gbp.conf [new file with mode: 0644]
config.guess
config.sub
cpm.5.in
cpmrm.1.in
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/rules [new file with mode: 0755]
diskdefs
fsck.cpm.1.in

diff --git a/.gbp.conf b/.gbp.conf
new file mode 100644 (file)
index 0000000..f090a6c
--- /dev/null
+++ b/.gbp.conf
@@ -0,0 +1,46 @@
+# Configuration file for git-buildpackage and friends
+
+[DEFAULT]
+# the default build command:
+#builder = debuild -i\.git/ -I.git
+# the default clean command:
+#cleaner = debuild clean
+# the default branch for upstream sources:
+upstream-branch = upstream
+# the default branch for the debian patch:
+debian-branch = master
+# the default tag formats used:
+#upstream-tag = upstream/%(version)s
+#debian-tag = debian/%(version)s
+# use pristine-tar:
+pristine-tar = True
+
+# Options only affecting git-buildpackage
+[git-buildpackage]
+#upstream-branch = dfsgclean
+# uncomment this to automatically GPG sign tags
+#sign-tags = True
+# keyid to GPG sign tags with
+#keyid = 0xdeadbeef
+# push to a remote repository after a successful tag: 
+#posttag = git-push git.example.com
+# use this for more svn-buildpackage like behaviour:
+export-dir = ../build-area/cpmtools/
+#tarball-dir = ../tarballs/
+
+# Options only affecting git-import-orig
+[git-import-orig]
+#upstream-branch = newupstream
+#debian-branch = dfsgclean
+#filter = .svn
+
+# Options only affecting git-import-dsc
+[git-import-dsc]
+#upstream-branch = svn-upstream
+#filter = [ 'CVS', '.cvsignore' ]
+
+# Options only affecting git-dch
+[git-dch]
+#git-log = --no-merges
+#snapshot-number = snapshot + 1
+
index eeb9aef181ba679b68402ac61cbd529f13a7f895..f32079abda668e5fc8f8de6f226e7b26384e8a03 100755 (executable)
@@ -1,10 +1,10 @@
 #! /bin/sh
 # Attempt to guess a canonical system name.
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
-#   Inc.
+#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
+#   Free Software Foundation, Inc.
 
-timestamp='2006-11-15'
+timestamp='2008-01-23'
 
 # This file is free software; you can redistribute it and/or modify it
 # under the terms of the GNU General Public License as published by
@@ -56,8 +56,8 @@ version="\
 GNU config.guess ($timestamp)
 
 Originally written by Per Bothner.
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
-Free Software Foundation, Inc.
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
+2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
 
 This is free software; see the source for copying conditions.  There is NO
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@ -330,7 +330,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
     sun4*:SunOS:5.*:* | tadpole*:SunOS:5.*:*)
        echo sparc-sun-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
        exit ;;
-    i86pc:SunOS:5.*:*)
+    i86pc:SunOS:5.*:* | i86xen:SunOS:5.*:*)
        echo i386-pc-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
        exit ;;
     sun4*:SunOS:6*:*)
@@ -532,7 +532,7 @@ EOF
                echo rs6000-ibm-aix3.2
        fi
        exit ;;
-    *:AIX:*:[45])
+    *:AIX:*:[456])
        IBM_CPU_ID=`/usr/sbin/lsdev -C -c processor -S available | sed 1q | awk '{ print $1 }'`
        if /usr/sbin/lsattr -El ${IBM_CPU_ID} | grep ' POWER' >/dev/null 2>&1; then
                IBM_ARCH=rs6000
@@ -781,7 +781,7 @@ EOF
     i*:CYGWIN*:*)
        echo ${UNAME_MACHINE}-pc-cygwin
        exit ;;
-    i*:MINGW*:*)
+    *:MINGW*:*)
        echo ${UNAME_MACHINE}-pc-mingw32
        exit ;;
     i*:windows32*:*)
@@ -791,12 +791,18 @@ EOF
     i*:PW*:*)
        echo ${UNAME_MACHINE}-pc-pw32
        exit ;;
-    x86:Interix*:[3456]*)
-       echo i586-pc-interix${UNAME_RELEASE}
-       exit ;;
-    EM64T:Interix*:[3456]* | authenticamd:Interix*:[3456]*)
-       echo x86_64-unknown-interix${UNAME_RELEASE}
-       exit ;;
+    *:Interix*:[3456]*)
+       case ${UNAME_MACHINE} in
+           x86)
+               echo i586-pc-interix${UNAME_RELEASE}
+               exit ;;
+           EM64T | authenticamd)
+               echo x86_64-unknown-interix${UNAME_RELEASE}
+               exit ;;
+           IA64)
+               echo ia64-unknown-interix${UNAME_RELEASE}
+               exit ;;
+       esac ;;
     [345]86:Windows_95:* | [345]86:Windows_98:* | [345]86:Windows_NT:*)
        echo i${UNAME_MACHINE}-pc-mks
        exit ;;
@@ -830,7 +836,14 @@ EOF
        echo ${UNAME_MACHINE}-pc-minix
        exit ;;
     arm*:Linux:*:*)
-       echo ${UNAME_MACHINE}-unknown-linux-gnu
+       eval $set_cc_for_build
+       if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
+           | grep -q __ARM_EABI__
+       then
+           echo ${UNAME_MACHINE}-unknown-linux-gnu
+       else
+           echo ${UNAME_MACHINE}-unknown-linux-gnueabi
+       fi
        exit ;;
     avr32*:Linux:*:*)
        echo ${UNAME_MACHINE}-unknown-linux-gnu
@@ -951,6 +964,9 @@ EOF
     x86_64:Linux:*:*)
        echo x86_64-unknown-linux-gnu
        exit ;;
+    xtensa*:Linux:*:*)
+       echo ${UNAME_MACHINE}-unknown-linux-gnu
+       exit ;;
     i*86:Linux:*:*)
        # The BFD linker knows what the default object file format is, so
        # first see if it will tell us. cd to the root directory to prevent
@@ -1209,9 +1225,15 @@ EOF
     SX-6:SUPER-UX:*:*)
        echo sx6-nec-superux${UNAME_RELEASE}
        exit ;;
+    SX-7:SUPER-UX:*:*)
+       echo sx7-nec-superux${UNAME_RELEASE}
+       exit ;;
     SX-8:SUPER-UX:*:*)
        echo sx8-nec-superux${UNAME_RELEASE}
        exit ;;
+    SX-8R:SUPER-UX:*:*)
+       echo sx8r-nec-superux${UNAME_RELEASE}
+       exit ;;
     Power*:Rhapsody:*:*)
        echo powerpc-apple-rhapsody${UNAME_RELEASE}
        exit ;;
@@ -1462,9 +1484,9 @@ This script, last modified $timestamp, has failed to recognize
 the operating system you are using. It is advised that you
 download the most up to date version of the config scripts from
 
-  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
+  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
 and
-  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
+  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD
 
 If the version you run ($0) is already up to date, please
 send the following data and any information you think might be
index 7ccee7305792d4cb9ea0a088c371db3ac3884777..6759825a5b7fcf64476b4398dc0e30b3090b925c 100755 (executable)
@@ -1,10 +1,10 @@
 #! /bin/sh
 # Configuration validation subroutine script.
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-#   2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation,
-#   Inc.
+#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
+#   Free Software Foundation, Inc.
 
-timestamp='2006-11-07'
+timestamp='2008-01-16'
 
 # This file is (in principle) common to ALL GNU software.
 # The presence of a machine in this file suggests that SOME GNU software
@@ -72,8 +72,8 @@ Report bugs and patches to <config-patches@gnu.org>."
 version="\
 GNU config.sub ($timestamp)
 
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
-Free Software Foundation, Inc.
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
+2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
 
 This is free software; see the source for copying conditions.  There is NO
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
@@ -245,12 +245,12 @@ case $basic_machine in
        | bfin \
        | c4x | clipper \
        | d10v | d30v | dlx | dsp16xx \
-       | fr30 | frv \
+       | fido | fr30 | frv \
        | h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
        | i370 | i860 | i960 | ia64 \
        | ip2k | iq2000 \
        | m32c | m32r | m32rle | m68000 | m68k | m88k \
-       | maxq | mb | microblaze | mcore \
+       | maxq | mb | microblaze | mcore | mep \
        | mips | mipsbe | mipseb | mipsel | mipsle \
        | mips16 \
        | mips64 | mips64el \
@@ -324,7 +324,7 @@ case $basic_machine in
        | clipper-* | craynv-* | cydra-* \
        | d10v-* | d30v-* | dlx-* \
        | elxsi-* \
-       | f30[01]-* | f700-* | fr30-* | frv-* | fx80-* \
+       | f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
        | h8300-* | h8500-* \
        | hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
        | i*86-* | i860-* | i960-* | ia64-* \
@@ -369,10 +369,14 @@ case $basic_machine in
        | v850-* | v850e-* | vax-* \
        | we32k-* \
        | x86-* | x86_64-* | xc16x-* | xps100-* | xscale-* | xscalee[bl]-* \
-       | xstormy16-* | xtensa-* \
+       | xstormy16-* | xtensa*-* \
        | ymp-* \
        | z8k-*)
                ;;
+       # Recognize the basic CPU types without company name, with glob match.
+       xtensa*)
+               basic_machine=$basic_machine-unknown
+               ;;
        # Recognize the various machine names and aliases which stand
        # for a CPU type and a company and sometimes even an OS.
        386bsd)
@@ -443,6 +447,14 @@ case $basic_machine in
                basic_machine=ns32k-sequent
                os=-dynix
                ;;
+       blackfin)
+               basic_machine=bfin-unknown
+               os=-linux
+               ;;
+       blackfin-*)
+               basic_machine=bfin-`echo $basic_machine | sed 's/^[^-]*-//'`
+               os=-linux
+               ;;
        c90)
                basic_machine=c90-cray
                os=-unicos
@@ -475,8 +487,8 @@ case $basic_machine in
                basic_machine=craynv-cray
                os=-unicosmp
                ;;
-       cr16c)
-               basic_machine=cr16c-unknown
+       cr16)
+               basic_machine=cr16-unknown
                os=-elf
                ;;
        crds | unos)
@@ -668,6 +680,14 @@ case $basic_machine in
                basic_machine=m68k-isi
                os=-sysv
                ;;
+       m68knommu)
+               basic_machine=m68k-unknown
+               os=-linux
+               ;;
+       m68knommu-*)
+               basic_machine=m68k-`echo $basic_machine | sed 's/^[^-]*-//'`
+               os=-linux
+               ;;
        m88k-omron*)
                basic_machine=m88k-omron
                ;;
@@ -683,6 +703,10 @@ case $basic_machine in
                basic_machine=i386-pc
                os=-mingw32
                ;;
+       mingw32ce)
+               basic_machine=arm-unknown
+               os=-mingw32ce
+               ;;
        miniframe)
                basic_machine=m68000-convergent
                ;;
@@ -809,6 +833,14 @@ case $basic_machine in
                basic_machine=i860-intel
                os=-osf
                ;;
+       parisc)
+               basic_machine=hppa-unknown
+               os=-linux
+               ;;
+       parisc-*)
+               basic_machine=hppa-`echo $basic_machine | sed 's/^[^-]*-//'`
+               os=-linux
+               ;;
        pbd)
                basic_machine=sparc-tti
                ;;
@@ -1017,6 +1049,10 @@ case $basic_machine in
                basic_machine=tic6x-unknown
                os=-coff
                ;;
+       tile*)
+               basic_machine=tile-unknown
+               os=-linux-gnu
+               ;;
        tx39)
                basic_machine=mipstx39-unknown
                ;;
@@ -1222,7 +1258,7 @@ case $os in
              | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
              | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
              | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
-             | -skyos* | -haiku* | -rdos* | -toppers*)
+             | -skyos* | -haiku* | -rdos* | -toppers* | -drops*)
        # Remember, each alternative MUST END IN *, to match a version number.
                ;;
        -qnx*)
@@ -1417,6 +1453,9 @@ case $basic_machine in
        m68*-cisco)
                os=-aout
                ;;
+        mep-*)
+               os=-elf
+               ;;
        mips*-cisco)
                os=-elf
                ;;
index 89371f6c0892fdcffd15c8aab45dcc52eb3aafbd..5e559c71e234d13ae205df7b13028ca195e54dd6 100644 (file)
--- a/cpm.5.in
+++ b/cpm.5.in
@@ -88,7 +88,7 @@ meaning:
 .sp
 F0: requires set wheel byte (Backgrounder II)
 .br
-F1: public file (P2DOS, ZSDOS), forground-only command (Backgrounder II)
+F1: public file (P2DOS, ZSDOS), foreground-only command (Backgrounder II)
 .br
 F2: date stamp (ZSDOS), background-only commands (Backgrounder II)
 .br
@@ -138,7 +138,7 @@ Bc stores the number of bytes in the last used record.  The value 0 means
 Al is interpreted as 16 byte-values, otherwise as 8 double-byte-values.
 A block pointer of 0 marks a hole in the file.  If a hole
 covers the range of a full extent, the extent will not be allocated.  In particular,
-the first extent of a file does not neccessarily have extent number 0.
+the first extent of a file does not necessarily have extent number 0.
 A file may not share blocks with other files, as its blocks would be freed
 if the other files is erased without a following disk system reset.  CP/M returns
 EOF when it reaches a hole, whereas UNIX returns zero-value bytes, which makes
index 9f9ed500ffcb4fa7194a43c8c2ca07ede75983dd..e8ec0310347aebd2f1799e0d11e0a9584ba00408 100644 (file)
@@ -4,7 +4,7 @@ cpmrm \- remove files on CP/M disks
 .\"}}}
 .SH SYNOPSIS \"{{{
 .ad l
-.B cpmera
+.B cpmrm
 .RB [ \-f
 .IR format ]
 .I image
@@ -13,7 +13,7 @@ cpmrm \- remove files on CP/M disks
 .ad b
 .\"}}}
 .SH DESCRIPTION \"{{{
-\fBcpmera\fP removes files from CP/M disks.
+\fBcpmrm\fP removes files from CP/M disks.
 .\"}}}
 .SH OPTIONS \"{{{
 .IP "\fB\-f\fP \fIformat\fP"
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..85f1534
--- /dev/null
@@ -0,0 +1,52 @@
+cpmtools (2.5-1) unstable; urgency=low
+
+  * new upstream version, closes: #345395
+  * freshen policy and debhelper version
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 30 Dec 2005 21:20:27 -0700
+
+cpmtools (2.4-3) unstable; urgency=low
+
+  * patch from A Costa for fsck man page typos, closes: #327918
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 28 Sep 2005 00:53:52 -0600
+
+cpmtools (2.4-2) unstable; urgency=low
+
+  * accept patches from A Costa for man page typos, closes: #305635, #305636
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 30 Apr 2005 00:08:30 -0600
+
+cpmtools (2.4-1) unstable; urgency=low
+
+  * new upstream version, closes: #275979
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 11 Oct 2004 10:58:22 -0600
+
+cpmtools (2.1-2) unstable; urgency=low
+
+  * fix thinko in rules file handling of autotools-dev support, closes: #241585
+
+ -- Bdale Garbee <bdale@gag.com>  Thu,  1 Apr 2004 21:41:39 -0700
+
+cpmtools (2.1-1) unstable; urgency=low
+
+  * new upstream version, closes: #239681
+  * deliver cpm.5 manpage in binary package, closes: #239680
+  * add autotools-dev as a build dep to keep config.* fresh
+  * move diskdefs into /etc/cpmtools as a conffile, closes: #239677
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 26 Mar 2004 11:48:01 -0700
+
+cpmtools (2.0-2) unstable; urgency=low
+
+  * add build-depend on libncurses-dev so that fsed builds, closes: #129679
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 18 Jan 2002 11:50:16 -0700
+
+cpmtools (2.0-1) unstable; urgency=low
+
+  * Initial Release.
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 15 Jan 2002 02:23:43 -0700
+
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..7ed6ff8
--- /dev/null
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..ba1a5b3
--- /dev/null
@@ -0,0 +1,15 @@
+Source: cpmtools
+Section: otherosfs
+Priority: optional
+Maintainer: Bdale Garbee <bdale@gag.com>
+Build-Depends: debhelper (>> 5), libncurses-dev, autotools-dev
+Standards-Version: 3.6.2.2
+
+Package: cpmtools
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Tools to access CP/M file systems
+ This package allows to access CP/M file systems similar to the well-known 
+ mtools package, which accesses MSDOS file systems.
+ .
+ All CP/M file system features are supported.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..6a4f224
--- /dev/null
@@ -0,0 +1,26 @@
+This package was debianized by Bdale Garbee <bdale@gag.com> on
+Tue, 15 Jan 2002 02:23:43 -0700.
+
+It was downloaded from http://www.moria.de/~michael/cpmtools/
+
+Upstream Author: Michael Haardt <michael@moria.de>
+
+Copyright:
+
+  Copyright 1997-2007 Michael Haardt <michael@moria.de>
+
+  The Windows port is copyright 2000, 2001 John Elliott
+
+  The getopt.[ch] and getopt1.c files are
+    Copyright (C) 1989,90,91,92,93,94,96,97,98 Free Software Foundation, Inc.
+
+  The install.sh file is Copyright (C) 1994 X Consortium
+
+This program is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 3 of the License, or
+(at your option) any later version.
+
+On Debian GNU/Linux systems, the complete text of the GNU General Public 
+License can be found in the `/usr/share/common-licenses' directory.
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..bb4a396
--- /dev/null
@@ -0,0 +1,4 @@
+etc/cpmtools
+usr/bin
+usr/share/man/man1
+usr/share/man/man5
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..50bd824
--- /dev/null
@@ -0,0 +1,2 @@
+NEWS
+README
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..7b17023
--- /dev/null
@@ -0,0 +1,65 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       ./configure --prefix=/usr --mandir=\$${prefix}/share/man \
+               --datadir=/etc/cpmtools
+       touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+       $(MAKE)
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       -$(MAKE) distclean
+
+       -test -r /usr/share/misc/config.sub && \
+               cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && \
+               cp -f /usr/share/misc/config.guess config.guess
+
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+       $(MAKE) install prefix=$(CURDIR)/debian/cpmtools/usr 
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installexamples
+       dh_installmenu
+       dh_installcron
+       dh_installman
+       dh_installinfo
+       dh_installchangelogs 
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
index 7d8a4442a80aa6e063e78bbec89ea94efb4ec2fb..020dfbf9f3eb494b36aca22fb7a0ee22168956a4 100644 (file)
--- a/diskdefs
+++ b/diskdefs
@@ -231,6 +231,16 @@ diskdef p112
   tracks 160
   sectrk 18
   blocksize 2048
+<<<<<<< HEAD:diskdefs
+  maxdir 128
+  skew 1
+  boottrk 1
+  os 3
+end
+
+
+diskdef p112a
+=======
   maxdir 256
   skew 1
   boottrk 2
@@ -238,15 +248,22 @@ diskdef p112
 end
 
 diskdef p112-old
+>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
   seclen 512
   tracks 160
   sectrk 18
   blocksize 2048
+<<<<<<< HEAD:diskdefs
+  maxdir 256
+=======
   maxdir 128
+>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
   skew 1
   boottrk 1
   os 3
 end
+<<<<<<< HEAD:diskdefs
+=======
 
 diskdef kpii
   seclen 512
@@ -258,3 +275,4 @@ diskdef kpii
   boottrk 1
   os 2.2
 end
+>>>>>>> 224b4e6d27a3af235500d9d8028ddbd3a60af7ed:diskdefs
index 068b4b9a6385e95bd21ab4fbe28e8015f1656746..e6fa5a7356c114a9008b93a6fcc0e4a8b77c904e 100644 (file)
@@ -38,10 +38,11 @@ Any errors are indicated by exit code 1.
 @DATADIR@/diskdefs     CP/M disk format definitions
 .\"}}}
 .SH DIAGNOSTICS .\"{{{
-.IP "\fIimage\fP: \fIused\fP/\fItotal\fP files (\fIn\fP.\fIn\fP% non-contiguos), \fIused\fP/\fItotal\fP blocks"
+.IP "\fIimage\fP: \fIused\fP/\fItotal\fP files (\fIn\fP.\fIn\fP% 
+non-contiguous), \fIused\fP/\fItotal\fP blocks"
 No inconsistencies could be found.  The number of used files actually
 is the number of used extents.  Since a file may use more than
-one extent, this may be greather than the actual number of files, but a
+one extent, this may be greater than the actual number of files, but a
 correct measure would not reflect how many files could still be created
 at most.  A file is considered fragmented, if sequential data blocks
 pointed to by the same extent do not have sequential block numbers.