altos/test: Compute and plot tilt based on GPS track
[fw/altos] / debian / rules
index 83f3a53f76f04744f5d71ce45ec74145e5ba5b1d..122a0fed2349bfcc7cbe9895e8fe9b095c730888 100755 (executable)
@@ -8,12 +8,12 @@ DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; f
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
        echo $(DEB_VERSION)
-       git-dch --release --new-version=$(DEB_VERSION)
+       git-dch --release --new-version=$(DEB_VERSION) --multimaint-merge
        git log > ChangeLog
        git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
-       git tag debian/$(DEB_VERSION)
-       git push --tags origin master
+#      git tag debian/$(DEB_VERSION)
+#      git push --tags origin master
 
 configure: configure-stamp
 configure-stamp:
@@ -21,11 +21,13 @@ configure-stamp:
        ./autogen.sh --prefix=/usr
        touch configure-stamp
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: configure-stamp  
        dh_testdir
-       $(MAKE) VERSION=$(PKG_VERSION)
+       $(MAKE)
        (cd doc ; $(MAKE))
        touch $@
 
@@ -43,6 +45,7 @@ install: build
        dh_installdirs
 
        $(MAKE) DESTDIR=$(CURDIR)/debian/altos install
+       sed -i "/dependency_libs/ s/'.*'/''/" `find debian/altos/usr/lib/altos/ -name '*.la'`
 
 binary-indep: install