f0fe45faf59d3c8d746a629ed72d9b46195295da
[fw/altos] / contrib / arch-linux / PKGBUILD-git.altos
1 # Contributor: Bob Finch <w9ya@qrpqrci.net>
2 pkgname=altos-git
3 pkgver=VERSION
4 pkgrel=1
5 pkgdesc="Software solutions for high powered rocketry avionics"
6 arch=('i686' 'x86_64')
7 url="http://www.altusmetrum.org/AltOS/"
8 license=('GPL')
9 depends=('openssl>=1.0.0' 'libusb-BETA' 'plplot-svn' 'sdcc' 'nickle' 'flite' 'kernel26>=2.6.33')
10 makedepends=('git')
11 optdepends=('uucp: cu is included and is a bare boned terminal to serial program'
12             'cutemon: gui-based minimal terminal to serial program'
13             'google-earth: useful for viewing the kml files of the flight path'
14             'docbook-xsl: for making an html doc file from the xsl source'
15             'fop: for making a pdf doc file from the xsl source')
16 source=(altos.desktop)
17 md5sums=('7308c5b015991046b195d1a2c0987004')
18
19 _gitroot="git://git.gag.com/fw/altos"
20 _gitname="altos"
21
22 build() {
23   cd "$srcdir"
24 #  msg "Connecting to GIT server...."
25
26   if [ -d $_gitname ] ; then
27     cd $_gitname && git pull origin
28 #    msg "The local files are updated."
29   else
30     git clone $_gitroot
31   fi
32
33 #  msg "GIT checkout done or server timeout"
34 #  msg "Starting make..."
35
36   rm -rf "$srcdir/$_gitname-build"
37   git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
38   cd "$srcdir/$_gitname-build"
39
40   #
41   # BUILD HERE
42   #
43
44   ./autogen.sh
45   ./configure --prefix=/usr
46   make || return 1
47   make DESTDIR="$pkgdir/" install
48   
49   mkdir -p $startdir/pkg/usr/share/pixmaps
50   mkdir -p $startdir/pkg/usr/share/applications
51   install -m644 debian/*.xpm $startdir/pkg/usr/share/pixmaps
52   install -m644 ../*.desktop $startdir/pkg/usr/share/applications
53