fix for LSB compliance
authorBdale Garbee <bdale@gag.com>
Thu, 17 Feb 2011 13:44:41 +0000 (06:44 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 17 Feb 2011 13:44:41 +0000 (06:44 -0700)
debian/changelog
tar.c

index 849abaeb2d8af72c1ab50ad47889a2ff2ba9d5ba..0a00ed40f1513747fcb9d7276c856d3abf7c23d6 100644 (file)
@@ -1,8 +1,11 @@
-pax (1:20090728-2) UNRELEASED; urgency=low
+pax (1:20090728-2) unstable; urgency=low
 
+  * update CFLAGS to prevent pax displaying file sizes 4*2^30 too large,
+    closes: #595482
+  * fix for tar.c to always add devmajor and devminor, closes: #609825
   * add Vcs entries to the control file
 
- -- Bdale Garbee <bdale@gag.com>  Fri, 12 Nov 2010 01:20:12 -0700
+ -- Bdale Garbee <bdale@gag.com>  Thu, 17 Feb 2011 06:39:27 -0700
 
 pax (1:20090728-1) unstable; urgency=low
 
diff --git a/tar.c b/tar.c
index 97639346d557bddd16a12bf7c7b9cedc5cceb397..2acc32fd5a3b3730b60346c05aa1e51b9861fde2 100644 (file)
--- a/tar.c
+++ b/tar.c
@@ -1079,6 +1079,15 @@ ustar_wr(ARCHD *arcn)
        strncpy(hd->uname, name_uid(arcn->sb.st_uid, 0), sizeof(hd->uname));
        strncpy(hd->gname, name_gid(arcn->sb.st_gid, 0), sizeof(hd->gname));
 
+       /*
+        * Always add devmajor and devminor
+        */
+       if (ul_oct ((u_long) MAJOR (arcn->sb.st_rdev), hd->devmajor,
+             sizeof (hd->devmajor), 3) ||
+           ul_oct ((u_long) MINOR (arcn->sb.st_rdev), hd->devminor,
+             sizeof (hd->devminor), 3))
+               goto out;
+
        /*
         * calculate and store the checksum write the header to the archive
         * return 0 tells the caller to now write the file data, 1 says no data