add DESTDIR comprehension to Makefile
authorBdale Garbee <bdale@gag.com>
Sat, 22 Oct 2011 21:20:58 +0000 (15:20 -0600)
committerBdale Garbee <bdale@gag.com>
Sat, 22 Oct 2011 21:20:58 +0000 (15:20 -0600)
Makefile

index 7a5838aef973333c96c43e603f55fa028432cd1a..be8443bec017ddc75ce8ed4b09119ce5482d7acf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -33,6 +33,6 @@ realclean: clean
        $(RM) $(PROG)
 
 install:
-       install -d -m 755 $(prefix)/bin $(prefix)/share/man/man1
-       install -s -m 755 $(PROG) $(prefix)/bin
-       install    -m 644 $(MAN)  $(prefix)/share/man/man1
+       install -d -m 755 $(DESTDIR)$(prefix)/bin $(prefix)/share/man/man1
+       install -s -m 755 $(PROG) $(DESTDIR)$(prefix)/bin
+       install    -m 644 $(MAN)  $(DESTDIR)$(prefix)/share/man/man1