move to dh, update standards version, mv git-buildpackage config to .git/
authorBdale Garbee <bdale@gag.com>
Sat, 22 Oct 2011 21:13:47 +0000 (15:13 -0600)
committerBdale Garbee <bdale@gag.com>
Sat, 22 Oct 2011 21:13:47 +0000 (15:13 -0600)
debian/changelog
debian/control
debian/gbp.conf [deleted file]
debian/rules

index 0a00ed40f1513747fcb9d7276c856d3abf7c23d6..af1d501b63fdc811fa622b8343184247102d82d0 100644 (file)
@@ -1,3 +1,9 @@
+pax (1:20090728-3) UNRELEASED; urgency=low
+
+  * switch to use of dh
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 22 Oct 2011 15:08:57 -0600
+
 pax (1:20090728-2) unstable; urgency=low
 
   * update CFLAGS to prevent pax displaying file sizes 4*2^30 too large,
index b1cb201730af8889716d80b0dda4a0828db331e9..8fa58ce236b700572769ad4db781b6d6c2d4cf39 100644 (file)
@@ -2,8 +2,8 @@ Source: pax
 Section: utils
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 5)
-Standards-Version: 3.9.1
+Build-Depends: debhelper (>= 7.0.50~)
+Standards-Version: 3.9.2
 Vcs-Git: git://git.gag.com/debian/pax
 Vcs-Browser: http://git.gag.com/?p=debian/pax
 
diff --git a/debian/gbp.conf b/debian/gbp.conf
deleted file mode 100644 (file)
index 99a0847..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Configuration file for git-buildpackage and friends
-
-[DEFAULT]
-# the default build command:
-#builder = debuild -i\.git/ -I.git
-# the default clean command:
-#cleaner = debuild clean
-# the default branch for upstream sources:
-upstream-branch = upstream
-# the default branch for the debian patch:
-debian-branch = master
-# the default tag formats used:
-#upstream-tag = upstream/%(version)s
-#debian-tag = debian/%(version)s
-# use pristine-tar:
-pristine-tar = True
-
-# Options only affecting git-buildpackage
-[git-buildpackage]
-#upstream-branch = dfsgclean
-# uncomment this to automatically GPG sign tags
-#sign-tags = True
-# keyid to GPG sign tags with
-#keyid = 0xdeadbeef
-# push to a remote repository after a successful tag: 
-posttag = git push --mirror
-# use this for more svn-buildpackage like behaviour:
-export-dir = ../build-area/pax/
-#tarball-dir = ../tarballs/
-
-# Options only affecting git-import-orig
-[git-import-orig]
-#upstream-branch = newupstream
-#debian-branch = dfsgclean
-#filter = .svn
-
-# Options only affecting git-import-dsc
-[git-import-dsc]
-#upstream-branch = svn-upstream
-#filter = [ 'CVS', '.cvsignore' ]
-
-# Options only affecting git-dch
-[git-dch]
-#git-log = --no-merges
-#snapshot-number = snapshot + 1
-
index 7b9110715fb89a25ee7c05af01063f84d2a9d446..416dbc8dcd7b244a048b1ccddb31cc8a18fa3b2a 100755 (executable)
@@ -1,61 +1,12 @@
 #!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
 
-# comment this to turn off verbose mode.
 export DH_VERBOSE=1
 
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       $(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp install-stamp
-
-       [ ! -f Makefile ] || $(MAKE) realclean
-
-       dh_clean
-
-install: install-stamp
-install-stamp: build-stamp
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) prefix=`pwd`/debian/pax/usr install
-
-       touch install-stamp
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installexamples
-       dh_installmenu
-       dh_installcron
-       dh_installmanpages cpio.1 tar.1
-       dh_installchangelogs
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@