use non-native versioning, don't run prebuild target on this branch, update changelog
[fw/altos] / debian / rules
index 9f24321b6d1398f2b0e38bdfb213588795ec3cec..a4cbe2c112147f66a3078cc62f9c6dba11c207e6 100755 (executable)
@@ -3,17 +3,10 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
-DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; fi | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       echo $(DEB_VERSION)
-       git-dch --release --new-version=$(DEB_VERSION) --multimaint-merge
-       git log > ChangeLog
-       git commit -n ChangeLog debian/changelog \
-               -m "update changelogs for Debian build"
-#      git tag debian/$(DEB_VERSION)
-#      git push --tags origin master
+       echo "not frobbing changelog for official builds"
 
 configure: configure-stamp
 configure-stamp: