no longer need patch
[fw/altos] / debian / changelog
index 6ed427ff4d231a5717aeb361dd12f08d23fe0366..6f7a1bec75a3e01e40cbb69d2ab780a85b3e8eed 100644 (file)
@@ -1,3 +1,397 @@
+altos (1.9.18-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * doc: fix a typo in the staging example
+  * update Releasing with learnings from 1.9.17 release
+  * set java-version=8 in rules to enable openjdk 21 support, closes: #1052587
+  * add a paragraph about how to hook up a pressure sensor to an EasyMotor
+  * kernel: conditionalize config "report in feet" on presence of baro sensor
+  * fix product name
+  * update ChangeLog for 1.9.18 release
+
+  [ Keith Packard ]
+  * doc: Use -optimize with asciidoctorpdf
+  * micropeak: Include firmware in install bits
+  * fixup seven segment debug code
+  * altos: Use BMI088 as z-axis accel as needed
+  * altos: Initial easytimer-v2 bits
+  * altos: Build easytimer-v2 bits
+  * altos/easytimer-v2: Add logging bits
+  * altos/easytimer-v2: Update comments in flash loader ao_pins.h
+  * altos/samd21: Enable stdio for USB by default
+  * altos: Updating pyro format tried to copy entries with no value
+  * altos/easytimer-v2: Initialize logging too
+  * Fix configure tests for multi-arch libaltos
+  * altos/lpc: Adjust ADC clock from 450kHz to 4.5MHz
+  * ao-tools: Add flash utility for stm32f1x chips
+  * altos: Start work on stm32f1 support
+  * altos/stm32f1: More stm32f103 work
+  * altos/stm32f103-nucleo: Use more bits
+  * altos/stm32f1: Start work on self-flash code
+  * stm32f1: Get boot loader working
+  * altos/stm32f103-nucleo: Add boot loader
+  * altos: Add ST7565 LCD driver
+  * src/draw: Provide some useful constants
+  * altos/draw: Build demos with -O3 to catch more bugs
+  * altos/draw: Skip line adjustment for vertical/horizontal
+  * altos/draw: Have each font declare ao_glyph_temp as .comm
+  * altos/driver: Document setting for AO_ST7565_BIAS
+  * altos/stm32f1: Add DMA and SPI drivers
+  * altos/stm32f103-nucleo: Drive a screen too
+  * altos/stm32f103-nucleo: Draw more of the LCO demo screen
+  * altos: Clean up st7565 LCD driver
+  * altos: Fix up stm32f103-nucleo 'lco' demo mode
+  * altos/stm32f1: Add more IP block drivers
+  * drivers: Add real i2c support to mmc5983
+  * altos/easymega-v3.0: Switch to STM32F103
+  * altos/telelco-v3: Create initial flash loader setup
+  * altos/telelco-v3: Move USB pullup from PA9 to PA10
+  * altos/stm32f1: Add ao_fast_timer.c
+  * altos: Build in 'draw' directory first
+  * altos: Add initial TeleLCO-v3 bits
+  * altos/stm32f1: Add eeprom emulation using flash
+  * altos/telelco-v3.0: Use eeprom emulation for config storage
+  * altos/telelco-v3.0: Add some real drawing stuff
+  * altos: Move ao_adc_single.h API header to kernel/
+  * altos/stm32f1: Add ao_adc_single support
+  * altos/telelco-v3.0: Add ao_adc_single usage to get battery voltage
+  * altos/telelco-v3.0: Fix up search UI
+  * altos/telelco*: Make LCO voltage display work on 2.0 and 3.0
+  * altos/stm32f1: Support beeper on tim3
+  * altos/stm32f1: Set PLLXTPRE value
+  * altos/stm32f1: Add STM_RCC_CFGR_PLLXTPRE_MASK value
+  * altos/telelco-v3.0: Add USB pull up
+  * altos/stm32f1: Turn on ADC during initialization sequence
+  * altos/stm32f1: Poke the ADC harder to get it to sample
+  * altos/stm32f1: Allow PA6 to be left alone in the SPI code
+  * altos/telelco-v3.0: Don't connect PA6 to SPI
+  * altos/telelco-v3.0: Battery voltage is on PA2
+  * altos/stm32f1: Support timers 2,3,4 for fast timer
+  * altos/telelco-v3.0: Use timer 2 for fast timer
+  * src/stm32f1: Disable extra JTAG pins in ao_clock_init
+  * switch to mode 3 for LCD
+  * stm32f1: make spi speed per-bus
+  * altos: Add SPI bus parameter to ao_spi_speed
+  * altos: Add wiring docs to st-7565 header
+  * altos: Fix pretend pad range for TeleLCO
+  * telelco-v3.0: Minor setup fixes
+  * altos: Build TeleLCO v3.0 bits by default
+  * altos/telelco-v3.0: Add contrast setting
+  * altos: Bump ST7565 speed to 20MHz
+  * altos/telelco-v3.0: Configure SPI GPIO pins to 50MHz
+  * altos/stm32f1: For some reason the DBG registers aren't always available
+  * altos: Add support for backlight control in ao_lco_bits
+  * altos/telelco-v3.0: Control LCD backlight with PWM
+  * telelco-v3.0: Add info page
+  * altos/telelco-v3: Add logo to 'info' page
+  * altos/draw: Add ao_text_width
+  * altos/telelco: Update backlight/contrast display upon change
+  * altos/st7565: Diff image during update
+  * altos/telelco-v3.0: Show backlight/contrast value as percent
+  * altos/stm32f1: Set beeper pin to 0 while off
+  * altos/telelco: Add per-box RSSI display screen
+  * altos/telelco: Add RSSI display to older devices
+  * altos/st7565: Set default contrast to 13
+  * altos/telelco-v3: Minor UI tweaks
+  * altos/easytimer-v2: Fix up ao_pins.h
+  * altoslib: Add EasyTimer-v2 support
+  * altos/easytimer-v2: Set default log size to 192kB
+  * altos/easytimer-v2: Fix product name
+  * altosui: Make accel cal dialog say 'beeper' instead of 'antenna'
+  * stm32f1: Clean up some ADC definitions
+  * src/easymini-2.0: Add combined .dfu file for Seeed testing
+  * altoslib: Add EasyMega v3.0 support
+  * altos/stm32f103: Fix continuous ADC code
+  * altos: Build EasyMega v3.0 by defaul
+  * altos/easymega-v3.0: Update i2c pin usage
+  * altos/stm32f1: Grab both TX/RX DMA mutexes while doing I2C
+  * altos/easytimer-v2: Generate combined .ihx file for seeed testing
+  * altos: ao_fec_prepare using wrong value for input len
+  * altos/test: Adjust CRC error rate after FEC fix
+  * altos/test: Add FEC test for simple 'hello' message
+  * altosui: Set the beeper to 0 to disable
+  * altosui: Support gps receiver setting
+  * Add EasyTimer v2 firmware
+  * doc: Add 1.9.18 release notes
+  * Version 1.9.18
+  * Fix up fat build target
+  * altos/draw: Add 'install' target
+  * doc: Add 1.9.18 release notes
+  * Version 1.9.18
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 28 Apr 2024 19:45:15 -0600
+
+altos (1.9.17-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * have TeleGPS production script save RF cal value
+  * update Releasing based on 1.9.16 release experiences
+  * doc: fix a typo in the staging example
+  * ao-test-igniter: allow anything other than 'open' to be valid so LED tests work
+  * ao-bringup: be consistent with success text in TeleGPS test script
+  * update ChangeLog for 1.9.17 release
+
+  [ Keith Packard ]
+  * altos-mapd: Install systemd dir in arch-independent location
+  * altoslib: Support Monitor Idle for EasyMini-3
+  * altos/stm32f042: Increase interrupt stack to 256 bytes
+  * altos: Add AO_STACK_CANARY to detect stack overflows sometimes
+  * altos/stmf0: Disable ao_boot_check_pin if not in use
+  * altos: Compute igniter good/bad thresholds using 3.5V value
+  * altos: Add pyro voltage divider values to boards with them
+  * altos: Don't include ao_pyro.h into telelco code
+  * altos: Use pyro voltage to check igniters
+  * altos: Use ublox-10 mode for TM v4.0
+  * doc: Release notes for 1.9.17
+  * Version 1.9.17
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 30 Aug 2023 10:50:23 -0600
+
+altos (1.9.16-2) unstable; urgency=medium
+
+  * fix path systemd service file for mapd is deliverd to, closes: #1036022
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 14 May 2023 10:48:57 -0700
+
+altos (1.9.16-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos: Fill in more of the draw code
+  * altos/draw: Add poly fill function
+  * altos/draw: Only cover ASCII
+  * altos/draw: Make test drawing app emulate TeleLCO
+  * altos/draw: Use float for polygon coords
+  * altos/draw: Add logo
+  * altos/draw: Add more fonts
+  * altos/draw: Move font files to subdirectory
+  * altos/draw: Add monospaced font
+  * altos/draw: Convert draw test framework to modern C
+  * altos/draw: Add transforms to polygon code
+  * altos/draw: Add NotoMono font
+  * altos/draw: Rearrange sample LCO screen in draw-test
+  * altos/draw: use --gc-sections in demo program
+  * altos/draw: Mock up TeleLCO boot sequence
+  * altos/draw: Rename test app to 'lco-test'
+  * altos/draw: Add validation for line drawing
+  * altos/draw: Check for horiz/vert line when clipping
+  * altos/draw: Fix clipping far line end
+  * altos/draw: Inline span fill for polygons
+  * altos/draw: Split out draw test scaffolding from lco-test.c
+  * altos/draw: Add line test app
+  * altos/draw: Use fewer fonts in lco sample
+  * altos/draw: hand-edit 64-pixel 3/5 to avoid jank
+  * altos/draw: Add damage tracking
+  * altos/draw: Add vera sans fonts
+  * altos/draw: Use <> for include files
+  * altos/draw: Use bitstream fonts for LCO demo
+  * altos/draw: Use damage for lco demo
+  * altos: Allow ports to use type other than 'void *' for gpio block
+  * altos/lpc: Support UART on pio1_13/pio1_14
+  * altos: Add TeleGPS v3.0 support
+  * altos: Build TeleGPS v3.0 by default
+  * altos/lpc: Add support for eeprom on 2x/3x chips
+  * altos/telegps-v3.0: Use eeprom for config
+  * altos/lpc: Validate UART pin config
+  * altos/lpcxpresso: Update for 11u24 board
+  * altos/telegps-v3.0: Fix SPI bus usage
+  * altoslib: Support TeleGPS v3 monitor idle
+  * altoslib: Parse more GPS monitor data
+  * altos/drivers: Support uBlox Max 10 chips
+  * altos: Dump GPS dop/course data from 'g' command
+  * altos/telegps-v3.0: Use new MAX 10 support in uBlox driver
+  * altos: Make sure storage is setup before starting log
+  * altos/lpc: Support 6k ram targets
+  * altos/telegps-v3.0: Use all 6kB of available ram
+  * altos/telegps-v3.0: Get LED blinking when GPS locks
+  * telegps: Add unit setting to device configuration dialog
+  * altos/stmf0: Remove some incorrect defines in stm32f0.h
+  * altos/stm32f04x: Smite the OPL_LAUNCH bit to reset boot config
+  * Version 1.9.15.1
+  * doc: Add 1.9.16 release notes
+  * Add TeleGPS v3.0 firmware
+  * altosdroid: Deal with Google requiring API version 31
+  * Version 1.9.16
+
+  [ Bdale Garbee ]
+  * add production scripts for TeleGPS v3.0
+  * update TeleGPS v3.0 production script to flash correct firmware versions
+  * updte ChangeLog for 1.9.16 release
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 27 Apr 2023 23:55:05 -0600
+
+altos (1.9.15-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos: Add .gitignore for telemega v6.0
+  * altos/telemega-v6: Remove beep freq defs and use defaults
+  * altos/telemega-v6.0: bmi088 axes were wrong
+  * altoslib: Hide internals of AltosIMU
+  * altos: Fix TMega v6.0 and v5.0 IMU axes
+  * doc: Add initial 1.9.15 release notes
+  * doc: Add HW specs for TeleMega v6.0
+  * Add TeleMega v6.0 firmware to release
+  * Add TeleMetrum v4.0 firmware to releases
+  * altos/telemetrum-v4.0: Add .gitignore
+  * doc: Add TeleMetrum v4.0 to specs and 1.9.15 release notes
+  * ao-tools/ao-flash: Use 'program' instead of 'flash' for samd21
+  * Version 1.9.15
+
+  [ Bdale Garbee ]
+  * altos: add csm84clio-v0.1 firmware
+  * altos: re-number csm85clio outputs 0..49 to match schematic and silkscreen
+  * ao-bringup: turnon and test scripts for TeleMetrum v4.0 & TeleMega v6.0
+  * releasing 1.9.15
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 19 Feb 2023 18:29:00 -0700
+
+altos (1.9.14-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * drivers/cc1200: Don't disable cc1200 interrupts ever
+  * altos/telefiretwo-v0.2: Get things building again
+  * altos/drivers: Use spi duplex to fetch register values
+  * altos/drivers: Increase LCO receive timeout to 20ms
+  * doc: Release notes for 1.9.14
+  * Version 1.9.14
+
+  [ Bdale Garbee ]
+  * ChangeLog for releas 1.9.14
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 02 Feb 2023 12:55:20 -0700
+
+altos (1.9.13-2) unstable; urgency=medium
+
+  * drop the suggests on slim | gdm, it's just no useful
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 29 Jan 2023 15:11:04 -0700
+
+altos (1.9.13-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos: Switch LED pin number to 8 bits
+  * altos: Use -ffunction-sections -fdata-sections
+  * altos: Add SAMD21 bits
+  * altos: Add sample samd21 application for snekboard
+  * ao-tools: Add ao-flash-samd21 script
+  * altos/samd21: Add register definitions
+  * altos/samd21: Get USB driver working in AltOS
+  * altos/samd21: Automatically erase flash when writing
+  * altos/snekboard: Indicate that USB is used for stdio
+  * altos: Switch LED pin number to 8 bits
+  * altos: Use --gc-sections
+  * altos: Add SAMD21 bits
+  * altos: Add sample samd21 application for snekboard
+  * ao-tools: Add ao-flash-samd21 script
+  * altos/samd21: Add register definitions
+  * altos/samd21: Get USB driver working in AltOS
+  * altos/samd21: Automatically erase flash when writing
+  * altos/snekboard: Indicate that USB is used for stdio
+  * Add option to beep max height in feet rather than just meters
+  * altos: Get SAMD21 SPI driver working in non-DMA mode
+  * snekboard: Add samd21 SPI test function
+  * This is what I'm using locally for flashing samd21 parts
+  * samd21: Configure ROM/RAM values per device and provide linker scripts for each
+  * altos: Add metro-m0 port for SAMD21G18 testing
+  * samd21: Fix up DMA driver
+  * samd21: Avoid divides in boot loader
+  * samd21: Fix value defines to be unsigned long
+  * samd21: Use DMA for SPI send
+  * snekboard: Need DMA for SPI now.
+  * samd21: Macro-ize the DMA register settings a bit
+  * samd21: Add ability to use arbitrary pin configs with SPI
+  * metro-m0: Configure on-board SPI flash part
+  * altos/ms5607: Use ao_gpio_set instead of stm_gpio_set
+  * samd21: Get ADC code compiling
+  * samd21: Add SPI configurations used by TM v4.0
+  * samd21: Get serial driver building
+  * altos/telemetrum-v4.0: Almost building
+  * samd21: Shrink default stack to 512 bytes
+  * samd21: Stub out exti code
+  * samd21: Stub out beep code
+  * altos/telemetrum-v4.0: It links
+  * samd21: Wire up pin interrupts
+  * metro-m0: Demo pin interrupts
+  * samd21: Get beep code working
+  * samd21: Move DMA channel defs to ao_dma_samd21.h
+  * samd21: Hook up AltOS timer functionality
+  * samd21: Hook up AltOS style ADC
+  * metro-m0: Hook up ADC sample from A pins
+  * telemetrum-v4.0: Add beeper and fix ADC defs
+  * telemetrum-v4.0: Remove unused file
+  * drivers/ublox: Clean up some debug mode code
+  * samd21: Leave serial RX interrupts enabled
+  * metro-m0: Add GPS support
+  * telemetrum-v4.0: Set USE_SERIAL_1_STDIN to 0
+  * telegps: Copy altosui 'beep feet' bits to telegps
+  * altos/ms5607: Use duplex for fetching data
+  * samd21: PA20 maps to SERCOM3.2 not SERCOM3.3
+  * samd21: Limit SPI baud value to 1
+  * samd21: Restore pin cfg when exti is disabled
+  * samd21: AO_SPI_0_PA04_PA05_PA06 is FUNC_D
+  * fixup for exti restore
+  * telemetrum-v4.0: MS5607 doesn't share SPI controller
+  * telemetrum-v4.0: Correct beeper configuration
+  * altos/cc1200: Simplify interrupt handling
+  * altos: Avoid modulus in task queue on parts without idiv
+  * samd21: Save interrupt pin status before enabling interrupts
+  * attiny, stm32l0: Note that these chips don't support spi duplex
+  * altos: Add ao_gps_utc_tick
+  * altos/ms5607: Fixup ms5607 changes for other chips
+  * altos: Make sure APRS packets are reasonably separated
+  * altos: Enable telemetrum telemetry for telemetrum v4.0
+  * altoslib: Handle TeleMetrum v4.0 in idle mode
+  * Add TeleMetrum v4.0 to release files
+  * ao-tools/ao-eeprom: Add support for TeleMega v5.0
+  * altoslib: Add notes about updating ao-eeprom for new product
+  * altos: Add timeout for MS5607 ADC conversion
+  * easymotor-v3.0: Use motor pressure to trigger data logging
+  * easymotor-v3.0: Clean up build bits
+  * altos/stm: Add ao_spi_put_pins for MS5607 driver
+  * altos/stmf0: Add ao_spi_put_pins for MS5067 driver
+  * altos: Add timeout in MS5607 get_sample code
+  * drivers: Add BMI088 driver
+  * altos: Add BMI088 test framework using Nucleo32 board for stm32f042
+  * altos: Add TeleMega v6.0
+  * doc: Update docs for asciidoctor-pdf version 2.x
+  * src/drivers: Ignore printf warnings in ao_aprs.c
+  * drivers: Add AO_LOG_NORMALIZED support to BMI088 command
+  * altos: Split AO_LOG_NORMALIZED support out in telemetry code
+  * ao-tools: Fix buffer overflow in lib/ao-hex.c
+  * ao-tools: Update ao-eeprom for TeleMega v6
+  * altoslib: Add TeleMega v6 support
+  * altos/telelco: Add some debug aids for TeleLCO event stuff
+  * easymotor-v3: Fix pressure to adc conversion to use reference voltage
+  * altos/easymotor: Move pressure conversion code to ao_motor_flight.c
+  * altos: Add makefiles for telemega v6
+  * doc: Add release notes for 1.9.13
+  * doc: Update copyright year to 2023
+  * Version 1.9.13
+  * Disable TM v4.0 firmware for 1.9.13
+  * doc: Add release notes for 1.9.13
+  * doc: Update copyright year to 2023
+  * Version 1.9.13
+
+  [ Bdale Garbee ]
+  * first stab at support for TeleMetrum v4.0
+  * update Releasing with tweaks made during 1.9.12 release process
+  * easymini v3.0 production scripts working
+  * EasyMotor v3 production script working, sans pressure input test
+  * ao-tools: don't do 'm 0' after 'E 0' since EasyMotor doesn't support it
+  * update Releasing to include EasyMini v3.0 loader
+  * ao-tools: new ao-test-pressure utility for bench testing EasyMotor
+  * ao-bringup: final production test script for EasyMotor v3
+  * ao-tools: increase robustness of turnon_easymotor
+  * TeleMetrum v4.0 work in progress
+  * altosui: force Locale.ROOT during CSV export to avoid commas in decimals
+  * ao-tools: return ao-flash-lpc operaton to "full speed"
+  * doc: add a warning to TeleLaunch docs about siren volume levels
+  * doc: add a link to a reference on ARES/RACES use of PowerPole connectors
+  * doc: update EasyMotor behavior description for firmware 1.9.13 and later
+  * doc: update EasyMotor behavior description for firmware 1.9.13 and later
+  * releasing 1.9.13
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 19 Jan 2023 22:59:20 -0700
+
 altos (1.9.12-1) unstable; urgency=medium
 
   [ Bdale Garbee ]
@@ -57,7 +451,7 @@ altos (1.9.12-1) unstable; urgency=medium
   * Auto-detect windows signing stuff
   * Version 1.9.12
 
- -- Bdale Garbee <Bdale Garbee <bdale@gag.com>  Fri, 28 Oct 2022 23:12:21 -0600
+ -- Bdale Garbee <bdale@gag.com>  Fri, 28 Oct 2022 23:12:21 -0600
 
 altos (1.9.11-2) unstable; urgency=medium