update changelog for Debian build
[fw/altos] / debian / changelog
index 2c658550351cc57ddbd1c5f0d7a5965dabc0e723..7824842f5ebfb4917ea4899195d2949d76a0f0c5 100644 (file)
@@ -1,3 +1,565 @@
+altos (1.7-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * Fix release note html to remove xml bits
+  * Update pdclib to version using arm-specific 'ar' program
+  * altos/stmf0: Add USART support
+  * altos/nucleo-32: Add basic support for STM32F042 Nucleo-32 board
+  * altos/test: Fix tests
+  * ao-bringup: Improve EasyMini turnon and test scripts
+  * altos/stm: Make ao_usb_set_address static. Saves a bunch of text space
+  * altos/arm: Align data so that gcc 5.4 doesn't do byte-accesses. Add -Wcast-align
+  * Add first lisp bits
+  * altos: Add lisp reader
+  * altos/lisp: Change lisp objects to use ao_poly everywhere. Add const
+  * altos/kernel: Make ao_cmd_readline public. Return char from ao_cmd_lex.
+  * altos/stmf0: Add lisp to include directories
+  * altos/lisp: add set/setq and ' in reader
+  * altos/lisp: Separate out values from atoms
+  * altos: Add lambda support to lisp
+  * altos: Add lambdakey
+  * altos/lisp: Start rewriting eval as state machine
+  * altos/lisp: get builtin macros working again
+  * altos/lisp: Change GC move API
+  * altos/lisp: make sure stack->formals_last gets moved during GC
+  * altos/lisp: more GC issues. add patom
+  * altos/lisp: convert GC to non-recursive
+  * altos/lambdakey-v1.0: Tweak memory allocations
+  * altos/lisp: working on lexical scoping
+  * altos/lisp: macros appear to work now
+  * altos/lisp: Clean up OS integration bits, add defun
+  * altos/lisp: add progn, while, read and eval
+  * altos/lisp: use regular read-eval-print loop for make const
+  * altos/lisp: Make read() return eof atom on end of file
+  * altos/lisp: Improve lisp test program UI
+  * altos/lisp: Deal with memory compation in the middle of operations
+  * altos/lisp: Add towers of hanoi example
+  * altos/lisp: add length, pack, unpack and flush
+  * altos/lisp: Share mark function for mark and move
+  * altos/lisp: Make ao_lisp_ref and ao_lisp_poly non-inline
+  * altos/lisp: Make sure memmove only happens once per object. Other GC fixes
+  * altos/lisp: Add save/restore infrastructure. Needs OS support to work.
+  * altos/lisp: Add save/restore to ao_lisp_test
+  * altos/lisp: Append a CRC to the saved image to validate on restore
+  * altos/lambdakey: Get save/restore working
+  * altos/stmf0: Add a comment about the requirements for using ao_flash_stm
+  * altos/lisp: Change GC to do moves in batches of 32
+  * altos/lisp: Simplify GC a bit by only marking the head of each object
+  * altos/lisp: Cache freed cons and stack items
+  * altos/lisp: Show number of collect calls in ao_lisp_test
+  * altos/lisp: Improve hanoi demo
+  * altos/lisp: Add license to hanoi demo
+  * altos/lisp: Evaluate macros once, then smash them into place
+  * altos/lisp: Get lambdakey and nucleo-32 building again
+  * altos/lisp: remove duplicate 'length' lambda from hanoi example
+  * altos/lisp: re-use small frames
+  * altos/lisp: Do better checking for un-evaluated macros in ROM
+  * altos/lisp: Allow macro/nlambda/lexpr to have multiple args
+  * altos/lisp: Take advantage of multi-arg macros. Add more ROM funcs
+  * altos/lambdakey: Strip out unused code
+  * altos/lisp: remove nth from hanoi.lisp
+  * altos/lisp: Make hanoi example output a bit prettier
+  * altos/lisp: Add incremental collection
+  * altos/lisp: Optimize chunk searching in collect
+  * altos/lisp: Allow empty defun bodies
+  * altos/test: Disable position independent executables
+  * altos/lisp: binary search for chunk in collect
+  * altos/lisp: Eliminate compiler warning about array bounds at -O3
+  * altos/lisp: Clean up hanoi.lisp comments.
+  * altos/lisp: Remove some stale frame debugging checks
+  * altos/lisp: Fix error atom name in ao_lisp_length
+  * altos/lisp: Dump globals on error
+  * altos/lisp: Fix uninitialized values in ao_lisp_make_const
+  * altos/lisp: Compile ao_lisp_make_const -no-pie
+  * altos/lisp: Make lambda, cond and while all have implicit progns
+  * altos/lisp: Take advantage of implicit progn in ROM code
+  * altos/lisp: have 'while' return the last body value
+  * altos/lisp: Take advantage of implicit progns in hanoi demo
+  * altos/lisp: Add continuations
+  * altos/lisp: Make DBG settings global
+  * altos/lisp: Use poly stashes for stacks
+  * altos/lisp: Empty lambda body is not an error
+  * altos/lisp: bounds check in move_map plus binary search
+  * altos/lisp: Build new ao_lisp_stack.c into test and lambdakey
+  * altos/lisp: Sort frames by atom
+  * altos/lisp: Add builtin 'collect'
+  * altos/lisp: Share binary search for memory chunk between mark and move
+  * altos/lisp: Cleanup some DBG defines
+  * altos/lisp: Include memory stats for test program
+  * altos/lisp: Move stack recursion check after null check
+  * altos/lisp: Clean up hanoi.lisp demo a bit
+  * altos/lisp: Tell compiler that the two lisp memory pools are aligned
+  * altos/lisp: Add casts to keep the latest GCC from whinging
+  * altos/lisp: Start adding scheme symbols
+  * altos/chaoskey: use both halves of the CRC
+  * altos: Eliminate printf format warning with long vs int
+  * ao-bringup: Allow serial number on turnon_easymega cmdline
+  * ao-bringup: test-chaoskey needs to use the SerialNumber dmesg line
+  * altos/stmf0: Allow apps to leave interrupt vectors at 0
+  * altos/stmf0: Complain if the SPI configuration isn't complete
+  * altos/stmf0: Allow projects to not use the USB boot loader
+  * altos: Allow applications to define LEDs for ao_report.c
+  * altos: Require SPI speed to be declared for cc1200
+  * altos/stmf0: Add adc and beep support for TeleMini v3.0
+  * altos: Initial TeleMini v3.0 code
+  * altos/telemini-v3.0: Update to second prototype version
+  * altos/telemini-v3.0: Finish initial turn-on
+  * altos: Split out TeleMini v3 log/telem labeling
+  * altos/telemini-v3.0: Swap main and apogee sense pins.
+  * altoslib: Add TeleMini v3 support
+  * altos/cc1111: Remove unneeded initialization in ao_timer.c
+  * ao-tools/ao-usbload: Pad image with 0xff instead of random bits
+  * altos: Don't wait while idle if trying to minimize interrupt latency
+  * altos/stm: Interrupt priority is in the upper bits of the priority mask
+  * altos/stm: Allow use basepri instead of primask for masking interrupts
+  * altos/avr: Avoid warning about unused args in stdio_put and stdio_get
+  * altos: Allow for console to be used for stdio
+  * altos/stm: Allow DMA channels to be hijacked by other code
+  * altos/stm: Make i2c code handle PCLK1 of 24MHz
+  * altos/stm: Add nvic priority register fields. Add more TIM234 defines.
+  * altos: Add bitmap drawing code
+  * altos: Add VGA driver for STM32L processors
+  * altos: Add PS/2 keyboard driver
+  * altos: Add console driver using VGA and PS/2
+  * altos/stm: Add draw and lisp to make search paths.
+  * altos: Add stm-vga demo project
+  * altos/telemini-v3.0: Add beeper defines needed for more general beeper code
+  * altos/stmf0: Support tim1 beeper channel other than 3
+  * altos/stmf0: Support timer 2/3 for the beeper
+  * altos/lisp: Not quite ready to start making it look like scheme yet
+  * altos/nucleo-32: Update lisp files, add beeper support
+  * Add initial TeleMini v3 docs
+  * telemini outline svg had wrong version number
+  * ao-tools/ao-flash-lpc: Adapt to current openocd LPC support
+  * ao-tools/ao-flash-stm: Use openocd instead of st-utils
+  * doc: Rename telemini doc file from telemini-v1.0.inc to telemini.inc
+  * cortexelf-v1: Add ps/2 and vga with graphics
+  * cortexelf-v1: Fix clock to drive VGA at 640/480. Add sdcard, remove others
+  * cortexelf-v1: Hook up serial consoles for debugging
+  * cortexelf-v1: Use new memory map to access all flash and ram. Add fat.
+  * cortexelf: Add lisp interpreter
+  * stm: Use common flash wait loop instead of inlining
+  * lisp: Fix up lisp build so projects can get ao_lisp_const.h built as needed
+  * cortexelf-v1: Add serialblather command.
+  * cortexelf-v1: Add buttons
+  * altos: Add AS1107 LED display driver
+  * cortexelf-v1: Hook up AS1107 in test mode
+  * altos: add button matrix driver
+  * altos: Allow buttons to be high when pressed rather than low
+  * cortexelf-v1: Hook up hex keypad using matrix input driver
+  * cortexelf-v1: Add bit flipping array generator
+  * cortexelf-v1: doodling with 1802 bits
+  * cortexelf-v1: Make bit flipping array constant
+  * stm: Add a few more GPIO functions to make dealing with the 1802 easier
+  * cortexelf-v1: Add pin definitions for 1802 connections
+  * altos: Define CC115L spi speed in each product
+  * telegps-v0.1: Hack up for SDCARD debugging
+  * altos: Disable FAT commands unless requested
+  * altos: Allow programs to enable SDCARD debugging if desired
+  * stm: Add more mask-based GPIO controls
+  * cortexelf-v1: More 1802 noodling
+  * ao-elftohex: Add conditions for skipping ELF sections
+  * altos: Place AS1107 in 'normal' mode at end of init sequence
+  * altos: Drive row low instead of high in matrix driver
+  * altos: Document a few more SPI mode bits in VGA driver
+  * altos: Escape lisp REP loop with () input
+  * altos: Use MP switch in cortexelf boot loader for force loader mode
+  * cortexelf-v1: Bump SPI pin speed to 40MHz to for sdcard. Fix VGA DMA.
+  * cortexelf-v1: Initialize key matrix code
+  * altos/telegps: Inherit LDFLAGS from lpc make specification
+  * cortexelf-v1: Fetch data at TPB rising when MWR or MRD are low
+  * altos/stmf0: Split up rom load in altos.ld to make linker happy
+  * telegps-v2.0: Remove fec_tx code and ADC logging.
+  * altos/telefiretwo-v0.2: Add AO_CC1200_SPI_SPEED
+  * altos/telebt-v3.0: Add LCO bits for testing
+  * altos/telemini-v3.0: Update to production hardware
+  * altos/telemini-v3.0: Add flash loader
+  * ao-test-baro: Be more lax about altitude checks
+  * altos/lpc: Fix up Makefile definitions
+  * altos/lpc: Add (void *) cast to fix alignment warning
+  * altos/telemini-v3.0: Remove vestiges of the pre-USB code
+  * altos/lpc,altos/stmf0: Use -n flag to work around link editor issue
+  * alots/stmf0: Fix vpath entry for AES directory
+  * doc: Update TeleMini v3 photos to production unit
+  * Replace turnon_telemini with v3 version. Add test-teleminiv3
+  * altos/lpc: Really fix aes entry in lpc vpath
+  * doc: Finish updates for v1.7
+  * altos/stmf0: Pull beeper pin low when beeper is off
+  * altoslib: Add TeleFireTwo eeprom support
+  * altos: Move old AO_LAUNCH defines to cc1111/ao_launch.h
+  * doc: Errors in the TeleMini v3.0 updates found by Bdale
+  * altos/ao_pad.c: Use #if HAS_LOG instead of #ifdef HAS_LOG
+  * altoslib: renamed AltosSensorTMini2, but didn't update AltosIdleFetch
+  * Bump to version 1.7
+
+  [ Bdale Garbee ]
+  * augment TeleDongle turn on script to support serial number on command line
+  * stop using /usr/share for binaries in remaining turnon scripts
+  * use elf, not ihx
+  * first rough cut at skeleton of code for pnpservo .. altos boots and runs
+  * initial skeleton of CortexELF support
+  * makefiles too
+  * capture pnpservo makefiles too
+  * initial cut at telegps-v2.0 firmware
+  * copy telefiretwo-v0.2 to start firmware for v1.0
+  * builds, loads, runs, not very useful yet
+  * need top level Makefile too
+  * add new ADC channels for telefiretwo
+  * fix TeleFireTwo product name in ao-list output
+  * enable spi flash on telefiretwo
+  * fleshing out logging for telefiretwo
+  * a stab at turning on rudimentary logging for telefiretwo
+  * cobble up a command to toggle logging on/off on TeleFireTwo
+  * enable logging support in telefiretwo
+  * add static test start and stop commands to radio protocol for telefiretwo
+  * eliminate spurious close braces
+  * implement static test start and stop protocol for telefiretwo+telebt
+  * allow multiple tests to be logged on telefiretwo without rebooting
+  * update copyright year in docs
+  * update ChangeLog for 1.7 release
+
+  [ Richard Hughes ]
+  * altos/chaoskey: Add a metainfo for the ChaosKey
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 24 Apr 2017 18:22:58 -0600
+
+altos (1.6.8-5) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos/lpc,altos/stmf0: Use -n flag to work around link editor issue,
+    closes: #860601
+  * ao-elftohex: Add conditions for skipping ELF sections
+  * ao-tools/ao-flash-lpc: Adapt to current openocd LPC support
+  * altos/telegps: Inherit LDFLAGS from lpc make specification
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 22 Apr 2017 12:07:57 -0600
+
+altos (1.6.8-4) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos/arm: Align data so that gcc 5.4 doesn't do byte-accesses. Add -Wcast-align
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 25 Jan 2017 12:22:30 -0700
+
+altos (1.6.8-3) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos/stm: Make ao_usb_set_address static. Saves a bunch of text space,
+    closes: #844816
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 13 Dec 2016 00:19:44 -0700
+
+altos (1.6.8-2) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * Update pdclib to version using arm-specific 'ar' program, closes: #838357
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 02 Oct 2016 17:49:32 -0600
+
+altos (1.6.8-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * updates made during 1.6.5 release process
+  * remove debian/ from master branch, it should live only on the debian branch
+  * reinstate debian/ content on the debian branch only
+  * update to latest Debian standards version
+  * update Changelog for release
+
+  [ Keith Packard ]
+  * Switch from GPLv2 to GPLv2+
+  * altos: Add telemetrum v3.0
+  * Bump version to 1.6.5.1 after 1.6.5 release
+  * altosuilib: Show indicator when they switch from invalid back to valid
+  * altos: Add STM32F0 beep and SPI byte API.
+  * altos: Keep telemetry and command output from interleaving
+  * altos: Don't access cc1120 SPI bus during recv after abort has started
+  * fixup for interleave
+  * altos: Expose cc1200 radio test functions for telemini bringup
+  * altos: Don't switch to flight 0 when log fills in flight
+  * altos: Stop building cc1111-based telemini v2.0 firmware
+  * altoslib: Add a 'seconds' method to AltosGPS
+  * altos: Add 'ao_button_get' to button driver
+  * altos: Make telelcotwo control two boxes instead of two pads
+  * altos/stmf0: Hook up clock output support
+  * altos/stmf0: Clean .bin files from flash-loader dirs
+  * altos: Use standard FIPS testing for chaoskey
+  * ao-chaosread: Add --infinite and --bytes options
+  * ao-chaosread: Eliminate double-free when serial match fails
+  * ao-bringup: Test chaoskey using dieharder
+  * ao-bringup: Use released files for chaoskey turnon
+  * Bump to version 1.6.6
+  * ao-bringup: Add colors to chaoskey test result reporting
+  * altos: Flash all LEDS during power on
+  * altos/stmf0: Switch ADC fast to ADC clock
+  * Bump verison to 1.6.7
+  * ao-chaosread: Parse -i and -b options
+  * ao-usbload: Check target device name to avoid mis-flashing
+  * altos/cc1120: remove unused status from ao_radio_fifo_write_stop
+  * ao-bringup: telemega allow serial on command line, loop on accel fail
+  * ao-tools/ao-cal-freq: --verbose option has no parameter
+  * altosui: Deal with connect failure in AltosConfigTD
+  * ao-bringup/turnon_telemetrum: serial on cmd line. Loop on accel fail
+  * ao-tools/ao-usbload: Fix -f flag, remove debug hacks
+  * ao-tools/ao-cal-freq: Re-open usb device each try
+  * Bump version to 1.6.7.1
+  * altos/stm: Make ao_spi_duplex out pointer const
+  * altos/stm: Create funcs to set SPI DMA parameters
+  * altos/stm: Set MISO DMA priority to HIGH to avoid OVR
+  * altos/stm: Set i2c recv DMA to HIGH
+  * altos/stm: Set SPI slave DMA priority to HIGH/VERY_HIGH
+  * Add 1.6.8 release notes
+  * altosui: Don't ship TeleMetrum v3.0 firmware (yet)
+  * Bump version to 1.6.8
+  * Remove pyro wizard file from master
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 05 Sep 2016 21:02:09 -0600
+
+altos (1.6.5-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * doc: Add install-html script
+  * Bump android version to 13
+  * ao-tools/ao-chaosread: Document length (-l) option
+  * altosdroid: Deal with multiple installed android SDKs
+  * Mark testing version 1.6.4.1
+  * altosui: Deliver firmware for Tmega 2.0 and TBT 3.0 for Windows too
+  * altos: Block interrupts while waking tasks sleeping on timers.
+  * altos: Move comment in ao_sleep_for next to related code
+  * altos/stm: remove ao_dma_abort
+  * altos/stm: use 0xff for dma mutex value for allocated mutexes
+  * altos/stm: Add more SPI status register bits
+  * altos/stm: Change ao_spi_send_sync definition to take const source
+  * altos: Add STM DMA debugging
+  * altos: Add STM SPI debugging
+  * altos/stm: move spi execution to common ao_spi_run
+  * altos/stm: Clean up spi_enable/disable_index functions
+  * altos/stm: Add better byte-level SPI api
+  * altos/drivers: Use more reliable byte interface for CC1120 reception
+  * altos: Add debug check for irq block when editing task queues
+  * altos: cc1200: use FIFO threshold pin output for APRS buffering
+  * altos: Make ao_delay(0) not wait forever
+  * altos/telemini-v2.0: Remove show tasks command
+  * altos: Make task list output more useful
+  * altos/stm: clean up ao_exti_enable
+  * altos: Leave USB enabled in flight with -DDEBUG=1
+  * altos: Use FIFO_THR pin for cc1120 transmit buffering
+  * Bump to testing version 1.6.4.2
+  * altos/cc1111: Remove 'show tasks' command
+  * Bump to 1.6.5. Add preliminary release notes
+  * Credit Chuck Haskin for helping fix the SPI bug.
+  * doc: Build 1.6.5 release notes
+
+  [ Bdale Garbee ]
+  * switch libgtk-3-bin build-dep to gtk-update-icon-cache, closes: #825455
+  * updating ChangeLog for 1.6.5 release
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 04 Jul 2016 23:48:50 +0200
+
+altos (1.6.4-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos/cc1111: Use SW to drive UART RTS pin
+  * Bump version to 1.6.3.1
+  * altosui/telegps: Ship firmware for new hardware
+  * altosdroid: Check for closed before writing/reading bluetooth
+  * Publish firmware with keithp-fat
+  * Add TeleMega to spec list. Add TeleGPS RF output.
+  * altoslib: Switch distance from m/ft to km/miles for large values
+  * altoslib: Remove some debug printf calls
+  * altosuilib: Rate limit map loading pacifier updates
+  * altoslib: Allow map preloading to be aborted
+  * altosdroid: Rate limit map loading pacifier
+  * altosuilib: Don't flicker missing voltages when changing units
+  * doc: Start update for 1.6.4
+  * altoslib: Clean up map file and url handling
+  * altosdroid: make disconnect stick past pause/restart
+  * altoslib: Get rid of AltosMap from AltosMapLoader
+  * telegps: Adapt to distance units switching changes
+  * Bump android app version
+  * Bump java library versions
+  * Automatically run 'git submodule update' if necessary
+  * altosui/telegps/micropeak: Handle both MULTI_LIB and non-MULTI_LIB builds
+  * altoslib: Store common frequencies in library version-independent form
+  * altoslib: Store saved state in version-independent format
+  * altoslib: Allow empty values in AltosHashSet representation
+  * altoslib: Set version and log space from AltosIdleFetch
+  * altoslib: Add log_space to AltosState
+  * altoslib: Add AltosIdleReader
+  * telegps: Use log_space when flight_log_max is missing
+  * telegps: Add monitor idle mode
+  * altoslib: use miles for distances > 1000ft.
+  * altosuilib: Have map preload respond to units and font size changes
+  * altosuilib: Rename AltosUIMap*New.java to AltosUIMap*.java
+  * doc: pad/idle indicator table was busted
+  * altosuilib: Fill preload map on site or lat/lon change
+  * altosuilib: Only display map debugging when serial_debug is enabled
+  * telegps-v1.0: Document how SN 1959 was fixed
+  * stmf0: Clear all USB state when resetting chip. Wakeup all sleepers
+  * stmf0: Do not send more data than requested for GET_DESCRIPTOR
+  * altos/lpc: Handle USB reset by resetting internal state
+  * altos/stm: Handle USB reset in STM32L usb driver
+  * altos/cc1115l: Reduce trace buffer size
+  * altos/stmf0: Rework the sram allocation to save a few text bytes
+  * altos/stmf0: Remove ao_usb_free
+  * altosdroid: Auto save freq changes on 'ok'
+  * altosui: Remove missing items from --summary output
+  * altosuilib: Track open frames, exit when none remain
+  * altosui: Don't open command window when --graph is provided
+  * doc: Updates to 1.6.4 release notes.
+  * altoslib: Switch preserved state format to JSON
+  * altoslib: Remove AltosHashSet code
+  * altoslib: Add null constructors to AltosQuaternion and AltosRotation
+  * altoslib: Add JSON-based object saving/restoring code
+  * altoslib: Use reflection JSON code for frequency preferences
+  * altoslib: Improve AltosState save/restore debugging
+  * altoslib: Get rid of manual JSON encoding stuff
+  * altoslib: Add null constructor for AltosCompanion
+  * altoslib: Add construction for remaining primitive array types to JSON
+  * altoslib: Add back some JSON exception debugging printfs
+  * altosui: Print filename before attempting to parse in --summary mode
+  * altoslib: Stop reflective JSON class walk at Object instead of null
+  * Bump version to 1.6.4
+
+  [ Bdale Garbee ]
+  * process updates made during 1.6.3 release cycle
+  * extend "ok" temp range to 40C, since battery charger on bench can drive temp above 35C at times in Bdale and Robert's production testing
+  * releasing 1.6.4
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 17 Jun 2016 10:02:32 -0600
+
+altos (1.6.3-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * Releasing: Copy TeleMega v2.0 bits to Binaries
+  * src/chaoskey-v0.1: Add HV enable support
+  * altos/chaoskey: Add support for flipping between raw and cooked bits
+  * altos/chaoskey: Delay ADC reading for 250ms at startup
+  * altos: remove blank line in stmf0/ao_timer.c
+  * altos/stmf0: Allow projects to specify non-default stack size
+  * altos: Add power management APIs
+  * altos/stmf0: Add suspend/resume support
+  * altos: Allow USB drivers to skip CDC-ACM -specific descriptors
+  * altos: Add power management to TRNG driver
+  * altos/chaoskey-v0.1: Add power management and change USB classes
+  * altos: Delay TRNG ADC long enough for HV supply to stabilize
+  * altos: Add simple stats test to TRNG code
+  * altos/stmf0: Add missing ao_gpio.c
+  * altos: Another fix for non CDC-ACM devices
+  * altos/stmf0: Fix location of device_id register
+  * altos/chaoskey: Encode both hardware and software versions in product ID
+  * altos/stmf0: Use device ID as usb serial number if requested
+  * altos/chaoskey: Use SoC device ID as serial number
+  * altos/chaoskey: Add another USB endpoint to read raw data
+  * altos: Add ChaosKey v1.0 product
+  * ao-bringup: Switch to v1.0 for chaoskey
+  * ao-tools: Add ao-chaosread
+  * altos/stmf0: Fix build without second USB IN endpoint
+  * libaltos: jni_md.h moved to linux subdir in Java install
+  * libaltos: Add unistd.h to get defines for various syscalls
+  * altos: Expose fast timer API from kernel/
+  * Change how we detect and install java
+  * ao-tools/ao-dump-up: Remove spurious flight state strings
+  * ao-tools/lib: Remove trailing whitespace from ao-elf.c
+  * ao-tools/lib: Add ao_hex_image_cat function
+  * ao-tools: Add ao-makebin
+  * altos/stmf0: Construct .bin files for flash loaders
+  * ao-bringup: Use dfu-util to install flash loader on chaoskey
+  * libaltos: Add Windows BT support. Split into separate source files.
+  * altosui: Delay between polling for igniter status in Fire Igniters
+  * altosuilib: Note that Windows now supports Bluetooth
+  * libaltos: Fix warning in linux libaltos code
+  * altoslib: use env var LAUNCH_SITES to override default URL
+  * altosuilib: Control map debugging output with Serial.debug
+  * altosui,telegps: Do not allow radio calibration to be edited
+  * altos/stm: Run scheduler code on interrupt stack
+  * altos/stm: Validate current task SP in interrupt by looking at PSP
+  * altos/stm: Allow apps to define different stack size
+  * altos/lpc: Add fast timer
+  * altos: Add one-byte SPI output routine for LPC and STM cores
+  * altos: Allow for flight hardware without any ADC values
+  * altos: Add Detherm log format (easymini without ADC)
+  * altos: Use mini logging for detherm, just without ADC
+  * altos/stmf0: Add SPI driver.
+  * altos/stmf0: Support HPE clock source
+  * doc: Note that EasyMega and TeleMega report A-D continuity
+  * altos: Add detherm product
+  * altos/stmf0: Add pwm and exti drivers
+  * altos: Add ao_gpi_set/clr_bits functions
+  * altos: Add easy mini plotting helper in test code
+  * altos/detherm: Add ms5607 to detherm
+  * altos/detherm: Add servo driver
+  * altos: Support telefire products in cc1200 driver
+  * altos: Add pad support for new telefire versions
+  * altos: telefiretwo-v0.1 bits
+  * altos: Allow for pad boxes with different sensor configurations
+  * altos: Support pad/lco boxes with fixed box numbers
+  * altos: Add TeleLCOTwo firmware
+  * altos: Fix telefiretwo .gitignore
+  * altos: Add ao_lco_two.c; alternate LCO interface code
+  * altos: Use simpler debounce logic for buttons
+  * altos/telelcotwo: Add idle timeout
+  * Add TeleFireTwo v0.2 project
+  * altos/stmf0: Fix external interrupts
+  * altos/telefiretwo-v0.2: Change alarm names in comment
+  * altosdroid: Don't set target location if lat/lon is MISSING
+  * altoslib: Add debugging to AltosPreferences.state() etc
+  * altoslib: Make AltosGPSSat implement Serializable
+  * altoslib: switch from keySet() to keys() in altos map tiles
+  * altos: avoid mixed declarations and code in ao_task.c
+  * Update java library version numbers
+  * AltosDroid play store keys have moved, update configure.ac
+  * Prepare for new Android release by updating version number
+  * libaltos: Fix for Mac OS X El Capitan
+  * Add preliminary 1.6.3 release notes
+  * altosdroid: Can only use message once
+  * Bump version to 1.6.3
+  * altosdroid: Track device location in app, not telemetry service
+  * altosdroid: Redraw offline map when my location changes
+  * altosdroid: Run even without Bluetooth
+  * altoslib: Use feet per second for imperial speed
+  * altoslib: Report exceptions caught while opening launch sites URL
+  * altoslib: Don't try to drag lines around until map is loaded
+  * Debug bits for telebt
+  * altos: Use TXE instead of TC for serial on STM32l
+  * altos/stm32l: Add support for software-driven HW flow control
+  * altos/telebt-v3.0: Flip CTS/RTS pins for BT module
+  * altos: Clear packet queue when starting packet master
+  * altosdroid: Add idle mode monitoring, reboot. Start igniters
+  * altosdroid: Split setup functions to separate dialog
+  * Fix key in AndroidManifest.xml.in
+  * altosdroid: Add configurable frequency set
+  * altoslib: Make AltosPreferencesBackend abstract. Add set/put Serializable
+  * doc: Add idle mode info to 1.6.3 release note
+  * Revert "altos/stm: Run scheduler code on interrupt stack"
+  * altosdroid: max height is a height, not a speed
+  * altoslib: Correct stats for flights without a real landing
+  * altoslib: Flush during set_state. Don't store listener state.
+  * publish AltosDroid in keithp-fat target
+  * altoslib: Deal with TeleMetrum v2.0 MMA6555 being inverted
+  * altos: Make sure AO_MMA655X_INVERT is declared where needed
+  * doc: Update AltosDroid chapter for 1.6.3
+  * doc: 1.6.3 release notes note TeleBT rts/cts and TM 2.0 monitor idle fixes
+  * micropeak: Change order of windows install so that java detect works
+  * altoslib: Fix map preloading callbacks, run in separate thread
+  * windows: Change install to look for browser in a different place
+  * Ignore some built files for 1.6.3
+
+  [ Robert Garbee ]
+  * fix argument to ao-cal-freq so devices other than /dev/ttyACM0 work
+
+  [ Bart Massey ]
+  * Clean up stmf0 adc init.
+  * altos: Fixed timing of panic display LED to be readable
+
+  [ Justin Vreeland ]
+  * Fix java class differing only by case
+
+  [ Bdale Garbee ]
+  * add beep to TeleMega turnon script
+  * releasing 1.6.3
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 06 May 2016 18:14:11 -0600
+
 altos (1.6.2-1) unstable; urgency=medium
 
   [ Bdale Garbee ]