ao-telem: Add new program to convert telem data to ascii
[fw/altos] / ao-tools / lib / Makefile.am
index f66ee0a99634a0e663393b549c3e618895f53944..1f8f2e42f33eb7d1098bbcc0aab5dff1842acd74 100644 (file)
@@ -1,6 +1,9 @@
 noinst_LIBRARIES = libao-tools.a
 
-AM_CFLAGS=$(WARN_CFLAGS) $(LIBUSB_CFLAGS)
+AM_CFLAGS=$(WARN_CFLAGS) $(LIBUSB_CFLAGS) $(GNOME_CFLAGS)
+
+libao_tools_a_uneeded = \
+       cc-log.c
 
 libao_tools_a_SOURCES = \
        ccdbg-command.c \
@@ -14,6 +17,12 @@ libao_tools_a_SOURCES = \
        ccdbg-memory.c \
        ccdbg-rom.c \
        ccdbg-state.c \
+       cc-analyse.c \
+       cc-convert.c \
+       cc-dsp.c \
+       cc-integrate.c \
+       cc-period.c \
+       cc-process.c \
        cc-usb.c \
        cc-usb.h \
        cc.h \
@@ -21,5 +30,13 @@ libao_tools_a_SOURCES = \
        cc-util.c \
        cc-bitbang.c \
        cc-bitbang.h \
+       cc-logfile.c \
+       cc-telem.c \
+       cc-telemetry.c \
+       cc-telemetry.h \
        cp-usb-async.c \
-       cp-usb-async.h
+       cp-usb-async.h \
+       i0.c \
+       chbevl.c \
+       mconf.h \
+       cephes.h