update changelogs for Debian build
[fw/altos] / Releasing
index 80d39f6a951965bb0606b1d2891ddd4d1ea314e8..98290576797b1acff01866e0577e6d21f3ee1242 100644 (file)
--- a/Releasing
+++ b/Releasing
@@ -1,5 +1,10 @@
 These are Bdale's notes on how to do a release.
 
+       confirm that doc/ has a release-notes file for the new release
+               - add a release notes file
+               - update doc/Makefile
+               - link release notes in doc/altusmetrum.xsl
+
        update the version in configure.ac and commit
 
        git tag -a <version>
@@ -10,6 +15,8 @@ These are Bdale's notes on how to do a release.
 
                at this point, we have Debian packages
 
+       git tag debian/<version>
+
        make distclean
 
        ./autogen.sh --with-fat-dir=/home/bdale/web/altusmetrum/AltOS/releases
@@ -29,8 +36,10 @@ These are Bdale's notes on how to do a release.
                this pushes fresh documents to the web site
 
        sudo debian/rules clean
+       git push
+       git push --tags
 
-               leave the build tree in an unclutterd state
+               push commits and leave the build tree in an uncluttered state
 
 Testing before a release