rename grc to gnuradio-companion, matching upstream future plans
authorBdale Garbee <bdale@gag.com>
Wed, 9 Jun 2010 02:03:32 +0000 (20:03 -0600)
committerBdale Garbee <bdale@gag.com>
Wed, 9 Jun 2010 02:03:32 +0000 (20:03 -0600)
grc/freedesktop/Makefile.am
grc/freedesktop/gnuradio-gnuradio-companion.desktop [new file with mode: 0644]
grc/freedesktop/gnuradio-grc.desktop [deleted file]
grc/freedesktop/grc_setup_freedesktop.in
grc/scripts/Makefile.am
grc/scripts/gnuradio-companion [new file with mode: 0755]
grc/scripts/grc [deleted file]

index 79388ba3a00984e1ef4d3e3f137969e52cbbb4ca..8c01338e72160af6f3fe865ab7923d338e4d7fac 100644 (file)
@@ -30,7 +30,7 @@ dist_ourdata_DATA = \
        grc-icon-48.png \
        grc-icon-32.png \
        gnuradio-grc.xml \
-       gnuradio-grc.desktop \
+       gnuradio-gnuradio-companion.desktop \
        gnuradio-usrp2_probe.desktop \
        gnuradio-usrp_probe.desktop
 
diff --git a/grc/freedesktop/gnuradio-gnuradio-companion.desktop b/grc/freedesktop/gnuradio-gnuradio-companion.desktop
new file mode 100644 (file)
index 0000000..5fd0497
--- /dev/null
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=GRC
+Exec=gnuradio-companion %F
+Categories=Development;
+MimeType=application/gnuradio-grc;
+Icon=gnuradio-grc
diff --git a/grc/freedesktop/gnuradio-grc.desktop b/grc/freedesktop/gnuradio-grc.desktop
deleted file mode 100644 (file)
index d9c70ca..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=GRC
-Exec=grc %F
-Categories=Development;
-MimeType=application/gnuradio-grc;
-Icon=gnuradio-grc
index 33fc4e1ac6b53439ac4f359b7815ebc23c9b77c3..db8d7459d834c92e87928f7f3ebc10dee790c016 100644 (file)
@@ -8,7 +8,7 @@
 ##################################################
 
 ICON_SIZES="32 48 64 128 256"
-MENU_ITEMS="grc usrp2_probe usrp_probe"
+MENU_ITEMS="gnuradio-companion usrp2_probe usrp_probe"
 if [ -n "$2" ]; then
        SRCDIR="$2"
 else
index 35c75d5feb5ba3a54fcdcd77942c6b8926920d64..20ba95751d711f56aa8cbe705f7b5ba6054d1324 100644 (file)
@@ -21,4 +21,4 @@
 
 include $(top_srcdir)/grc/Makefile.inc
 
-dist_bin_SCRIPTS = grc usrp2_probe usrp_probe
+dist_bin_SCRIPTS = gnuradio-companion usrp2_probe usrp_probe
diff --git a/grc/scripts/gnuradio-companion b/grc/scripts/gnuradio-companion
new file mode 100755 (executable)
index 0000000..8a6cc0a
--- /dev/null
@@ -0,0 +1,54 @@
+#!/usr/bin/env python
+"""
+Copyright 2009 Free Software Foundation, Inc.
+This file is part of GNU Radio
+
+GNU Radio Companion is free software; you can redistribute it and/or
+modify it under the terms of the GNU General Public License
+as published by the Free Software Foundation; either version 2
+of the License, or (at your option) any later version.
+
+GNU Radio Companion is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program; if not, write to the Free Software
+Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA
+"""
+
+import pygtk
+pygtk.require('2.0')
+import gtk
+
+try: from gnuradio import gr
+except ImportError, e:
+       d = gtk.MessageDialog(type=gtk.MESSAGE_ERROR, buttons=gtk.BUTTONS_CLOSE, message_format="""
+Cannot import gnuradio. Are your PYTHONPATH and LD_LIBRARY_PATH set correctly?""")
+       d.set_title(str(e))
+       d.run()
+       exit(-1)
+
+from gnuradio.grc import VERSION
+from optparse import OptionParser
+
+if __name__ == "__main__":
+       usage = 'usage: %prog [options] [saved flow graphs]'
+       version = """
+GNU Radio Companion %s
+
+This program is part of GNU Radio
+GRC comes with ABSOLUTELY NO WARRANTY.
+This is free software,
+and you are welcome to redistribute it.
+"""%VERSION
+       parser = OptionParser(usage=usage, version=version)
+       (options, args) = parser.parse_args()
+       from gnuradio.grc.python.Platform import Platform
+       from gnuradio.grc.gui.ActionHandler import ActionHandler
+       #setup icon using icon theme
+       try: gtk.window_set_default_icon(gtk.IconTheme().load_icon('gnuradio-grc', 256, 0))
+       except: pass
+       ActionHandler(args, Platform())
+
diff --git a/grc/scripts/grc b/grc/scripts/grc
deleted file mode 100755 (executable)
index 8a6cc0a..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/usr/bin/env python
-"""
-Copyright 2009 Free Software Foundation, Inc.
-This file is part of GNU Radio
-
-GNU Radio Companion is free software; you can redistribute it and/or
-modify it under the terms of the GNU General Public License
-as published by the Free Software Foundation; either version 2
-of the License, or (at your option) any later version.
-
-GNU Radio Companion is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program; if not, write to the Free Software
-Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA
-"""
-
-import pygtk
-pygtk.require('2.0')
-import gtk
-
-try: from gnuradio import gr
-except ImportError, e:
-       d = gtk.MessageDialog(type=gtk.MESSAGE_ERROR, buttons=gtk.BUTTONS_CLOSE, message_format="""
-Cannot import gnuradio. Are your PYTHONPATH and LD_LIBRARY_PATH set correctly?""")
-       d.set_title(str(e))
-       d.run()
-       exit(-1)
-
-from gnuradio.grc import VERSION
-from optparse import OptionParser
-
-if __name__ == "__main__":
-       usage = 'usage: %prog [options] [saved flow graphs]'
-       version = """
-GNU Radio Companion %s
-
-This program is part of GNU Radio
-GRC comes with ABSOLUTELY NO WARRANTY.
-This is free software,
-and you are welcome to redistribute it.
-"""%VERSION
-       parser = OptionParser(usage=usage, version=version)
-       (options, args) = parser.parse_args()
-       from gnuradio.grc.python.Platform import Platform
-       from gnuradio.grc.gui.ActionHandler import ActionHandler
-       #setup icon using icon theme
-       try: gtk.window_set_default_icon(gtk.IconTheme().load_icon('gnuradio-grc', 256, 0))
-       except: pass
-       ActionHandler(args, Platform())
-