Further updates for removing omnithreads
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Mon, 26 Apr 2010 20:04:23 +0000 (13:04 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Mon, 26 Apr 2010 20:04:23 +0000 (13:04 -0700)
Updates README
Removes Darwin specific variable in usrp.pc

README
config/grc_usrp.m4
usrp/usrp.pc.in

diff --git a/README b/README
index 6eeb0fe8ae68be216bda4dbe7d64e3f88f561db9..4656af2c974427c8373da96b5ae045d1e5c1bfad 100644 (file)
--- a/README
+++ b/README
@@ -177,7 +177,7 @@ http://sourceforge.net/project/showfiles.php?group_id=1369&package_id=175103
 
 We use Smart Pointers, the thread library and a bunch of other boost stuff.
 If your system doesn't have boost 1.35 or later, see README.building-boost
-for additional info.
+for additional info.  (Note: Mac OSX systems require 1.37 or later.)
 
 
 (7) cppunit 1.9.14 or later.   http://cppunit.sourceforge.net
index 1bebfc5b95d6c41accb928bc506ac3358a3e25cd..999b9c5c331b7db74b87e217bc6d5859685b0aba 100644 (file)
@@ -59,18 +59,6 @@ AC_DEFUN([GRC_USRP],[
         usrp_LA="\${abs_top_builddir}/usrp/host/lib/libusrp.la"
     fi
 
-    dnl There pkg-config file for usrp requires omnithread for Darwin only.  Create a variable
-    dnl for just the usrp.pc.in case.
-    case "$host_os" in
-      darwin*)
-        usrp_darwin_omnithread_pc_requires="gnuradio-omnithread"
-        ;;
-      *) dnl (blanks)
-        usrp_darwin_omnithread_pc_requires=""
-        ;;
-    esac
-    AC_SUBST(usrp_darwin_omnithread_pc_requires)
-
     AC_CONFIG_FILES([ \
        usrp/Makefile \
        usrp/usrp.pc \
index 2a15a05fda595716e141075eee896076c91ec382..d4794aa6fe722e5111d6075d25e039cea2b00b9f 100644 (file)
@@ -5,7 +5,7 @@ includedir=@includedir@
 
 Name: usrp
 Description: USRP Client Side C++ interface
-Requires: @LIBUSB_PKG_CONFIG_NAME@ @usrp_darwin_omnithread_pc_requires@
+Requires: @LIBUSB_PKG_CONFIG_NAME@
 Version: @VERSION@
 Libs: -L${libdir} -lusrp
 Cflags: -I${includedir}