Update build configuration for OSX omnithreads changeover
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Mon, 26 Apr 2010 16:13:17 +0000 (09:13 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Mon, 26 Apr 2010 16:13:17 +0000 (09:13 -0700)
gr-audio-osx now depends on gruel (via gnuradio-core) vs. omnithreads
usrp now depends on gruel vs. omnithreads

Boost base library dependency has been upped to 1.37 for
Darwin only, for Darwin specific code in usrp host library

config/grc_gr_audio_osx.m4
config/grc_usrp.m4
configure.ac

index 95fbc17d55895213c6c180677169a49d9621b7f5..df8634ff6fa352ce4b1b122e89bffec1fcfeb679 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008,2010 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -20,8 +20,7 @@ dnl Boston, MA 02110-1301, USA.
 AC_DEFUN([GRC_GR_AUDIO_OSX],[
     GRC_ENABLE(gr-audio-osx)
 
-    dnl Don't do gr-audio-osx if omnithread or gnuradio-core skipped
-    GRC_CHECK_DEPENDENCY(gr-audio-osx, omnithread)
+    dnl Don't do gr-audio-osx if gnuradio-core skipped
     GRC_CHECK_DEPENDENCY(gr-audio-osx, gnuradio-core)
 
     dnl If execution gets to here, $passed will be:
index 286641928bc8367b101ac2fe34a72cec5b3650e8..1bebfc5b95d6c41accb928bc506ac3358a3e25cd 100644 (file)
@@ -22,8 +22,8 @@ AC_DEFUN([GRC_USRP],[
 
     GRC_WITH(usrp)
 
-    dnl Don't do usrp if omnithread skipped
-    GRC_CHECK_DEPENDENCY(usrp, omnithread)
+    dnl Don't do usrp if gruel is skipped
+    GRC_CHECK_DEPENDENCY(usrp, gruel)
 
     dnl Make sure the fast usb technique is set, OS dependent.
     dnl This is always performed, since it puts out CLI flags.
index 3ba5bb387d1a86a980f7f8d7f6973153be22b458..3abdfbfcfd6cafe16de03554a34a790362550416 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008,2009 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -264,7 +264,17 @@ dnl We require the boost headers, thread lib and date_time lib.
 dnl AX_BOOST_BASE finds the headers and the lib dir (-L<foo>)
 dnl
 dnl calls AC_SUBST(BOOST_CPPFLAGS), AC_SUBST(BOOST_LDFLAGS) and defines HAVE_BOOST
-AX_BOOST_BASE([1.35])
+dnl
+dnl Current Boost version requirement is >=1.35 for all platforms except Darwin,
+dnl which requires >=1.37 for code in usrp host library.
+case "$host_os" in
+     darwin*)
+        AX_BOOST_BASE([1.37])
+        ;;
+      *)
+        AX_BOOST_BASE([1.35])
+        ;;
+esac
 
 dnl calls AC_SUBST(BOOST_THREAD_LIB), AC_SUBST(BOOST_CXXFLAGS) and defines HAVE_BOOST_THREAD
 AX_BOOST_THREAD