Imported Debian patch 3.6-3 debian/3.6-3
authorBdale Garbee <bdale@gag.com>
Mon, 5 Mar 2007 23:26:32 +0000 (16:26 -0700)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 05:09:36 +0000 (23:09 -0600)
debian/changelog
debian/control
debian/elilo.config [new file with mode: 0644]
debian/elilo.sh
debian/elilo.templates [new file with mode: 0644]
debian/po/POTFILES.in [new file with mode: 0644]
debian/po/templates.pot [new file with mode: 0644]
debian/postinst
debian/rules
debian/sys2ansi.pl

index bd730c37081cad868f7e37099b7bc20f1a7ea5b5..31ace07c208bec1bc6ff536d0c8bea7bd296f9c5 100644 (file)
@@ -1,3 +1,13 @@
+elilo (3.6-3) unstable; urgency=high
+
+  * patch from Dann Frazier that adds an option to run /usr/sbin/elilo in 
+    the postinst using debconf, closes: #410362
+  * cranking the urgency since 410362 helps with a problem upgrading to etch
+    for systems that depend on elilo
+  * elilo.sh uses bash syntax, so use bash explicitly, closes: #385492
+
+ -- Bdale Garbee <bdale@gag.com>  Mon,  5 Mar 2007 16:26:32 -0700
+
 elilo (3.6-2) unstable; urgency=low
 
   * freshen gnu-efi build dependency version, closes: #355252
index 15710885111032cbb63a02bef7ffa7d01e3cad3c..31ef4870233a4f47d632c6bc506f17ea2834aa9d 100644 (file)
@@ -2,12 +2,12 @@ Source: elilo
 Section: admin
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>> 5), gnu-efi (>=3.0c-1)
-Standards-Version: 3.6.2.1
+Build-Depends: debhelper (>> 5), gnu-efi (>=3.0c-1), po-debconf
+Standards-Version: 3.7.2
 
 Package: elilo
 Architecture: i386 ia64
-Depends: efibootmgr, dosfstools
+Depends: efibootmgr, dosfstools, debconf (>= 0.5)
 Description: Bootloader for systems using EFI-based firmware
  This is the Linux bootloader for systems using the Intel EFI firmware
  specification.  This includes all ia64 systems, and some ia32 systems.
diff --git a/debian/elilo.config b/debian/elilo.config
new file mode 100644 (file)
index 0000000..eb8c0a9
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+set -e
+
+. /usr/share/debconf/confmodule
+
+if [ "2" ] && dpkg --compare-versions $2 lt 3.2-1
+then
+  db_input high elilo/format || true
+else
+  db_input high elilo/runme || true
+fi
+db_go || true
index 6a65e70c7b02847f90a1363848099a3372765dbd..4b1a8522302a7d47d2ba1c38401b8a99635ea2aa 100644 (file)
@@ -1,4 +1,4 @@
-#! /bin/sh
+#! /bin/bash
 
 ###############################################################################
 ##
diff --git a/debian/elilo.templates b/debian/elilo.templates
new file mode 100644 (file)
index 0000000..c0bd1c0
--- /dev/null
@@ -0,0 +1,25 @@
+Template: elilo/runme
+Type: boolean
+Default: true
+_Description: Automatically run elilo?
+ It is necessary to run /usr/sbin/elilo to install the new elilo binary into
+ the EFI partition.  
+ .
+ WARNING: This procedure will write data into the debian directory of the
+ EFI disk partition, possibly overwriting files installed there by hand.
+ .
+ Not installing the new elilo binary on the EFI disk partition may leave the
+ system in an unbootable state.  Alternatives to automatic updating of the
+ partition include runnning /usr/sbin/elilo by hand, or installing the new 
+ /usr/lib/elilo/elilo.efi executable into the EFI disk partition manually.
+
+Template: elilo/format
+Type: boolean
+Default: true
+_Description: Reformat and reload EFI partition?
+ The structure of files in the EFI disk partition has changed since pre-3.2 
+ versions of the elilo package.  The EFI boot manager entry for Debian needs 
+ to be updated to reflect these changes.
+ .
+ In most cases, if no manual changes to the EFI partition content need to 
+ be preserved, this update can be handled automatically.
diff --git a/debian/po/POTFILES.in b/debian/po/POTFILES.in
new file mode 100644 (file)
index 0000000..4ef1d3d
--- /dev/null
@@ -0,0 +1 @@
+[type: gettext/rfc822deb] elilo.templates
diff --git a/debian/po/templates.pot b/debian/po/templates.pot
new file mode 100644 (file)
index 0000000..3be4f39
--- /dev/null
@@ -0,0 +1,72 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
+#
+#, fuzzy
+msgid ""
+msgstr ""
+"Project-Id-Version: PACKAGE VERSION\n"
+"Report-Msgid-Bugs-To: bdale@gag.com\n"
+"POT-Creation-Date: 2007-03-05 16:47-0700\n"
+"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
+"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
+"Language-Team: LANGUAGE <LL@li.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=CHARSET\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: boolean
+#. Description
+#: ../elilo.templates:1001
+msgid "Automatically run elilo?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../elilo.templates:1001
+msgid ""
+"It is necessary to run /usr/sbin/elilo to install the new elilo binary into "
+"the EFI partition."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../elilo.templates:1001
+msgid ""
+"WARNING: This procedure will write data into the debian directory of the EFI "
+"disk partition, possibly overwriting files installed there by hand."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../elilo.templates:1001
+msgid ""
+"Not installing the new elilo binary on the EFI disk partition may leave the "
+"system in an unbootable state.  Alternatives to automatic updating of the "
+"partition include runnning /usr/sbin/elilo by hand, or installing the new  /"
+"usr/lib/elilo/elilo.efi executable into the EFI disk partition manually."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../elilo.templates:2001
+msgid "Reformat and reload EFI partition?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../elilo.templates:2001
+msgid ""
+"The structure of files in the EFI disk partition has changed since pre-3.2  "
+"versions of the elilo package.  The EFI boot manager entry for Debian needs  "
+"to be updated to reflect these changes."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../elilo.templates:2001
+msgid ""
+"In most cases, if no manual changes to the EFI partition content need to  be "
+"preserved, this update can be handled automatically."
+msgstr ""
index 50b76cadb56d74cc159ea62d389e1860ad0b6496..465c7a99e9af8ac05bec45dc1621bd3c10636d7c 100644 (file)
@@ -1,12 +1,32 @@
-#!/bin/sh -e
+#!/bin/sh
+
+set -e
+
+if [ -f /usr/share/debconf/confmodule ]; then
+  . /usr/share/debconf/confmodule
+fi
 
-# don't bother with debconf for this, since very few systems are likely to
-# be affected by this upgrade, and it's a one-shot deal.  this postinst can
-# probably be safely removed for the woody+1 release.
 
 case "$1" in
-    configure)
-        # continue below
+    configure|reconfigure)
+       # On new installs, do nothing - elilo-installer will handle it for d-i
+       if grep -q "^# UNCONFIGURED FSTAB FOR BASE SYSTEM" /etc/fstab ; then
+         exit 0
+       fi
+        if [ "$2" ] && dpkg --compare-versions $2 lt 3.2-1
+        then
+            db_get elilo/format || true;
+            if [ x"$RET" = x"true" ]; then
+                echo "Running elilo..."
+                /usr/sbin/elilo --format --efiboot
+            fi
+            exit 0
+        fi
+        db_get elilo/runme || true;
+        if [ x"$RET" = x"true" ]; then
+            echo "Running elilo..."
+            /usr/sbin/elilo
+        fi
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)
@@ -19,34 +39,6 @@ case "$1" in
     ;;
 esac
 
-if [ "$2" ] && dpkg --compare-versions $2 lt 3.2-1
-then
-  echo ""
-  echo "You appear to be upgrading from an old (pre-3.2) version of the elilo"
-  echo "package.  The structure of files in the EFI partition is different"
-  echo "now, and the EFI boot manager entry for Debian needs to be updated."
-  echo ""
-  echo "If you have not made any manual changes to the EFI partition content"
-  echo "that you want to preserve, we can reformat and reload that partition"
-  echo "for you, and rewrite the boot manager entry to be correct."
-  echo ""
-  echo "Do you want me to reformat and reload the EFI partition and write an"
-  echo -n "updated boot manager entry for you [Ny]? "
-
-  read answer
-  case "$answer" in
-    [Yy]*)
-       echo -n "Working... "
-       /usr/sbin/elilo --format --efiboot
-       echo "done."
-       ;;
-    *)
-       echo "No action taken.  See /usr/share/doc/elilo/* for more info."
-       ;;
-  esac
-  echo ""
-fi
-
 #DEBHELPER#
 
 exit 0
index 0a1c6a59720a479058f1ba6be961a0b3552803da..c805a03a456783a0c93bd4d67ae154effcd2c449 100755 (executable)
@@ -26,6 +26,7 @@ clean:
 
        -$(MAKE) clean
 
+       debconf-updatepo
        dh_clean
 
 install: build
@@ -53,6 +54,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installdocs
+       dh_installdebconf
        dh_installexamples examples/netboot examples/textmenu_chooser
        cp debian/sys2ansi.pl \
                debian/elilo/usr/share/doc/elilo/examples/textmenu_chooser/
index ecf7b6b9045da2542e26a486edbe2bf9aa476c19..d8c3f51b90483cf79cfe68bdce26c0cd188b5aca 100644 (file)
@@ -1,5 +1,5 @@
 #!/usr/bin/perl
-# $Id: sys2ansi.pl,v 1.1 2002/10/29 22:35:52 bdale Exp $
+# $Id: sys2ansi.pl,v 1.1 2002-10-29 22:35:52 bdale Exp $
 #
 # Perl script to convert a Syslinux-format screen to PC-ANSI
 # to display in a color xterm or on the Linux console