Imported Debian patch 3.6-2 debian/3.6-2
authorBdale Garbee <bdale@gag.com>
Sun, 2 Apr 2006 06:28:59 +0000 (22:28 -0800)
committerBdale Garbee <bdale@gag.com>
Tue, 20 May 2008 05:09:35 +0000 (23:09 -0600)
debian/changelog
debian/control
debian/elilo.sh

index 4b0cb5a8b01dc78d12e1b438ead24158a8b0a1cd..bd730c37081cad868f7e37099b7bc20f1a7ea5b5 100644 (file)
@@ -1,3 +1,11 @@
+elilo (3.6-2) unstable; urgency=low
+
+  * freshen gnu-efi build dependency version, closes: #355252
+  * patch from Alex Williamson that adds support to our elilo user space 
+    script for the vmm= option needed by Xen, closes: #350185
+   
+ -- Bdale Garbee <bdale@gag.com>  Sat,  1 Apr 2006 22:28:59 -0800
+
 elilo (3.6-1) unstable; urgency=low
 
   * new upstream version
index 68b7730b08cb979fc2a3d6309e61c4f0c342591d..15710885111032cbb63a02bef7ffa7d01e3cad3c 100644 (file)
@@ -2,7 +2,7 @@ Source: elilo
 Section: admin
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>> 5), gnu-efi (>=3.0b-1)
+Build-Depends: debhelper (>> 5), gnu-efi (>=3.0c-1)
 Standards-Version: 3.6.2.1
 
 Package: elilo
index df78c64eed2a2a38f7c7a6236306da5360098a95..6a65e70c7b02847f90a1363848099a3372765dbd 100644 (file)
@@ -364,6 +364,8 @@ copyfiles()
                sed 's/^image[[:space:]]*=[[:space:]]*//' | grep -v ':'`
     initrdfiles=`grep '^[[:space:]]*initrd[[:space:]]*=' $bootconf | \
                sed 's/.*=[[:space:]]*//' | grep -v ':'`
+    vmmfiles=`grep '^[[:space:]]*vmm[[:space:]]*=' $bootconf | \
+               sed 's/.*=[[:space:]]*//' | grep -v ':'`
 
     ## Point of no return, removing the old EFI/debian tree
     rm -rf $TARGET/$EFIROOT
@@ -398,6 +400,7 @@ recreated every time elilo runs.  Any local changes will be lost.\n\
        -e "s|\t| |g" \
        -e "s|\(^image[[:space:]]*=[[:space:]]*\)\([^:]*\)$|\1$EFIROOT\2|" \
        -e "s|\(^[[:space:]]*initrd[[:space:]]*=[[:space:]]*\)\([^:]*\)$|\1$EFIROOT\2|" \
+       -e "s|\(^[[:space:]]*vmm[[:space:]]*=[[:space:]]*\)\([^:]*\)$|\1$EFIROOT\2|" \
        < "$bootconf" > "$TARGET/$EFIROOT/$CFFILE"
     if [ $? != 0 ] ; then
        echo 1>&2 "$PRG: An error occured while writing to $boot"
@@ -406,7 +409,7 @@ recreated every time elilo runs.  Any local changes will be lost.\n\
 
     [ "$DEBUG" = 1 ] && echo "----" && cat "$TARGET/$EFIROOT/$CFFILE" && echo "----"
 
-    for i in $imagefiles $initrdfiles; do
+    for i in $imagefiles $initrdfiles $vmmfiles; do
        [ "$VERBOSE" = 1 ] && echo "$PRG: Installing $i on $boot..."
        if [ -f $i ]; then
            mkdir -p `dirname "$TARGET/$EFIROOT/$i"`
@@ -575,7 +578,9 @@ chkspace()
                sed 's/^image[[:space:]]*=[[:space:]]*//' | grep -v ':'`
     initrdfiles=`grep '^[[:space:]]*initrd[[:space:]]*=' $bootconf | \
                sed 's/.*=[[:space:]]*//' | grep -v ':'`
-    bytesneeded=`cat $imagefiles $initrdfiles $install $bootconf 2>/dev/null | wc -c`
+    vmmfiles=`grep '^[[:space:]]*vmm[[:space:]]*=' $bootconf | \
+               sed 's/.*=[[:space:]]*//' | grep -v ':'`
+    bytesneeded=`cat $imagefiles $initrdfiles $vmmfiles $install $bootconf 2>/dev/null | wc -c`
     # convert to KB, allowing 5% overhead
     kbneeded=$(( bytesneeded / 1024 + bytesneeded / 20480 ))
     kbavailable=$(df -P -k $TARGET | sed -n "s|^$boot[[:space:]]\+[0-9]\+[[:space:]]\+[0-9]\+[[:space:]]\+\([0-9]\+\).*$|\1|p")