fixing cross arch build paths and options
authorBdale Garbee <bdale@gag.com>
Tue, 8 Jun 2010 19:22:25 +0000 (13:22 -0600)
committerBdale Garbee <bdale@gag.com>
Tue, 8 Jun 2010 19:22:25 +0000 (13:22 -0600)
debian/patches/fix-paths.diff [new file with mode: 0644]
debian/patches/series [new file with mode: 0644]
debian/rules
debian/source/format [new file with mode: 0644]

diff --git a/debian/patches/fix-paths.diff b/debian/patches/fix-paths.diff
new file mode 100644 (file)
index 0000000..64b12ae
--- /dev/null
@@ -0,0 +1,27 @@
+diff -u -r elilo/Make.defaults /tmp/elilo-3.12/Make.defaults
+--- elilo/Make.defaults        2009-11-01 22:27:09.000000000 -0700
++++ /tmp/elilo-3.12/Make.defaults      2010-06-08 13:15:19.905132316 -0600
+@@ -62,8 +62,8 @@
+ CDIR    := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi)
+ TOPDIR  =
+-HOSTARCH   = $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32,)
+-ARCH     := $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32,)
++HOSTARCH   = $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32, | sed s,amd64,x86_64, )
++ARCH     := $(shell dpkg-architecture -qDEB_BUILD_ARCH | sed s,i[3456789]86,ia32, | sed s,amd64,x86_64, )
+ INCDIR           = -I. -I$(TOPDIR) -I$(EFIINC) -I$(EFIINC)/$(ARCH) -I$(EFIINC)/protocol -I$(TOPDIR)/efi110
+ CPPFLAGS   = -DCONFIG_$(ARCH) 
+@@ -128,9 +128,9 @@
+       ARCH3264 = -m32
+       LD3264 = -melf_i386
+-      GNUEFILIB := /emul/ia32-linux$(GNUEFILIB)
+-      EFILIB    := /emul/ia32-linux$(EFILIB)
+-      EFICRT0   := /emul/ia32-linux$(EFICRT0)
++      GNUEFILIB := /usr/lib32
++      EFILIB    := /usr/lib32
++      EFICRT0   := /usr/lib32
+   endif
+ endif
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644 (file)
index 0000000..80f5939
--- /dev/null
@@ -0,0 +1 @@
+fix-paths.diff
index d17298ec913a69afd45dcc03f92eb5e72b44c98d..be2c8ffaaa4beffd74aa4fa50a75226fd3cb1696 100755 (executable)
@@ -24,8 +24,7 @@ endif
 
 ifeq ($(buildarch), amd64)
        mkdir debian/build32
-       $(MAKE) -C debian/build32 -f ../../Makefile SRCDIR=../.. ARCH=ia32 \
-               CFLAGS=-m32
+       $(MAKE) -C debian/build32 -f ../../Makefile SRCDIR=../.. ARCH=ia32 
 endif
 
        $(MAKE)
@@ -57,9 +56,9 @@ ifeq ($(buildarch), i386)
 endif
 
 ifeq ($(buildarch), amd64)
-       mkdir -p debian/elilo/emul/ia32-linux/usr/lib/elilo
-       cp debian/build32/elilo.efi debian/elilo/emul/ia32-linux/usr/lib/elilo/elilo.efi
-       chmod 0644 debian/elilo/emul/ia32-linux/usr/lib/elilo/elilo.efi
+       mkdir -p debian/elilo/usr/lib32/elilo
+       cp debian/build32/elilo.efi debian/elilo/usr/lib32/elilo/elilo.efi
+       chmod 0644 debian/elilo/usr/lib32/elilo/elilo.efi
 endif
 
        cp elilo.efi debian/elilo/usr/lib/elilo/elilo.efi
diff --git a/debian/source/format b/debian/source/format
new file mode 100644 (file)
index 0000000..163aaf8
--- /dev/null
@@ -0,0 +1 @@
+3.0 (quilt)