fixed typo
[fw/sdcc] / sdcc.spec
1 #
2 # spec file for package sdcc
3 #
4
5 Name:          sdcc
6 Requires:      /bin/sh
7 License:       GPL, LGPL
8 Group:         Applications/Engineering
9 Provides:      sdcc
10 Summary:       Small Device C Compiler
11 Version:       2.3.7
12 Release:       4
13 Source:        %{name}-%{version}.tar.bz2
14 URL:           http://sdcc.sourceforge.net/
15 Packager:      Bernhard Held <bernhard@bernhardheld.de>
16 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
17
18 %description
19 SDCC is a C compiler for 8051 class and similar microcontrollers.
20 The package includes the compiler, assemblers and linkers, a device
21 simulator and a core library. The processors supported (to a varying
22 degree) include the 8051, ds390, z80, hc08, and PIC.
23
24 %prep
25 %setup -n sdcc
26
27 %build
28 ./configure CFLAGS="$RPM_OPT_FLAGS" --prefix=/usr docdir=$RPM_BUILD_ROOT/%{_defaultdocdir}/%{name}
29 make
30 cd doc
31 make
32 cd ..
33
34 %install
35 rm -rf $RPM_BUILD_ROOT/usr
36 make prefix=$RPM_BUILD_ROOT/usr install
37 cd doc
38 make install
39 cd ..
40
41 %files
42 %defattr(-,root,root)
43 /usr/bin
44 /usr/share/sdcc/include
45 /usr/share/sdcc/lib
46 %doc %{_defaultdocdir}
47
48 %changelog
49 * Sun Jan 04 2004 - bernhard@bernhardheld.de
50 - updated
51 * Sat Apr 27 2002 - steve@icarus.com
52 - first version from Stephen Williams