Add the SPEC file.
[fw/sdcc] / sdcc.spec
1 Summary: Small Device C Compiler
2 Name: sdcc
3 Version: 2.2.2
4 Release: 0.20010225
5 Copyright: GPL
6 Group: Applications/Engineering
7 Source: sdcc-2.2.2.tar.gz
8 URL: http://sdcc.sourceforge.net/
9 Packager: Stephen Williams <steve@icarus.com>
10
11 BuildRoot: /tmp/sdcc
12
13 %description
14 SDC is a C compiler for 8051 class and similar microcontrollers.
15 The packge includes the compiler, assemblers and linkers, a device
16 simulator and a core library. The processors supported (to a varying
17 degree) include the 8051, avr and z80.
18
19 %prep
20 %setup -n sdcc-2.2.2
21
22 %build
23 ./configure --prefix=/usr/local
24 make all
25
26 %install
27 make prefix=$RPM_BUILD_ROOT/usr/local  install
28
29 %files
30
31 %attr(-,root,root) /usr/local/bin/sdcc
32 %attr(-,root,root) /usr/local/bin/sdcpp
33 %attr(-,root,root) /usr/local/bin/asx8051
34 %attr(-,root,root) /usr/local/bin/aslink
35 %attr(-,root,root) /usr/local/bin/packihx
36 %attr(-,root,root) /usr/local/bin/sdcdb
37 %attr(-,root,root) /usr/local/share/sdcc
38
39 %attr(-,root,root) /usr/local/bin/s51
40 %attr(-,root,root) /usr/local/bin/savr
41 %attr(-,root,root) /usr/local/bin/sz80
42
43 %attr(-,root,root) %doc /usr/local/doc/ucsim