fat: sign Windows installers with our new code signing certificate
[fw/altos] / telegps / Makefile.am
index 7ab0749cfa01162f0389f01c7f82bab851eb0e9e..067df0c740b33d912e885b6f84f4fdeee8788d59 100644 (file)
@@ -1,3 +1,6 @@
+# location of code signing key, et al
+CODEKEYDIR=~/altusmetrumllc/ssl.com
 JAVAROOT=classes
 AM_JAVACFLAGS=$(JAVAC_VERSION_FLAGS) -encoding UTF-8 -Xlint:deprecation -Xlint:unchecked
 
@@ -337,6 +340,9 @@ $(MACOSX_DIST): $(MACOSX_FILES) $(MACOSX_EXTRA) Makefile
 $(WINDOWS_DIST): $(WINDOWS_FILES) telegps-windows.nsi
        -rm -f $@
        makensis -Otelegps-windows.log "-XOutFile $@" "-DVERSION=$(VERSION)" telegps-windows.nsi || (cat telegps-windows.log && exit 1)
+       jsign --keystore $(CODEKEYDIR)/altus_metrum,_llc.p12 --alias 1 \
+               --storetype PKCS12 --storepass `cat $(CODEKEYDIR)/password` \
+               --tsaurl http://ts.ssl.com --tsmode RFC3161 $@
 
 Manifest.txt: Makefile
        echo 'Main-Class: org.altusmetrum.telegps.TeleGPS' > $@