map-server: Create Manifest.txt at build time
[fw/altos] / map-server / altos-mapd / Makefile.am
index bb20dd845886ec795c4234006890f2351748b41a..3f1c65158e995507d978f01c1c78236eb76b728a 100644 (file)
@@ -60,6 +60,10 @@ altos-mapd: Makefile
        echo 'exec java -Djava.library.path="$(altoslibdir)" -jar "$(altosmapddir)/altosmapd.jar" "$$@"' >> $@
        chmod +x $@
 
+Manifest.txt: Makefile
+       echo 'Main-Class: altosmapd.AltosMapd' > $@
+       echo "Class-Path: $(ALTOSLIB_CLASS) $(ALTOSUILIB_CLASS)" >> $@
+
 altos-mapd-test: Makefile
        echo '#!/bin/sh' > $@
        echo 'dir="$$(dirname $$0)"' >> $@