altosdroid: fixup fetching active device address
[fw/altos] / debian / rules
index 1353321d49be85562e4f5868a2b928992c24cd57..ebcb3b803dfd4e5c90b16b857cf5a23b8c739149 100755 (executable)
@@ -8,17 +8,18 @@ DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; f
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
        echo $(DEB_VERSION)
-       git-dch --release --new-version=$(DEB_VERSION)
+       git-dch --release --new-version=$(DEB_VERSION) --multimaint-merge
        git log > ChangeLog
        git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
-       git tag debian/$(DEB_VERSION)
+#      git tag debian/$(DEB_VERSION)
 #      git push --tags origin master
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       ./autogen.sh --prefix=/usr
+       PKG_CONFIG_PATH=/opt/stlink/lib/pkgconfig ./autogen.sh \
+               --prefix=/usr --with-google-key=/opt/google/maps-api-key
        touch configure-stamp
 
 build: build-arch build-indep
@@ -27,7 +28,7 @@ build-indep: build-stamp
 
 build-stamp: configure-stamp  
        dh_testdir
-       $(MAKE) VERSION=$(PKG_VERSION)
+       $(MAKE)
        (cd doc ; $(MAKE))
        touch $@