make sure to use Google Maps API key for official builds
[fw/altos] / debian / rules
index 028b548f31990072a505fc75f3818cd60abd8ccd..ebcb3b803dfd4e5c90b16b857cf5a23b8c739149 100755 (executable)
@@ -8,7 +8,7 @@ DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; f
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
        echo $(DEB_VERSION)
-       git-dch --release --new-version=$(DEB_VERSION)
+       git-dch --release --new-version=$(DEB_VERSION) --multimaint-merge
        git log > ChangeLog
        git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
@@ -18,7 +18,8 @@ prebuild:
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       ./autogen.sh --prefix=/usr
+       PKG_CONFIG_PATH=/opt/stlink/lib/pkgconfig ./autogen.sh \
+               --prefix=/usr --with-google-key=/opt/google/maps-api-key
        touch configure-stamp
 
 build: build-arch build-indep
@@ -27,7 +28,7 @@ build-indep: build-stamp
 
 build-stamp: configure-stamp  
        dh_testdir
-       $(MAKE) VERSION=$(PKG_VERSION)
+       $(MAKE)
        (cd doc ; $(MAKE))
        touch $@