Merge branch 'branch-1.4' into debian
[fw/altos] / debian / rules
index ebcb3b803dfd4e5c90b16b857cf5a23b8c739149..c1c9a0f8549297d49fd6b332b7f2492d87a9819c 100755 (executable)
@@ -3,17 +3,10 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
-DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; fi | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       echo $(DEB_VERSION)
-       git-dch --release --new-version=$(DEB_VERSION) --multimaint-merge
-       git log > ChangeLog
-       git commit -n ChangeLog debian/changelog \
-               -m "update changelogs for Debian build"
-#      git tag debian/$(DEB_VERSION)
-#      git push --tags origin master
+       echo "not frobbing changelog for official builds"
 
 configure: configure-stamp
 configure-stamp: