add initial package build scripts for Arch Linux from Bob Finch
[fw/altos] / debian / rules
index f6efe9900a96b5487086e75c0222585086425367..a7468b9f5c99814da86002ffd31fd184eb7df2e6 100755 (executable)
@@ -7,6 +7,7 @@ DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; f
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
+       echo $(DEB_VERSION)
        git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
        git commit -n ChangeLog debian/changelog \
@@ -25,6 +26,7 @@ build: build-stamp
 build-stamp: configure-stamp  
        dh_testdir
        $(MAKE) VERSION=$(PKG_VERSION)
+       (cd doc ; $(MAKE))
        touch $@
 
 clean: