add initial package build scripts for Arch Linux from Bob Finch
[fw/altos] / debian / rules
index f4e9f840fccd39f337e46cea40bc292e992b2d6e..a7468b9f5c99814da86002ffd31fd184eb7df2e6 100755 (executable)
@@ -3,10 +3,11 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
-DEB_VERSION := $(shell -git describe | tr - +)
+DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; fi | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
+       echo $(DEB_VERSION)
        git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
        git commit -n ChangeLog debian/changelog \
@@ -25,6 +26,7 @@ build: build-stamp
 build-stamp: configure-stamp  
        dh_testdir
        $(MAKE) VERSION=$(PKG_VERSION)
+       (cd doc ; $(MAKE))
        touch $@
 
 clean: