add initial package build scripts for Arch Linux from Bob Finch
[fw/altos] / debian / rules
index ac594c076242236ce4c40b79a5d9625bd4ac13b0..a7468b9f5c99814da86002ffd31fd184eb7df2e6 100755 (executable)
@@ -3,13 +3,14 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
-DEB_VERSION := $(shell git describe | tr - +)
+DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; fi | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
+       echo $(DEB_VERSION)
        git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
-       git commit ChangeLog debian/changelog \
+       git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
        git tag debian/$(DEB_VERSION)
        git push --tags origin master
@@ -25,6 +26,7 @@ build: build-stamp
 build-stamp: configure-stamp  
        dh_testdir
        $(MAKE) VERSION=$(PKG_VERSION)
+       (cd doc ; $(MAKE))
        touch $@
 
 clean: