reinstate debian/ content on the debian branch only
[fw/altos] / debian / rules
index ebcb3b803dfd4e5c90b16b857cf5a23b8c739149..9ff89cc82a14fefedddf9072698f2ae6cff82d0b 100755 (executable)
@@ -3,23 +3,18 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
-DEB_VERSION := $(shell if [ -x /usr/bin/git ]; then git describe; else echo 0; fi | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       echo $(DEB_VERSION)
-       git-dch --release --new-version=$(DEB_VERSION) --multimaint-merge
-       git log > ChangeLog
-       git commit -n ChangeLog debian/changelog \
-               -m "update changelogs for Debian build"
-#      git tag debian/$(DEB_VERSION)
-#      git push --tags origin master
+       echo "not frobbing changelog for official builds"
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        PKG_CONFIG_PATH=/opt/stlink/lib/pkgconfig ./autogen.sh \
-               --prefix=/usr --with-google-key=/opt/google/maps-api-key
+               --prefix=/usr \
+               --disable-install-shared-mime-info \
+               --with-google-key=/opt/google/maps-api-key
        touch configure-stamp
 
 build: build-arch build-indep
@@ -36,6 +31,7 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
+       rm -f debian/altos.sharedmimeinfo
        [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean 
 
@@ -66,7 +62,8 @@ binary-arch: install
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam
-#      dh_installmime
+       cp icon/org-altusmetrum-mimetypes.xml debian/altos.sharedmimeinfo
+       dh_installmime
 #      dh_python
 #      dh_installinit
 #      dh_installcron