move git-using variable declaration into the prebuild target
[fw/altos] / debian / rules
index ac594c076242236ce4c40b79a5d9625bd4ac13b0..343cd71a5a457de06052951f25f7fd98ca3b8008 100755 (executable)
@@ -3,13 +3,13 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
-DEB_VERSION := $(shell git describe | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
+       DEB_VERSION := $(shell git describe | tr - +)
        git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
-       git commit ChangeLog debian/changelog \
+       git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
        git tag debian/$(DEB_VERSION)
        git push --tags origin master