move git-using variable declaration into the prebuild target
[fw/altos] / debian / rules
index 0033fcbedd615d8ca5e2e85daab7a93221917f3a..343cd71a5a457de06052951f25f7fd98ca3b8008 100755 (executable)
@@ -6,10 +6,13 @@ PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       git-dch --release --new-version=`git describe | tr - +`
+       DEB_VERSION := $(shell git describe | tr - +)
+       git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
-       git commit ChangeLog debian/changelog \
+       git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
+       git tag debian/$(DEB_VERSION)
+       git push --tags origin master
 
 configure: configure-stamp
 configure-stamp: