Add date to GPS data, captured from GPRMC packet.
[fw/altos] / debian / rules
index 078dac56cddff93a9e91161cd046e1181d255b42..260ba7733145c9e64e86598350fee17f3be60ad7 100755 (executable)
@@ -3,13 +3,16 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
+DEB_VERSION := $(shell git describe | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       dch -v `git describe | tr - +` "build for Debian from git"
+       git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
-       git commit ChangeLog debian/changelog \
+       git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
+       git tag debian/$(DEB_VERSION)
+       git push --tags origin master
 
 configure: configure-stamp
 configure-stamp:
@@ -38,6 +41,8 @@ install: build
        dh_installdirs
 
        $(MAKE) DESTDIR=$(CURDIR)/debian/altos install
+       install -o root -g root -m 0644 debian/altusmetrum.xpm \
+               $(CURDIR)/debian/altos/usr/share/pixmaps/altusmetrum.xpm
 
 # Build architecture-independent files here.
 binary-indep: install
@@ -51,7 +56,7 @@ binary-arch: install
        dh_installdocs
        dh_installexamples
        dh_install
-#      dh_installmenu
+       dh_installmenu
 #      dh_installdebconf
 #      dh_installlogrotate
 #      dh_installemacsen