Add date to GPS data, captured from GPRMC packet.
[fw/altos] / debian / rules
index 0033fcbedd615d8ca5e2e85daab7a93221917f3a..260ba7733145c9e64e86598350fee17f3be60ad7 100755 (executable)
@@ -3,13 +3,16 @@
 
 export DH_VERBOSE=1
 PKG_VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: \(.*\)/\1/p')
+DEB_VERSION := $(shell git describe | tr - +)
 
 # this target invoked by git-buildpackage using a clean hook, see .gbp.conf
 prebuild:
-       git-dch --release --new-version=`git describe | tr - +`
+       git-dch --release --new-version=$(DEB_VERSION)
        git log > ChangeLog
-       git commit ChangeLog debian/changelog \
+       git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
+       git tag debian/$(DEB_VERSION)
+       git push --tags origin master
 
 configure: configure-stamp
 configure-stamp: