doc: Describe max flight log, ignite mode and pad orientation
[fw/altos] / debian / rules
index 83f3a53f76f04744f5d71ce45ec74145e5ba5b1d..028b548f31990072a505fc75f3818cd60abd8ccd 100755 (executable)
@@ -12,8 +12,8 @@ prebuild:
        git log > ChangeLog
        git commit -n ChangeLog debian/changelog \
                -m "update changelogs for Debian build"
-       git tag debian/$(DEB_VERSION)
-       git push --tags origin master
+#      git tag debian/$(DEB_VERSION)
+#      git push --tags origin master
 
 configure: configure-stamp
 configure-stamp:
@@ -21,7 +21,9 @@ configure-stamp:
        ./autogen.sh --prefix=/usr
        touch configure-stamp
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: configure-stamp  
        dh_testdir
@@ -43,6 +45,7 @@ install: build
        dh_installdirs
 
        $(MAKE) DESTDIR=$(CURDIR)/debian/altos install
+       sed -i "/dependency_libs/ s/'.*'/''/" `find debian/altos/usr/lib/altos/ -name '*.la'`
 
 binary-indep: install