update changelog for Debian build
[fw/altos] / debian / changelog
index 84801358400aa3247852eea1c144a30e9997e251..b31626efe936682ca3074770369145d5b2804180 100644 (file)
@@ -1,3 +1,258 @@
+altos (1.9.5-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altosui: Spurious ; in altos-windows.nsi.in kept out TM v3.0 ihx
+  * Add support for TLS if needed
+  * Releasing: save .map files too
+  * altos: Use state transitions to directly drive igniters
+  * altos: Add 'booster' mode for dual-deploy igniters
+  * altos/stm: Increase MISO DMA priority to very high
+  * altos: Protect shared storage_data with mutex
+  * altos: Support flash parts > 8MB
+  * altos: Use new ao_spi_speed inline to set SPI speeds using spec'd frequencies
+  * altosui: Re-set pad orientation labels after product name is set
+  * altos/stmf0, stm32f0: Call ao_boot_chain to start application
+  * altos/stm: Fix stack validation code
+  * altos: Fix a bunch of time variables to be AO_TICK_TYPE
+  * altos: Add initial stm32l0 support
+  * altos: Switch micropeak v2.0 to stm32l0
+  * altos: Declare ao_delay_until API in ao.h
+  * altos: Move empty ao_mutex_get/put to ao_notask.h
+  * altos: Add ao_delay_until to ao_notask
+  * remove ao_delay_until from ao.h
+  * altos/ao_storage: allow erased byte value to be set by application
+  * altos/ao_storage: Allow apps to #define storage parameters
+  * altos: Micropeak v2.0 doesn't have a flash loader anymore
+  * altos/stm32l0: More DMA fixes
+  * altos/stm32l0: Some device addrs were wrong
+  * altos/stm32l0: Get SPI driver working
+  * altos/stm32l0: Get exti working
+  * altos/stm32l0: Remove some unused code in USART driver
+  * altos/stm32l0: Remove some unused code in ao_timer.c
+  * altos/stm32l0: Add adc and flash drivers
+  * altos/micropeak-v2.0: Finish hardware bring-up
+  * altos/stm32l0: Provide ao_spi_speed inline as per new clocking API
+  * altos/stm32l0: Add LPUART driver
+  * altos: add noreturn attribute to ao_panic
+  * ao-tools: Add TeleGPS log parsing to ao-eeprom
+  * altos: Remove ao_led_toggle API from general code
+  * altos: Remove support for !HAS_TASK_QUEUE
+  * altos/stm32l0: Big update in functionality
+  * altos: Add MicroPeak v2.0 support to ao_log_micro
+  * altos/micropeak-v2.0: Functionally complete.
+  * altos/mpusb-v3.0: Make this build again
+  * micropeak: Check for empty data when fetching log
+  * micropeak: Fix top-level window building
+  * micropeak: Add support for MicroPeak v2.0
+  * altos: Don't report inhibited pyro channels as fired
+  * altos: Allow multiple manual firing of main/drogue channels
+  * altoslib: Don't fetch config data for every idle status
+  * altoslib: Flush output when disabling remote
+  * altoslib: Improve configuration performance over remote link
+  * altosui: Improve configuration save feedback
+  * doc: Fix spelling error in updating-firmware section.
+  * altoslib: Deal with reflashing EasyMega boards with ancient firmware
+  * altosuilib: Allow config to be missing in rom config dialog
+  * libaltos: Map generic windows device names to actual names
+  * altoslib: Set default logging directory to $HOME/AltusMetrum
+  * macosx: Hack JavaApplicationStub to set freetype properties
+  * windows: Point windows users at adoptopenjdk.net by default
+  * altosuilib: Make dialogs mostly scrollable
+  * macosx: Update macosx install script
+  * libaltos: Update to support Mac OS X 10.15 (catalina)
+  * altoslib: Print more helpful debug messages when checking rom version
+  * doc: Add 1.9.5 release notes
+  * altosdroid: Copy generated .apks to bin directory
+  * altosui: Work around lack of actual USB product names on Windows
+  * Version 1.9.5
+
+  [ Bdale Garbee ]
+  * ao-bringup: ensure TeleMega turnon scripts are using the right test versions
+  * doc: EasyMotor and EasyTimer have the same mounting geometry as EasyMini
+  * fix broken TeleBT turnon script
+  * docs: fix horrible typo in TeleLaunch configuration section
+  * docs: add explicit admonition about avoiding 'c f' when configuring TeleLaunch
+  * debian: stop delivering gdm and slim theme materials, since we don't use them
+  * releasing 1.9.5
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 30 Sep 2020 00:19:56 -0600
+
+altos (1.9.4-2) unstable; urgency=medium
+
+  * eliminate old explicit run-time dep on libjson-c4, closes: #966562
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 05 Aug 2020 11:27:40 -0600
+
+altos (1.9.4-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * ao-bringup: first cut at turn-on scripts for EasyTimer v1
+  * releasing 1.9.4
+
+  [ Keith Packard ]
+  * Add telemetrum v3.0 firmware to release
+  * altos: Reduce flash temp buffer to make space for Em v1.0 ISR stack
+  * altos: Make AO_STORAGE_TEST use a separate buffer
+  * doc: Doc updates for 1.9.4
+  * Version 1.9.4
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 02 Jul 2020 20:22:56 -0600
+
+altos (1.9.3-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos: add APRS 'offset' value to set APRS transmision time
+  * altoslib, altosui, telegps: Add configuration support for APRS offset
+  * doc: Document APRS offset configuration value
+  * doc: start release notes for 1.9.3
+  * map-server: Create Manifest.txt at build time
+  * altosui: Report baro ground alt for 'Pad Altitude' when GPS missing
+  * Start release notes for 1.9.4
+  * ao-tools: Use array indexing instead of addition to make gcc-10 happy
+  * ao-tools: Declare ao_verbose as extern in shared header.
+  * debian: Switch debian dependency to picolibc
+  * altos/stm: Make ao_eeprom_total a #define instead of a const variable
+  * Create map file for all programs
+  * altos/lpc: Add explicit defines for all register groups
+  * ignore .map files
+  * altos: Move from newlib-nano to picolibc
+  * Mark stm_interrupt_vector as const so it is READONLY
+  * ao-tools/ao-usbload: stubs in man page for missing options
+  * altos: Allow MPU9250 SPI speed to be set by application
+  * altos: Allow accel-only flight code
+  * altos: Allow igniter status beeping with only 'extra' channels
+  * altos: Allow BMX160 to be used as primary accel
+  * altos: Allow flight support without logging
+  * altos: Build easytimer-v1 by default
+  * altos: Fix ao_ignite.c to work without HAS_IGNITE
+  * easytimer-v1: Enable pyro commands
+  * altos: Initialize pyro code for easytimer-v1
+  * altoslib: Remember flight list in AltosConfigData
+  * altosui: Adjust max log setting for storage block size
+  * altos: Move ao_storage_erase to shared code. Add len
+  * altos: Round selected log size down to ao_storage_block multiple
+  * altos: Handle flight_log_max not being multiple of ao_storage_block
+  * altos: Leave accel data in ring raw; swap for orientation on fetch
+  * Add EasyTimer configuration support
+  * altoslib: Add EasyTimer idle monitor support
+  * Add some release note notes
+  * altoslib: Fix easytimer voltage conversions
+  * altosui: Remove six-axis pad orientation for easy timer
+  * altos: Don't include baro-specific config values for easytimer
+  * altos: Fix HAS_FLIGHT_DEBUG for easytimer
+  * doc: Avoid mis-interpretation of '+' in device wiring tables
+  * doc: Update for EasyTimer
+  * Check for picolibc when testing arm compilers
+  * Add EasyTimer firmware to packages and Releasing
+  * map-server: Manifest files are generated now
+  * altos/test: Ignore ao_flight_test_mini binary
+  * altos: Remove newlib-nano defines from Makedefs.in
+  * altos: Fix printf format mis-matches
+  * altos: Leave floating printf enabled on m3 devices
+  * Update 1.9.3 release notes
+  * doc: Update doc for 1.9.3
+  * Version 1.9.3
+
+  [ Bdale Garbee ]
+  * point turnon_telemetrum_v2 to correct test script for v2.0
+  * altos: add easytimer-v1 source directory
+  * releasing 1.9.3
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 15 Jun 2020 20:36:15 -0600
+
+altos (1.9.2-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * Releasing: capture notes from 1.9.1 release
+  * Releasing: add TeleMetrum v3.0 firmware to production list
+  * doc: update copyright year in footers, note need to check this doc/RELNOTEs
+  * update info on using separate pyro batteries to encourage including a switch
+  * update TeleMega production scripts for v4.0
+  * include TeleMega v4 in list of firmware included in fat build and LLC repo
+  * update copyright assertion in TeleLaunch manual
+  * update ChangeLog for release 1.9.2
+
+  [ Keith Packard ]
+  * altos: Initial bits for TeleMega v4.0
+  * altos: Build TeleMega v4.0 bits
+  * altos: Use AO_TICK_TYPE/AO_TICK_SIGNED for lco/pad code
+  * altos: Make debug telemini firmware a bit easier to build
+  * altos: TeleMini beeper is on Tim2 CH4, not Tim3 CH4
+  * altos: Disable ao_btm debug. Avoids breaking 's' command
+  * altos: Always start application if boot pin isn't in use
+  * Generate altosdroid/app/build.gradle at configure time
+  * Force using opensdk-8 to build altosdroid
+  * Bump altosdroid version to 20, always build release apk
+  * Use 'must' instead of 'should' in reference to switch for pyro battery
+  * altosdroid: Switch to NotificationCompat
+  * altosdroid: Request fine location permission if not already granted
+  * altosdroid: Check if the telem service is running when bluetooth gets enabled
+  * Bump version to build a new android app -- 1.9.1c
+  * altosdroid: Add text size selection
+  * Bump version to build a new android app (23)
+  * altosdroid: Use custom dialog themes for all dialogs
+  * altosdroid: Fix a pile of compile warnings
+  * altosdroid: Change tracker selection dialog
+  * altosdroid: Ignore 'build.gradle', which is built from a .in file
+  * altosdroid: Add helper 'makefile'
+  * altosui: Set idle mode frequency before starting link
+  * altosdroid: When the user switches frequency, look for something there
+  * Bump version to build a new android app (25)
+  * altosdroid: Use select tracker dialog when deleting a tracker
+  * altosdroid: Make frequency changes during idle mode work
+  * altosdroid: Change layout of idle mode dialog a bit
+  * altoslib: Reset consecutive GPS count when GPS bad
+  * altos: Fix wiring mistakes for TeleMega v4.0
+  * altos: Add new telemetry packet format for TeleMega v4
+  * altos: Create new log format for TeleMega v4
+  * altoslib: Add 'gauss' units for magnetic field strength
+  * altosuilib: Add fourth column to info table
+  * altoslib: Store IMU accel ground data in converted values
+  * altoslib: Add support for TeleMega v4
+  * altoslib: Move 'state_name' API to AltosCalData
+  * altoslib: Report whether GPS data contains new location/sat info
+  * altoslib: Re-initialize cal data for eeprom record set
+  * altoslib: Report raw baro height instead of kalman filtered value
+  * altosuilib: Put units on GPS altitude and height in info table
+  * altoslib: Pass all flight records while reading telem file
+  * doc: updates for 1.9.2
+  * altosui: Add TeleMega v4.0 firmware to altosui packaged bits
+  * altosuilib: Eliminate a couple java compiler warnings
+  * Bump version for new android upload
+  * altos: Log BMX160 data when present
+  * altos: Copy BMX160 data to data ring
+  * altos: Get BMX160 initialized correctly
+  * altoslib: Remove ADXL375 debug noise
+  * ao-tools: Add TeleMega v4.0 to ao-eeprom
+  * altos: Init BMX160 more carefully
+  * altoslib: Correct IMU axes for telemetry data
+  * ao-tools: Handle TeleMega v4.0 telemetry in ao-telem
+  * altos: Adjust comment about how the BMX160 is oriented
+  * altos/altoslib: BMX160 Y axis gyro direction is opposite from MPU
+  * altoslib: Fix Tmega v4 eeprom parsing
+  * libaltos: Delay freeing serial device until not busy
+  * altoslib: Correct sign of telemega v4 pitch
+  * altoslib: Remove hard-coded accel scale for mega eeprom
+  * altosuilib, altoslib: Add azimuth and compass to reports
+  * altos/telemega-4.0: Fix signs of IMU pitch and mag across
+  * altos/bmx160: Compute µT in bmx160 driver using trim data
+  * altoslib: BMX160 driver now returns µT values for mag sensor
+  * Bump java lib versions in preparation for 1.9.2
+  * Set doc version and date from package version and release date
+  * Bump version to 1.9.2, android 27
+  * Bump java lib versions in preparation for 1.9.2
+  * altoslib: Add TeleMega-v4 adxl375 config to AltosConfigData
+  * Bump version to 1.9.2, android 27
+  * Set doc version and date from package version and release date
+  * Bump java lib versions in preparation for 1.9.2
+  * Bump version to 1.9.2, android 27
+  * altoslib: Remove debug printf from AltosIMU.java
+  * libaltos: Create altos_pause_one_second API
+  * Bump java lib versions in preparation for 1.9.2
+  * Bump version to 1.9.2, android 27
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 25 Feb 2020 23:58:43 -0700
+
 altos (1.9.1-1) unstable; urgency=medium
 
   [ Bdale Garbee ]