update changelog for Debian build
[fw/altos] / debian / changelog
index 46958fa16fb86974f0760049c797a2ae7f5ea052..b31626efe936682ca3074770369145d5b2804180 100644 (file)
@@ -1,3 +1,464 @@
+altos (1.9.5-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altosui: Spurious ; in altos-windows.nsi.in kept out TM v3.0 ihx
+  * Add support for TLS if needed
+  * Releasing: save .map files too
+  * altos: Use state transitions to directly drive igniters
+  * altos: Add 'booster' mode for dual-deploy igniters
+  * altos/stm: Increase MISO DMA priority to very high
+  * altos: Protect shared storage_data with mutex
+  * altos: Support flash parts > 8MB
+  * altos: Use new ao_spi_speed inline to set SPI speeds using spec'd frequencies
+  * altosui: Re-set pad orientation labels after product name is set
+  * altos/stmf0, stm32f0: Call ao_boot_chain to start application
+  * altos/stm: Fix stack validation code
+  * altos: Fix a bunch of time variables to be AO_TICK_TYPE
+  * altos: Add initial stm32l0 support
+  * altos: Switch micropeak v2.0 to stm32l0
+  * altos: Declare ao_delay_until API in ao.h
+  * altos: Move empty ao_mutex_get/put to ao_notask.h
+  * altos: Add ao_delay_until to ao_notask
+  * remove ao_delay_until from ao.h
+  * altos/ao_storage: allow erased byte value to be set by application
+  * altos/ao_storage: Allow apps to #define storage parameters
+  * altos: Micropeak v2.0 doesn't have a flash loader anymore
+  * altos/stm32l0: More DMA fixes
+  * altos/stm32l0: Some device addrs were wrong
+  * altos/stm32l0: Get SPI driver working
+  * altos/stm32l0: Get exti working
+  * altos/stm32l0: Remove some unused code in USART driver
+  * altos/stm32l0: Remove some unused code in ao_timer.c
+  * altos/stm32l0: Add adc and flash drivers
+  * altos/micropeak-v2.0: Finish hardware bring-up
+  * altos/stm32l0: Provide ao_spi_speed inline as per new clocking API
+  * altos/stm32l0: Add LPUART driver
+  * altos: add noreturn attribute to ao_panic
+  * ao-tools: Add TeleGPS log parsing to ao-eeprom
+  * altos: Remove ao_led_toggle API from general code
+  * altos: Remove support for !HAS_TASK_QUEUE
+  * altos/stm32l0: Big update in functionality
+  * altos: Add MicroPeak v2.0 support to ao_log_micro
+  * altos/micropeak-v2.0: Functionally complete.
+  * altos/mpusb-v3.0: Make this build again
+  * micropeak: Check for empty data when fetching log
+  * micropeak: Fix top-level window building
+  * micropeak: Add support for MicroPeak v2.0
+  * altos: Don't report inhibited pyro channels as fired
+  * altos: Allow multiple manual firing of main/drogue channels
+  * altoslib: Don't fetch config data for every idle status
+  * altoslib: Flush output when disabling remote
+  * altoslib: Improve configuration performance over remote link
+  * altosui: Improve configuration save feedback
+  * doc: Fix spelling error in updating-firmware section.
+  * altoslib: Deal with reflashing EasyMega boards with ancient firmware
+  * altosuilib: Allow config to be missing in rom config dialog
+  * libaltos: Map generic windows device names to actual names
+  * altoslib: Set default logging directory to $HOME/AltusMetrum
+  * macosx: Hack JavaApplicationStub to set freetype properties
+  * windows: Point windows users at adoptopenjdk.net by default
+  * altosuilib: Make dialogs mostly scrollable
+  * macosx: Update macosx install script
+  * libaltos: Update to support Mac OS X 10.15 (catalina)
+  * altoslib: Print more helpful debug messages when checking rom version
+  * doc: Add 1.9.5 release notes
+  * altosdroid: Copy generated .apks to bin directory
+  * altosui: Work around lack of actual USB product names on Windows
+  * Version 1.9.5
+
+  [ Bdale Garbee ]
+  * ao-bringup: ensure TeleMega turnon scripts are using the right test versions
+  * doc: EasyMotor and EasyTimer have the same mounting geometry as EasyMini
+  * fix broken TeleBT turnon script
+  * docs: fix horrible typo in TeleLaunch configuration section
+  * docs: add explicit admonition about avoiding 'c f' when configuring TeleLaunch
+  * debian: stop delivering gdm and slim theme materials, since we don't use them
+  * releasing 1.9.5
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 30 Sep 2020 00:19:56 -0600
+
+altos (1.9.4-2) unstable; urgency=medium
+
+  * eliminate old explicit run-time dep on libjson-c4, closes: #966562
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 05 Aug 2020 11:27:40 -0600
+
+altos (1.9.4-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * ao-bringup: first cut at turn-on scripts for EasyTimer v1
+  * releasing 1.9.4
+
+  [ Keith Packard ]
+  * Add telemetrum v3.0 firmware to release
+  * altos: Reduce flash temp buffer to make space for Em v1.0 ISR stack
+  * altos: Make AO_STORAGE_TEST use a separate buffer
+  * doc: Doc updates for 1.9.4
+  * Version 1.9.4
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 02 Jul 2020 20:22:56 -0600
+
+altos (1.9.3-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos: add APRS 'offset' value to set APRS transmision time
+  * altoslib, altosui, telegps: Add configuration support for APRS offset
+  * doc: Document APRS offset configuration value
+  * doc: start release notes for 1.9.3
+  * map-server: Create Manifest.txt at build time
+  * altosui: Report baro ground alt for 'Pad Altitude' when GPS missing
+  * Start release notes for 1.9.4
+  * ao-tools: Use array indexing instead of addition to make gcc-10 happy
+  * ao-tools: Declare ao_verbose as extern in shared header.
+  * debian: Switch debian dependency to picolibc
+  * altos/stm: Make ao_eeprom_total a #define instead of a const variable
+  * Create map file for all programs
+  * altos/lpc: Add explicit defines for all register groups
+  * ignore .map files
+  * altos: Move from newlib-nano to picolibc
+  * Mark stm_interrupt_vector as const so it is READONLY
+  * ao-tools/ao-usbload: stubs in man page for missing options
+  * altos: Allow MPU9250 SPI speed to be set by application
+  * altos: Allow accel-only flight code
+  * altos: Allow igniter status beeping with only 'extra' channels
+  * altos: Allow BMX160 to be used as primary accel
+  * altos: Allow flight support without logging
+  * altos: Build easytimer-v1 by default
+  * altos: Fix ao_ignite.c to work without HAS_IGNITE
+  * easytimer-v1: Enable pyro commands
+  * altos: Initialize pyro code for easytimer-v1
+  * altoslib: Remember flight list in AltosConfigData
+  * altosui: Adjust max log setting for storage block size
+  * altos: Move ao_storage_erase to shared code. Add len
+  * altos: Round selected log size down to ao_storage_block multiple
+  * altos: Handle flight_log_max not being multiple of ao_storage_block
+  * altos: Leave accel data in ring raw; swap for orientation on fetch
+  * Add EasyTimer configuration support
+  * altoslib: Add EasyTimer idle monitor support
+  * Add some release note notes
+  * altoslib: Fix easytimer voltage conversions
+  * altosui: Remove six-axis pad orientation for easy timer
+  * altos: Don't include baro-specific config values for easytimer
+  * altos: Fix HAS_FLIGHT_DEBUG for easytimer
+  * doc: Avoid mis-interpretation of '+' in device wiring tables
+  * doc: Update for EasyTimer
+  * Check for picolibc when testing arm compilers
+  * Add EasyTimer firmware to packages and Releasing
+  * map-server: Manifest files are generated now
+  * altos/test: Ignore ao_flight_test_mini binary
+  * altos: Remove newlib-nano defines from Makedefs.in
+  * altos: Fix printf format mis-matches
+  * altos: Leave floating printf enabled on m3 devices
+  * Update 1.9.3 release notes
+  * doc: Update doc for 1.9.3
+  * Version 1.9.3
+
+  [ Bdale Garbee ]
+  * point turnon_telemetrum_v2 to correct test script for v2.0
+  * altos: add easytimer-v1 source directory
+  * releasing 1.9.3
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 15 Jun 2020 20:36:15 -0600
+
+altos (1.9.2-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * Releasing: capture notes from 1.9.1 release
+  * Releasing: add TeleMetrum v3.0 firmware to production list
+  * doc: update copyright year in footers, note need to check this doc/RELNOTEs
+  * update info on using separate pyro batteries to encourage including a switch
+  * update TeleMega production scripts for v4.0
+  * include TeleMega v4 in list of firmware included in fat build and LLC repo
+  * update copyright assertion in TeleLaunch manual
+  * update ChangeLog for release 1.9.2
+
+  [ Keith Packard ]
+  * altos: Initial bits for TeleMega v4.0
+  * altos: Build TeleMega v4.0 bits
+  * altos: Use AO_TICK_TYPE/AO_TICK_SIGNED for lco/pad code
+  * altos: Make debug telemini firmware a bit easier to build
+  * altos: TeleMini beeper is on Tim2 CH4, not Tim3 CH4
+  * altos: Disable ao_btm debug. Avoids breaking 's' command
+  * altos: Always start application if boot pin isn't in use
+  * Generate altosdroid/app/build.gradle at configure time
+  * Force using opensdk-8 to build altosdroid
+  * Bump altosdroid version to 20, always build release apk
+  * Use 'must' instead of 'should' in reference to switch for pyro battery
+  * altosdroid: Switch to NotificationCompat
+  * altosdroid: Request fine location permission if not already granted
+  * altosdroid: Check if the telem service is running when bluetooth gets enabled
+  * Bump version to build a new android app -- 1.9.1c
+  * altosdroid: Add text size selection
+  * Bump version to build a new android app (23)
+  * altosdroid: Use custom dialog themes for all dialogs
+  * altosdroid: Fix a pile of compile warnings
+  * altosdroid: Change tracker selection dialog
+  * altosdroid: Ignore 'build.gradle', which is built from a .in file
+  * altosdroid: Add helper 'makefile'
+  * altosui: Set idle mode frequency before starting link
+  * altosdroid: When the user switches frequency, look for something there
+  * Bump version to build a new android app (25)
+  * altosdroid: Use select tracker dialog when deleting a tracker
+  * altosdroid: Make frequency changes during idle mode work
+  * altosdroid: Change layout of idle mode dialog a bit
+  * altoslib: Reset consecutive GPS count when GPS bad
+  * altos: Fix wiring mistakes for TeleMega v4.0
+  * altos: Add new telemetry packet format for TeleMega v4
+  * altos: Create new log format for TeleMega v4
+  * altoslib: Add 'gauss' units for magnetic field strength
+  * altosuilib: Add fourth column to info table
+  * altoslib: Store IMU accel ground data in converted values
+  * altoslib: Add support for TeleMega v4
+  * altoslib: Move 'state_name' API to AltosCalData
+  * altoslib: Report whether GPS data contains new location/sat info
+  * altoslib: Re-initialize cal data for eeprom record set
+  * altoslib: Report raw baro height instead of kalman filtered value
+  * altosuilib: Put units on GPS altitude and height in info table
+  * altoslib: Pass all flight records while reading telem file
+  * doc: updates for 1.9.2
+  * altosui: Add TeleMega v4.0 firmware to altosui packaged bits
+  * altosuilib: Eliminate a couple java compiler warnings
+  * Bump version for new android upload
+  * altos: Log BMX160 data when present
+  * altos: Copy BMX160 data to data ring
+  * altos: Get BMX160 initialized correctly
+  * altoslib: Remove ADXL375 debug noise
+  * ao-tools: Add TeleMega v4.0 to ao-eeprom
+  * altos: Init BMX160 more carefully
+  * altoslib: Correct IMU axes for telemetry data
+  * ao-tools: Handle TeleMega v4.0 telemetry in ao-telem
+  * altos: Adjust comment about how the BMX160 is oriented
+  * altos/altoslib: BMX160 Y axis gyro direction is opposite from MPU
+  * altoslib: Fix Tmega v4 eeprom parsing
+  * libaltos: Delay freeing serial device until not busy
+  * altoslib: Correct sign of telemega v4 pitch
+  * altoslib: Remove hard-coded accel scale for mega eeprom
+  * altosuilib, altoslib: Add azimuth and compass to reports
+  * altos/telemega-4.0: Fix signs of IMU pitch and mag across
+  * altos/bmx160: Compute µT in bmx160 driver using trim data
+  * altoslib: BMX160 driver now returns µT values for mag sensor
+  * Bump java lib versions in preparation for 1.9.2
+  * Set doc version and date from package version and release date
+  * Bump version to 1.9.2, android 27
+  * Bump java lib versions in preparation for 1.9.2
+  * altoslib: Add TeleMega-v4 adxl375 config to AltosConfigData
+  * Bump version to 1.9.2, android 27
+  * Set doc version and date from package version and release date
+  * Bump java lib versions in preparation for 1.9.2
+  * Bump version to 1.9.2, android 27
+  * altoslib: Remove debug printf from AltosIMU.java
+  * libaltos: Create altos_pause_one_second API
+  * Bump java lib versions in preparation for 1.9.2
+  * Bump version to 1.9.2, android 27
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 25 Feb 2020 23:58:43 -0700
+
+altos (1.9.1-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * updates to Releasing based on 1.9 release process learnings
+  * doc: add flash-force instructions for TeleBT v3.0
+  * doc: add force-bootloader instructions for TeleGPS v1 and v2
+  * altos: add support for telefireeight-v2.0
+  * altos: add telefireeight-v2.0 to src/Makefile and to Releasing
+  * Makefiles, too
+  * altos: add initial support for TeleFireOne v2.0
+  * altos: ADS124S0X driver compiles with initialization code maybe completed
+  * altos: first cut of code for telefireone-v2.0
+  * doc: new TeleLaunch system manual
+  * doc: actually add the telelaunch files
+  * altos: first cut at ADS124S0X driver interrupt handling
+  * altos: fix ads124s0x data structure
+  * altos: ADS124S0X driver compiles now
+  * altos: snapshot - working on ads124x0x driver
+  * altos: ads124s0x successfully reading data
+  * add an explicit reference to Poron open-cell foam in Appendix A
+  * ao-bringup: add a turnon_telefireeight script
+  * TeleFireEight has simple green LEDs for continuity
+  * doc: add more text to TeleLaunch manual, be less sloppy with dBm assertions
+  * doc: add some text to TeleLaunch troubleshooting about SAFE/ARM on TeleFire
+  * doc: add some text about cross-bank drag race safe/arm to TeleLaunch manual
+  * altosui: add monitor idle support for TeleMetrum v3
+  * altosui: add TeleMetrum v3 to delivered firmware list
+  * altosuilib: TeleMetrum v3, like v2, doesn't use flash for config
+  * ao-bringup: add production test support for TeleMetrum v3.0
+  * start the process of releasing 1.9.1
+  * update release date in all documents
+  * update ChangeLog for 1.9.1 release
+
+  [ Keith Packard ]
+  * doc: Update all docs to 1.9. Note this in doc/RELNOTES
+  * ao-tools: Add lots of compiler warning flags to ao-tools build
+  * ao-tools: Fix warnings in ao-tools
+  * ao-tools/ao-load: Return status from 'rewrite'
+  * ao-tools/ao-cal-accel: Initialize byte count var 'l'
+  * ao-tools/ao-telem: Print out 'log_max' value. Clean up compiler warnings.
+  * Remove ao-chaosread
+  * doc: Fix typo in TeleBT v3 flash-force instructions
+  * altos: Delete unused config bits for telefireeight-v2.0. Add Makefile
+  * altos/telefireeight-v2.0: Add flash loader Makefile
+  * Use strip-nondeterminism to fix JAR timestamps
+  * altos: Fix spelling of stm_dma_ch4_5_6_isr
+  * altos/stm: Note that ao_i2c_recv_dma_isr isn't actually used
+  * altos: Mark local functions 'static'
+  * altos: Declare all public functions in header files
+  * altos: Add 'void' to function declarations with no params.
+  * altos: Stop doing pointer arith on void *
+  * altos: Remove unused ao_adc_get from ao_adc_stm.c
+  * altos: Declare task stack as union of uint8_t and uint32_t
+  * altos: Add a pile more compiler warnings
+  * stm: Expose LCD font API in ao_lcd_font.h
+  * ao-bringup: chaosread is no longer part of altos
+  * ao-tools/ao-dump-up: Document --wait flag
+  * altos/stm-demo: Make this build again after various API and CFLAGS changes
+  * altos: Add -Wshadow to CFLAGS
+  * altos/attiny: Mark 'mode' param to ao_exti_setup_port as used
+  * altos: Move common build definitions to src/Makefile.defs
+  * altos: Remove AO_LOG_STATE from ao_log_telefiretwo
+  * altos/telefireone-v1.0: Doesn't have a beeper
+  * altos/telefireone-v1.0: Clean up Makefile
+  * altos/telefireone-v1.0: Turn off USE_INTERNAL_FLASH
+  * altos/telefireone-v1.0: Set AO_LOG_FORMAT
+  * altos/telefireone-v1.0: Set various ADC values
+  * altos/telefireone-v1.0: Track ao_led_init API change
+  * altos: Build telefireone-v1.0 by default
+  * altos/telefireone-v2.0: Remove build of ao_product.h from Makefile
+  * altos: Fix ISR declarations to make them non-weak
+  * altos: Allow applications to override newlib printf selection
+  * altos: Fix several mis-specified time types
+  * altos: Change default time type to 32-bits
+  * altos: add ao_time_ns API
+  * doc: A few minor edits to telelaunch docs
+  * altos/drivers/ao_led.c: Declare LED port as void * to allow any SoC to use this code
+  * altos: ARM ABI requires 8-byte aligned stack
+  * altos/stm32f4: Add -mfloat-abi=hard compile option
+  * altos/stm32f4: Need to read-back register after clock enable
+  * altos/stm32f4: Wrong value for CK48MSEL_PLL_Q
+  * altos/stm32f4: Working on USB
+  * altos/stm32f4-disco: Remove scheme
+  * doc: Document LEDs on TeleGPS devices
+  * doc: Make sure all 'code' examples are in DejaVu Sans Mono
+  * altos: Use ao_data_accel_invert when changing orientation value
+  * altoslib: Fetch correct mag along data for EasyMega v2
+  * altoslib: Correct monitor idle IMU data for EasyMega v2
+  * altos/lambdakey-v1.0: Fix obvious build errors
+  * altos: Work on MAX6691 driver
+  * altos: get ao_max6691 driver working
+  * altos/telefireone-v2.0: Definitions needed for MAX6691 driver
+  * altos: Add MAX6691 and ADS131A0X data to ring if present
+  * altos: Change MAX6691 driver to run its own thread
+  * altos/telefireone-v2.0: Include MAX6691 data in ring
+  * altos: Add preliminary TeleStatic v3.0 code
+  * Add TeleStatic-v3.0 makefiles
+  * altos: Directly compute radio tuning values from frequency
+  * doc: Describe what sunlight does to MicroPeak and how to protect it
+  * altosui: Ship EasyMini v2.0 firwmare
+  * doc: Say 'thousands of feet' instead of '3000-4000 feet'
+  * altos: Support ao_ms5607_dump when no ms5607 task
+  * altos/micropeak-v2.0: Don't run flight code when plugged in
+  * altos/micropeak-v2.0: Wait for the power supply to stabilize before measuring
+  * altos/micropeak-v2.0: Fix LED blinking sequence at power-on
+  * altos/micropeak-v2.0: Go into standby mode after landing
+  * altoslib: Always create an ordered record set for eeprom files
+  * altosui/telegps: Display error message when attempting to graph unknown files
+  * altos/micropeak-v2.0: expose log and config commands over USB
+  * altoslib: Add support for MicroPeak v2 eeprom format
+  * altos: Don't dump MS5607 eeprom in 'B' command
+  * altos/micropeak-v2: Erase log space at end of BOOST_DELAY
+  * altos/micropeak-v2: Correct AO_LOG_ID value
+  * altos/micropeak-v2: Update .gitignore
+  * ao-tools: Change ao-eeprom into eeprom analysis tool
+  * altos: Allow ms5607 driver to either set ao_sensor_errors or panic
+  * ao-tools/ao-telem: Fix man page and usage to match code
+  * ao-tools/lib: Add atmosphere model
+  * ao-tools/ao-eeprom: Add altitude data for baro values
+  * altosuilib: Don't crash when flashing an unknown device
+  * icon: Add altosdroid-specific icon
+  * altos/stmf0: Leave power interface disabled until needed
+  * altos/stmf0: Add 'ao_serial_shutdown'
+  * altos/stmf0: Allow SPI to be powered down when idle if desired
+  * altos/micropeak-v2.0: Reduce power usage
+  * altos: Record all failed sensors and report status at power up
+  * ao-tools/ao-eeprom: Add support for TeleFireTwo
+  * altoslib: Stop using deprecated Java functionality
+  * Use discovered java path for compiler and jni include files
+  * altosdroid: Hack up build to 'work' for now
+  * altosui: Fix path to easymini-v2.0 ihx file
+  * altosui: Make it possible to disable APRS
+  * altos: Use fast timer for buttons instead of edge-triggered ISR
+  * debian: Add libjson-c4 dependency
+  * Add new altosdroid icon
+  * icon: Ignore generated LED images
+  * Add .gitignore files for new projects
+  * libaltos: gitignore btletest
+  * altosui: Display data for point nearest cursor in map view
+  * altosui: Add speed and gps height to map display data
+  * drivers: Use 'main_value' instead of 'main'
+  * altos: Replace ao_xmem functions with direct mem calls
+  * altos: Add bmx160 driver
+  * altos: Integrate BMX160 into data code
+  * altos: Add EasyMega v3.0 bits (not setup correctly yet)
+  * altos: Add missing build files for avr/attiny devices
+  * altosdroid: Update Makefile.am to run gradle-based build
+  * altos: Switch all main() to return 'int'
+  * altos: Rename 'log' in ao_log_fireone to 'ao_fireone_data'
+  * doc: Describe new 'show nearest values' in map view
+  * doc: Update for 1.9.1
+  * altoslib: Don't crash when map flight data is missing
+  * telegps: Get --graph mode working after recent changes
+  * altos/telefire: Don't arm the box if the local arm switch is off
+  * altos/test: Get test code working again after restructuring
+  * altosdroid: Make altosdroid code more resilient to weird androidisms
+  * altoslib: Don't bother adding FREETTS to CLASSPATH
+  * altos: Relabel packet receive status line for TeleFire boxes
+  * altos: Improve labeling of telefire receive packet information
+  * altoslib: Fix setting of CLASSPATH
+  * altoslib: Fix original telemetry sensor packet parsing
+  * altos: TeleMetrum v3.0 has ADXL375 and Max-8Q
+  * altoslib: Set up adxl375 for TM v3.0 in idle mode
+  * altos: Send "metrum" telemetry packets for TeleMetrum v3.0 boards
+  * ao-telem: Show all 24 bits of GPS altitude data
+  * doc: Mention TeleMetrum v3.0 in release notes for 1.9.1
+  * doc: Update docs to reference TeleMetrum v3 where appropriate
+  * altoslib: Linker script changed -> the USB desc is two bytes off
+  * altosuilib: Show the recovered product name in the Configure Rom dialog
+  * altosuilib: Wait for Windows to get ready with new device
+  * Release note about self-flashing on windows waiting for devices
+
+  [ Mike Beattie ]
+  * Remove ant build files
+  * Move java source, and resources to new paths for gradle
+  * Update files that reference new paths
+  * Add gradle build files
+  * buildinfo data comes from Makedefs now, not Version
+  * Clean up duplication in AndroidManifest.xml.in
+  * Remove versioning data from AndroidManifest.xml.in
+  * Add FOREGROUND_SERVICE permission which is now required
+  * Indentation cleanup
+  * Commented out duplicate strings
+  * Import cleanup
+  * Convert to AndroidX from support_v4
+  * Update persistent notification in TelemetryService
+  * Update Google Maps API usage.
+  * Update app to use Material Design Light theme
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 05 Dec 2019 22:45:45 -0700
+
+altos (1.9-3) unstable; urgency=medium
+
+  * cherry-pick commit that makes builds reproducible
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 03 Feb 2019 23:02:33 -0700
+
+altos (1.9-2) unstable; urgency=medium
+
+  * Revert "elide pdf files from delivered docs until ruby-asciidoctor-pdf escapes NEW"
+  * add ruby-asciidoctor-pdf to build deps
+  * cherry-pick fix for ao-cal-accel, quilt-style
+  * cherry-pick patch that fixes doc versions, quilt-style
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 04 Jan 2019 14:59:55 -0700
+
 altos (1.9-1) unstable; urgency=medium
 
   [ Bdale Garbee ]
@@ -17,6 +478,14 @@ altos (1.9-1) unstable; urgency=medium
   * update easymega turn-on script for v2.0
   * ao-bringup: get turnon_easymega working for v2.0
   * changelog for 1.9 release
+  * update changelog for Debian build
+  * use ChangeLog from branch-1.9 in unmolested form
+  * need to run autoreconf before calling dh_auto_configure
+  * elide pdf files from delivered docs until ruby-asciidoctor-pdf escapes NEW
+  * update changelog for Debian build
+  * update build dependencies to include newlib-nano, elide cc1111
+  * fix dep5 copyright syntax
+  * add lintian overrides
 
   [ Keith Packard ]
   * altosdroid: Bump version to 18 for 1.8.7
@@ -89,8 +558,9 @@ altos (1.9-1) unstable; urgency=medium
   * doc: Add 1.9 release notes
   * Change Releasing to reflect asciidoctor switch
   * Update to version 1.9
+  * doc: Skip .pdf generation when asciidoctor-pdf is missing
 
- -- Bdale Garbee <bdale@gag.com>  Wed, 02 Jan 2019 22:24:05 -0700
+ -- Bdale Garbee <bdale@gag.com>  Wed, 02 Jan 2019 23:42:19 -0700
 
 altos (1.8.7-2) unstable; urgency=medium