update changelog for Debian build
[fw/altos] / debian / changelog
index 0f637bb58a6b6d0af3689260658f3a9b34084c1d..ae7aead59eb5dd812719396bee2a5cb728f7296d 100644 (file)
@@ -1,3 +1,244 @@
+altos (1.9.15-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos: Add .gitignore for telemega v6.0
+  * altos/telemega-v6: Remove beep freq defs and use defaults
+  * altos/telemega-v6.0: bmi088 axes were wrong
+  * altoslib: Hide internals of AltosIMU
+  * altos: Fix TMega v6.0 and v5.0 IMU axes
+  * doc: Add initial 1.9.15 release notes
+  * doc: Add HW specs for TeleMega v6.0
+  * Add TeleMega v6.0 firmware to release
+  * Add TeleMetrum v4.0 firmware to releases
+  * altos/telemetrum-v4.0: Add .gitignore
+  * doc: Add TeleMetrum v4.0 to specs and 1.9.15 release notes
+  * ao-tools/ao-flash: Use 'program' instead of 'flash' for samd21
+  * Version 1.9.15
+
+  [ Bdale Garbee ]
+  * altos: add csm84clio-v0.1 firmware
+  * altos: re-number csm85clio outputs 0..49 to match schematic and silkscreen
+  * ao-bringup: turnon and test scripts for TeleMetrum v4.0 & TeleMega v6.0
+  * releasing 1.9.15
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 19 Feb 2023 18:29:00 -0700
+
+altos (1.9.14-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * drivers/cc1200: Don't disable cc1200 interrupts ever
+  * altos/telefiretwo-v0.2: Get things building again
+  * altos/drivers: Use spi duplex to fetch register values
+  * altos/drivers: Increase LCO receive timeout to 20ms
+  * doc: Release notes for 1.9.14
+  * Version 1.9.14
+
+  [ Bdale Garbee ]
+  * ChangeLog for releas 1.9.14
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 02 Feb 2023 12:55:20 -0700
+
+altos (1.9.13-2) unstable; urgency=medium
+
+  * drop the suggests on slim | gdm, it's just no useful
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 29 Jan 2023 15:11:04 -0700
+
+altos (1.9.13-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altos: Switch LED pin number to 8 bits
+  * altos: Use -ffunction-sections -fdata-sections
+  * altos: Add SAMD21 bits
+  * altos: Add sample samd21 application for snekboard
+  * ao-tools: Add ao-flash-samd21 script
+  * altos/samd21: Add register definitions
+  * altos/samd21: Get USB driver working in AltOS
+  * altos/samd21: Automatically erase flash when writing
+  * altos/snekboard: Indicate that USB is used for stdio
+  * altos: Switch LED pin number to 8 bits
+  * altos: Use --gc-sections
+  * altos: Add SAMD21 bits
+  * altos: Add sample samd21 application for snekboard
+  * ao-tools: Add ao-flash-samd21 script
+  * altos/samd21: Add register definitions
+  * altos/samd21: Get USB driver working in AltOS
+  * altos/samd21: Automatically erase flash when writing
+  * altos/snekboard: Indicate that USB is used for stdio
+  * Add option to beep max height in feet rather than just meters
+  * altos: Get SAMD21 SPI driver working in non-DMA mode
+  * snekboard: Add samd21 SPI test function
+  * This is what I'm using locally for flashing samd21 parts
+  * samd21: Configure ROM/RAM values per device and provide linker scripts for each
+  * altos: Add metro-m0 port for SAMD21G18 testing
+  * samd21: Fix up DMA driver
+  * samd21: Avoid divides in boot loader
+  * samd21: Fix value defines to be unsigned long
+  * samd21: Use DMA for SPI send
+  * snekboard: Need DMA for SPI now.
+  * samd21: Macro-ize the DMA register settings a bit
+  * samd21: Add ability to use arbitrary pin configs with SPI
+  * metro-m0: Configure on-board SPI flash part
+  * altos/ms5607: Use ao_gpio_set instead of stm_gpio_set
+  * samd21: Get ADC code compiling
+  * samd21: Add SPI configurations used by TM v4.0
+  * samd21: Get serial driver building
+  * altos/telemetrum-v4.0: Almost building
+  * samd21: Shrink default stack to 512 bytes
+  * samd21: Stub out exti code
+  * samd21: Stub out beep code
+  * altos/telemetrum-v4.0: It links
+  * samd21: Wire up pin interrupts
+  * metro-m0: Demo pin interrupts
+  * samd21: Get beep code working
+  * samd21: Move DMA channel defs to ao_dma_samd21.h
+  * samd21: Hook up AltOS timer functionality
+  * samd21: Hook up AltOS style ADC
+  * metro-m0: Hook up ADC sample from A pins
+  * telemetrum-v4.0: Add beeper and fix ADC defs
+  * telemetrum-v4.0: Remove unused file
+  * drivers/ublox: Clean up some debug mode code
+  * samd21: Leave serial RX interrupts enabled
+  * metro-m0: Add GPS support
+  * telemetrum-v4.0: Set USE_SERIAL_1_STDIN to 0
+  * telegps: Copy altosui 'beep feet' bits to telegps
+  * altos/ms5607: Use duplex for fetching data
+  * samd21: PA20 maps to SERCOM3.2 not SERCOM3.3
+  * samd21: Limit SPI baud value to 1
+  * samd21: Restore pin cfg when exti is disabled
+  * samd21: AO_SPI_0_PA04_PA05_PA06 is FUNC_D
+  * fixup for exti restore
+  * telemetrum-v4.0: MS5607 doesn't share SPI controller
+  * telemetrum-v4.0: Correct beeper configuration
+  * altos/cc1200: Simplify interrupt handling
+  * altos: Avoid modulus in task queue on parts without idiv
+  * samd21: Save interrupt pin status before enabling interrupts
+  * attiny, stm32l0: Note that these chips don't support spi duplex
+  * altos: Add ao_gps_utc_tick
+  * altos/ms5607: Fixup ms5607 changes for other chips
+  * altos: Make sure APRS packets are reasonably separated
+  * altos: Enable telemetrum telemetry for telemetrum v4.0
+  * altoslib: Handle TeleMetrum v4.0 in idle mode
+  * Add TeleMetrum v4.0 to release files
+  * ao-tools/ao-eeprom: Add support for TeleMega v5.0
+  * altoslib: Add notes about updating ao-eeprom for new product
+  * altos: Add timeout for MS5607 ADC conversion
+  * easymotor-v3.0: Use motor pressure to trigger data logging
+  * easymotor-v3.0: Clean up build bits
+  * altos/stm: Add ao_spi_put_pins for MS5607 driver
+  * altos/stmf0: Add ao_spi_put_pins for MS5067 driver
+  * altos: Add timeout in MS5607 get_sample code
+  * drivers: Add BMI088 driver
+  * altos: Add BMI088 test framework using Nucleo32 board for stm32f042
+  * altos: Add TeleMega v6.0
+  * doc: Update docs for asciidoctor-pdf version 2.x
+  * src/drivers: Ignore printf warnings in ao_aprs.c
+  * drivers: Add AO_LOG_NORMALIZED support to BMI088 command
+  * altos: Split AO_LOG_NORMALIZED support out in telemetry code
+  * ao-tools: Fix buffer overflow in lib/ao-hex.c
+  * ao-tools: Update ao-eeprom for TeleMega v6
+  * altoslib: Add TeleMega v6 support
+  * altos/telelco: Add some debug aids for TeleLCO event stuff
+  * easymotor-v3: Fix pressure to adc conversion to use reference voltage
+  * altos/easymotor: Move pressure conversion code to ao_motor_flight.c
+  * altos: Add makefiles for telemega v6
+  * doc: Add release notes for 1.9.13
+  * doc: Update copyright year to 2023
+  * Version 1.9.13
+  * Disable TM v4.0 firmware for 1.9.13
+  * doc: Add release notes for 1.9.13
+  * doc: Update copyright year to 2023
+  * Version 1.9.13
+
+  [ Bdale Garbee ]
+  * first stab at support for TeleMetrum v4.0
+  * update Releasing with tweaks made during 1.9.12 release process
+  * easymini v3.0 production scripts working
+  * EasyMotor v3 production script working, sans pressure input test
+  * ao-tools: don't do 'm 0' after 'E 0' since EasyMotor doesn't support it
+  * update Releasing to include EasyMini v3.0 loader
+  * ao-tools: new ao-test-pressure utility for bench testing EasyMotor
+  * ao-bringup: final production test script for EasyMotor v3
+  * ao-tools: increase robustness of turnon_easymotor
+  * TeleMetrum v4.0 work in progress
+  * altosui: force Locale.ROOT during CSV export to avoid commas in decimals
+  * ao-tools: return ao-flash-lpc operaton to "full speed"
+  * doc: add a warning to TeleLaunch docs about siren volume levels
+  * doc: add a link to a reference on ARES/RACES use of PowerPole connectors
+  * doc: update EasyMotor behavior description for firmware 1.9.13 and later
+  * doc: update EasyMotor behavior description for firmware 1.9.13 and later
+  * releasing 1.9.13
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 19 Jan 2023 22:59:20 -0700
+
+altos (1.9.12-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * need to save .bin for TeleGPS v2.0
+  * first cut at EasyMotor v3 support
+  * a few config tweaks
+  * get ram usage under control, etc
+  * Revert "adxl375: Disable spi duplex"
+  * fix SPI index definition
+  * recognize EasyMotor-v3 too
+  * fix mailing list reference to use mailman3 path
+  * doc: additional improvements to motortest manual
+  * doc: include reference to Loki Research closures in motortest document
+  * fat: sign Windows installers with our new code signing certificate
+  * update Releasing to include reference to jsign as a release dependency
+  * updating changelog for 1.9.12 release
+
+  [ Keith Packard ]
+  * lpc: Make beeper timer configurable
+  * easymotor-v3: Configure beeper
+  * lpc: Stick magic value at 0x2fc to let us use PIO0_1
+  * lpc: Fix name of timer ioconf for pio0_1
+  * lpc: Fix name of timer ioconf constants
+  * lpc: Fixes for timer configuration
+  * easymotor-v3: enable adxl debugging
+  * adxl375: Disable spi duplex
+  * lpc: Attempt to make beeper generate correct tone
+  * altos: Fix ADXL375 SPI mode definitions and usage
+  * Disable adxl debug, set long delay
+  * reduce adxl speed to 100kHz
+  * lpc: Add SPI mode support. Use for ADXL375 on easymotor
+  * easymotor-v3: Increase ADXL spi speed back to normal, remove delay
+  * lpc: Shuffle more bits around for flash loader
+  * altos: Add EasyMotor-v3.0 to regular builds
+  * ao-eeprom: Add EasyMotor decode
+  * altoslib: Replace EasyMotor v2 code with v3
+  * ao-eeprom: Add easy motor support
+  * altos: Document easymotor record length
+  * doc: Update call sign
+  * ao-elftohex: Allow multiple elf files to be merged together
+  * easymini-v3.0: Create combined .ihx file for testing
+  * ao-elftohex: Add '-n' option to elide symbol table from output
+  * easymini: Elide symbols from combined .ihx file
+  * altos: Increase AES IV buffer to hold maximum AES state
+  * altos: Allow setting telemetry interval to zero without crashing
+  * Add EasyMini v3.0 firmware to release
+  * ao-eeprom: Handle merge conflict from easymotor-v3 branch
+  * easymotor-v3: Fix beeper config
+  * altos: Allow 'c a 0' without Syntax Error
+  * altoslib: Map log format back to USB device id
+  * altosuilib: Limit EasyMotor graphs to motor pressure and accel by default
+  * doc: Add specs for EasyMini v3 and EasyMotor v3
+  * doc: Add preliminary 1.9.12 release notes
+  * Add EasyMotor v3 firmware to release
+  * altosui: Ship motortest.pdf with packaged builds
+  * altosuilib: Remove some debug printfs
+  * Auto-detect windows signing stuff
+  * Version 1.9.12
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 28 Oct 2022 23:12:21 -0600
+
+altos (1.9.11-2) unstable; urgency=medium
+
+  * cherry pick patch from master that increases AES IV buffer to hold 
+    maximum AES state, closes: #1022301
+
+ -- Bdale Garbee <bdale@gag.com>  Mon, 24 Oct 2022 10:02:35 -0600
+
 altos (1.9.11-1) unstable; urgency=medium
 
   [ Bdale Garbee ]