update changelogs for Debian build
[fw/altos] / debian / changelog
index 572af3e6f4986bfbe35da9f40814d8b3e66cd88c..32569ac50ade8bdfb68547ee5bf9f25a6806b4f0 100644 (file)
@@ -1,4 +1,164 @@
-altos (0.7+81+g012e717) unstable; urgency=low
+altos (0.7.1+73+g8c8dc37) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * remove the csv build dep, as that code will be abandoned
+
+  [ Keith Packard ]
+  * altosui: Remove ability to graph data in .csv files
+  * altosui: Separate out jfreechart and jcommon directories
+  * altosui: Split out flight monitoring to separate window
+  * altosui: Create buttons for main actions
+  * altosui: Fix channel setting at serial open time
+  * altosui: Fix more calls to AltosPreferences.channel()
+  * altosui: Create abstract interface for flight data display
+  * altosui: Add tab UI with 'pad' mode.
+  * altosui: Add ascent, descent and landed tabs
+  * altos: Use grey leds when unlit - easier to see
+
+  [ Anthony Towns ]
+  * use value_font for values
+  * add --replay command line argument
+  * read preferences for --replay
+  * reduce font size for FlightInfoTable
+  * use grayled.png for off
+  * add compass bearing to voice output
+  * add compass bearing during descent
+
+  [ Keith Packard ]
+  * altosui: Add RF calibration to TeleMetrum config dialog
+  * altosui: Eliminate unncessary import altosui lines
+  * altosui: Open serial device at 'new' time. Prohibit duplicate opens.
+  * altosui: Replace flight status table with labels, fix resize.
+  * altosui: With --replay option, exit when replay window is closed
+  * altosui: oops, missed a file in the previous commit
+  * altosui: eliminate menu bar, moving elements to buttons.
+  * altosui: add reboot button to telemetrum configuration UI
+  * altosui: Add callsign configuration in AltosUI configuration dialog
+  * altosui: Cleanup flight UI layout
+  * altosui: Add igniter status to ascent and descent tabs
+  * altosui: Add igniter ground testing code
+  * altosui: Unify datafile selection to AltosDataChooser
+  * altosui: Clean up global AltosUI configuration settings dialog
+  * doc: Add preliminary altosui documentation
+  * doc: git ignore generated doc files
+  * doc: Document the 'Flash Image' operation.
+  * altosui: Use timeouts to recover from broken packet links.
+
+  [ Bdale Garbee ]
+  * update turnon scripts to use stashed copies of stable release
+    firmware
+
+  [ Keith Packard ]
+  * altosui: switch channel selector to combo box. Shorten displayed
+    device names
+  * altosui: When switching log files, don't terminate log thread
+
+  [ Bdale Garbee ]
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 20 Nov 2010 00:18:45 -0700
+
+altos (0.7.1+32+g8103432) unstable; urgency=low
+
+  * add build-dep on libcsv-java
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 06 Oct 2010 16:25:57 -0600
+
+altos (0.7.1+28+gd8a2f4c) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * make the column headers comma separated, too, so they align with the
+    data
+
+  [ Keith Packard ]
+  * altosui: set default .csv file name in file save dialog
+  * altosui: Remember directory containing firmware files
+
+  [ Anthony Towns ]
+  * Add graphing.
+  * Add JFreeChart to Makefile.am
+
+  [ Keith Packard ]
+  * altosui: Use recorded ground acceleration when reading eeprom files
+  * altosui: Write raw sensor data to .csv files
+  * altosui: Factor some UI elements into separate classes
+  * altosui: remove unused ReplayThread wrapper classes
+  * altosui: Require 4 sats for 'good' GPS data
+  * altosui: Create iterables for log file scanning. Split out display
+    threads
+  * altosui: .CSV output: add link quality, gps hdop and sat C/N0
+    numbers
+  * altosui: Deal with eeprom dates going backwards across wrap
+
+  [ Anthony Towns ]
+  * Hax0r graphing to support telem/eeprom files
+
+  [ Keith Packard ]
+  * altosui: use Altos constants in graphing code
+
+  [ Anthony Towns ]
+  * Add callsign/serial/flight to graph title
+
+  [ Keith Packard ]
+  * altosui: Add KML file export.
+
+  [ Bdale Garbee ]
+  * add build dep on jfreechart lib
+
+ -- Bdale Garbee <bdale@gag.com>  Wed, 06 Oct 2010 16:19:12 -0600
+
+altos (0.7.1) unstable; urgency=low
+
+  [ Keith Packard ]
+  * Add firmware and libaltos to 'fat' target at top-level
+  * altosui: Remove some debug printfs.
+  * altosui: libaltos.so is built with libtool -- it's in
+    ../libaltos/.libs
+  * Add --with-fat-dir configure option to publish finished stand-alone
+    bits
+  * altosui: Fix telemetry file reader to handle tick count wrapping
+  * altosui: Remove debug printfs from AltosTelemetryReader
+  * altosui: Fill in time value of last Eeprom record read from file
+  * altosui: Stop parsing eeprom file after hitting 'landed' state
+
+ -- Bdale Garbee <bdale@gag.com>  Fri, 10 Sep 2010 00:09:02 -0600
+
+altos (0.7+96+g48f5799) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: conflating USB product and vendor IDs is a bad idea
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 09 Sep 2010 21:29:13 -0600
+
+altos (0.7+94+g1ac3d7e) unstable; urgency=low
+
+  * initial cut at an altosui man page
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 09 Sep 2010 20:34:38 -0600
+
+altos (0.7+92+g0ea7576) unstable; urgency=low
+
+  [ Bdale Garbee ]
+  * handle versioning of ihx files (poorly) by just wildcarding the file
+    name
+
+  [ Keith Packard ]
+  * altosui: Need to have JVM include path substituted into libaltos
+    Makefile
+  * altosui: Store libaltos.so in $(libdir)/altos
+  * altosui: Display error dialog when AltOS JNI library can't be loaded
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 09 Sep 2010 20:05:44 -0600
+
+altos (0.7+86+g6c0ae7e) unstable; urgency=low
+
+  [ Keith Packard ]
+  * altosui: Add explicit requirement to create classes directory
+  * altosui: fix telemetrum.inf FFFE:000A product names on AMD64 and
+    ia64
+  * altosui: hack to make JAVAROOT directory get created before javac
+    runs
+  * altosui: remove FATJAR from all-local to avoid building fat .jar
+    file
 
   [ Bdale Garbee ]
   * add libtool to build deps