update changelog for Debian build
[fw/altos] / debian / changelog
index 919289316432814fc92e2befefd0d7a92c49f09b..0f637bb58a6b6d0af3689260658f3a9b34084c1d 100644 (file)
@@ -1,3 +1,208 @@
+altos (1.9.11-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * capture odd changes from production machine?
+  * fix version in 1.9.10 release notes
+  * fix version in 1.9.10 release notes
+  * need to capture .bin file for telebt loader, too
+  * doc: add an appendix on frequency calibration to the all-in-one manual
+  * need to capture .bin file for telebt loader, too
+  * need to save .bin for TeleGPS v2.0
+  * dial it down a bit more to not exceed +10 dBm, or 10 mW
+  * use correct test script for v1.0 easymega
+  * doc: add an appendix with examples for configurable pyro channels
+  * releasing 1.9.11
+
+  [ Keith Packard ]
+  * altosdroid: Skip map draw before transform is set
+  * altosdroid: Fix tab updates on Android 11 after rotate
+  * Version 1.9.10.1
+  * micropeak: detect empty log received from device
+  * ao-tools/ao-test-igniter: Deal with devices that use both 'apogee' for ADC
+  * altos/attiny: Switch to avrisp2 for development programmer
+  * altos: Switch all tick variables to AO_TICK_TYPE/AO_TICK_SIGNED
+  * altosdroid: Add BLUETOOTH_CONNECT permission, handle its lack
+  * Version 1.9.10.2
+  * data_interval == 0 means no data collection
+  * altos: AES code was storing bytes in an int array
+  * ao_pyro: Move delay_done out of pyro structure
+  * Switch from AdoptOpenJDK to Adoptium
+  * libaltos: Build Mac OSX libaltos.dylib for arm64 too
+  * Version 1.9.10.3
+  * altos: Re-enable apogee delay
+  * altos/attiny: Eliminate warnings from -Wconversion
+  * altos/drivers: Add explicit casts in ao_aprs, ao_bmx160 and ao_btm
+  * altos/drivers/ao_button: Save all 32-bits of irq status
+  * drivers: Fix type of radio timeout parameter
+  * ao_gps_skytrac, ao_gps_ublox: Add explicit casts to quiet -Wconversion
+  * ao_companion: Make time conversion to 16-bits in companion protocol explicit
+  * ao_hmc5883: Add explicit casts for -Wconversion
+  * drivers/ao_lco: Fix box types to be uint16_t. Also clean other -Wconversion messages
+  * drivers: Resolve -Wconversion in m25, mma655x, mmc5983, mpu and ms5607
+  * drivers/ao_packet: Switch time values to AO_TICK_TYPE
+  * drivers/ao_pad: Convert from/to 16-bit times over the air
+  * drivers/ao_quadrature: Fix -Wconversion warnings
+  * drivers/ao_rn4678: Fix timeouts to use AO_TICK_TYPE
+  * altos: Switch ao_radio_recv timeout to AO_TICK_TYPE
+  * altos/ao_stdio: use uint8_t for stdio index
+  * altos/ao_freq: Use uint32_t for radio freq setting value
+  * beep, cmd, config, convert_volt, data, distance, fec, kalman: -Wconversion warnings
+  * fifo: Add casts to fifo operation macros for -Wconversion
+  * ao_companion: Make motor_number uint16_t
+  * ao_convert_pa: Switch array index to unsigned type
+  * ao_flight: ao_interval_end type was too small, could cause premature landing state
+  * ao_gps, ao_log: Make conversions to 16-bit time log values explicit
+  * ao_log: Change flight type to uint16_t, widen APIs dealing with flight numbers to int32_t
+  * more 16-bit log tick values
+  * ao_log: Fix sensor time triggers to use AO_TICK_TYPE
+  * ao_log: Add casts to reduce -Wconversion warnings
+  * ao_micro: Add casts to micropeak code for -Wconversion warnings
+  * ao_radio_cmac: Make recv timeouts AO_TICK_TYPE
+  * ao_radio_cmac_cmd: Clean up types for -Wconversion
+  * ao_monitor: Clean up -Wconversion warnings
+  * kalman, report, romconfig, sample, send_packet: Clean up -Wconversion warnings
+  * ao_serial: Change serial_sleep_for APIs to use AO_TICK_TYPE
+  * ao_task: Task ids are 8-bits, fix type in struct ao_task
+  * ao_telemetry: Switch time variables to AO_TICK_TYPE
+  * ao_telemetry: Use int16_t types for telemetry packet intervals
+  * ao_telemetry: Add casts to reduce -Wconversion warnings
+  * ao_tracker: Fix tracker_interval type to match config type (plus -Wconversion)
+  * altos/lpc: Add casts to reduce -Wconversion warnings
+  * altos/micropeak-v2.0: Add casts to reduce -Wconversion warnings
+  * ao_flash_task: Add casts to reduce -Wconversion warnings
+  * ao_micropeak.c: Add casts to reduce -Wconversion warnings
+  * altos/stm: Add casts to reduce -Wconversion warnings
+  * altos/stm32l0: Add casts to reduce -Wconversion warnings
+  * altos/stmf0: Add casts to reduce -Wconversion warnings. Use AO_TICK_TYPE
+  * altos/telefire: Add cast to AO_LED_CONTINUITY to eliminate -Wconversion warning
+  * telefireone-v1.0: Use a boolean value for ao_log_running
+  * ao_lco_v2: Use int32_t for temporary box value in step_box
+  * ao_lco_v2: Add casts to reduce -Wconversion warnings
+  * altos/telemega-v5.0: Add casts to beep values
+  * altos: Add -Wconversion
+  * altos: Deal with 8-character version numbers
+  * altos: Document how delay_done is used in ao_pyro.c
+  * Version 1.9.10.4
+  * Allow TX power to be limited to 10mW
+  * ao-telem: Read from stdin if no filenames
+  * telegps-v0.3: Reduce stack size to fit in ram
+  * ao-tools/ao-eeprom: Dump converted info for F packets
+  * lpc: ADC 5 was busted
+  * lpc: Make beeper configurable
+  * src: Add easymini-v3.0
+  * doc: Document 10mw limit configuration
+  * doc: Add release notes for 1.9.11
+  * doc: Update copyrights to 2022
+  * Version 1.9.11
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 29 May 2022 21:09:27 -0600
+
+altos (1.9.10-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * libaltos: Make windows dlls reproducible
+  * libaltos: Use original windows printf/scanf
+  * Version 1.9.9.1
+  * altosdroid: Switch storage to media dir
+  * altoslib: Add callback from AltosLog on file open failure
+  * altosdroid: Catch log file open failures and show an error dialog
+  * doc: Version 1.9.10 notes
+  * altos/telemega-v5.0: Add .gitignore
+  * Version 1.9.10
+
+  [ Bdale Garbee ]
+  * update to latest policy and debhelper versions
+  * releasing 1.9.10
+
+ -- Bdale Garbee <bdale@gag.com>  Sun, 10 Oct 2021 21:44:54 -0600
+
+altos (1.9.9-1) unstable; urgency=medium
+
+  [ Bdale Garbee ]
+  * capture updates to Releasing from 1.9.8 release
+  * update TeleMega bench scripts for v5.0 hardware
+  * snapshot TeleMega v4 turnon and test scripts before crafting v5 versions
+  * libaltos: don't carry pre-built .dll files in the repo any more
+  * releasing 1.9.9
+
+  [ Keith Packard ]
+  * altosdroid: Set android version to 30
+  * Remind us to update ANDROID_VERSION
+  * altos: Fix config upgrade from 1.24 to 1.25
+  * altoslib: Parse TeleMega v5.0 eeprom records
+  * altos: Measure mmc5983 offset
+  * 1.9.9 release notes
+  * Version 1.9.9
+
+ -- Bdale Garbee <bdale@gag.com>  Thu, 07 Oct 2021 00:01:59 -0600
+
+altos (1.9.8-1) unstable; urgency=medium
+
+  [ Keith Packard ]
+  * altosdroid: Work without GPS available
+  * altosuilib: Remove spurious message about libaltos
+  * kernel: Widen pyro time values to 32 bits
+  * doc: telemini force freq is pin 6, not 7
+  * altosdroid: Show altitude as well as height
+  * libaltos: Use cross compilers to build libaltos for i686, amd64, aarch64, armel and armhf
+  * ao-bringup: Revert EasyMini scripts to 1.0
+  * altos: Fixes for GCC 10 (-fno-common is default)
+  * ao-test-igniter: Also test ADC voltage for in-range of 1-4 volts
+  * ao-bringup: Use ao-test-igniter voltage check feature in pyro tests
+  * altos: Add preliminary TeleMega v5.0 bits
+  * altos: Add MMC5983 driver
+  * altos: Change MMC5893 driver to avoid interrupts
+  * libaltos: Add new microchip MAC address to bluetooth map
+  * micropeak: Show error message if USB adapter open fails
+  * altos: Prepare for picolibc stdio change
+  * telemega-v5.0: Add Makefiles
+  * Show mag sensor SPI ID
+  * altos: Fix telemega v5.0 CS_FLASH pin
+  * altos: Record MPU6000 failure but let device boot
+  * altos/stm: Use picolibc startup code
+  * altos: Add bit-bang i2c driver
+  * altos: Get MMC5983 driver working
+  * altos/stm: Minor cleanups in ao_arch_funcs.h
+  * altos/telemega-v5.0: Fix config for MMC5983
+  * altos: Detect CC120X device type
+  * altos: Support normalized axes in mpu6000 and mmc5983
+  * altos: Allow devices to override default beep
+  * altos: Support normalized log
+  * altos: Add normalized telemetry support
+  * altos: Update telemega-v5.0 config
+  * altoslib: Support TeleMega v5.0
+  * altosui: Add options for low frequency beeper
+  * altos: Fix up HAS_FLIGHT_DEBUG
+  * altos: Allow beep tone spacing to be changed
+  * altos/telemega-v5.0: Space tones closer together
+  * altos: Build TeleMega v5.0 bits
+  * Add TeleMega v5.0 firmware
+  * altosdroid: Add tilt angle to pad and flight tabs
+  * libaltos: Update windows DLLs
+  * Bump version to 1.9.7.1
+  * altos: Deal with cc1201 limitations
+  * altos: All beep-enabled boards have beep config
+  * Add test-easymini-v1.0 script
+  * altoslib: Document how to add a new product
+  * libaltos: Ignore cjnitest files for all targets
+  * doc: Note pyro channel time limits on <1.9.8 firmware
+  * doc: Add specs for TeleMega v5.0
+  * doc: Update for 1.9.8
+  * Version 1.9.8
+
+  [ Bdale Garbee ]
+  * doc: add mounting hole spacing information to product outlines
+  * debian: add --disable-multi-arch to configure
+  * update ChangeLog for 1.9.8 release
+
+ -- Keith Packard <keithp@keithp.com>  Mon, 20 Sep 2021 21:30:49 -0600
+
+altos (1.9.7-2) unstable; urgency=medium
+
+  * pull in fix from master branch for gcc-10 compilation, closes: #991800
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 03 Aug 2021 09:44:09 -0600
+
 altos (1.9.7-1) unstable; urgency=medium
 
   [ Keith Packard ]
@@ -87,7 +292,7 @@ altos (1.9.7-1) unstable; urgency=medium
   * Version 1.9.7
 
   [ Bdale Garbee ]
-  * TeleLaunch docs should use telelaunch.txt, update copyright year, lose "draft"
+  * TeleLaunch docs use telelaunch.txt, update copyright year, lose "draft"
   * put notes in Releasing about keeping doc/header.inc up to date
   * doc: add documentation on how to re-flash a TeleMini v3 over USB
   * doc: first draft of manual for EasyMotor
@@ -101,7 +306,7 @@ altos (1.9.7-1) unstable; urgency=medium
   * ao-tools: update ao-flash-stm32f0x to work with openocd in Debian unstable
   * ao-bringup: add tools for flash/cal/test of EasyMotor v2
   * ao-bringup: fix easymotor script to use .bin for dfu-util
-  * TeleLaunch docs should use telelaunch.txt, update copyright year, lose "draft"
+  * TeleLaunch docs use telelaunch.txt, update copyright year, lose "draft"
   * put notes in Releasing about keeping doc/header.inc up to date
   * doc: add documentation on how to re-flash a TeleMini v3 over USB
   * doc: first draft of manual for EasyMotor