fat: sign Windows installers with our new code signing certificate
[fw/altos] / altosui / Makefile.am
index 19bcb913950b3c6576d6381e4bbc1646028c9f48..c2df5de720b06d050c64af194df8ccae27953b03 100644 (file)
@@ -1,3 +1,5 @@
+# location of code signing key, et al
+CODEKEYDIR=~/altusmetrumllc/ssl.com
 
 JAVAROOT=classes
 AM_JAVACFLAGS=$(JAVAC_VERSION_FLAGS) -encoding UTF-8 -Xlint:deprecation -Xlint:unchecked
 
 JAVAROOT=classes
 AM_JAVACFLAGS=$(JAVAC_VERSION_FLAGS) -encoding UTF-8 -Xlint:deprecation -Xlint:unchecked
@@ -411,3 +413,7 @@ $(MACOSX_DIST): $(MACOSX_FILES) $(MACOSX_EXTRA) Makefile
 $(WINDOWS_DIST): $(WINDOWS_FILES) altos-windows.nsi Instdrv/NSIS/Includes/java.nsh
        -rm -f $@
        makensis -Oaltos-windows.log "-XOutFile $@" "-DVERSION=$(VERSION)" altos-windows.nsi || (cat altos-windows.log && exit 1)
 $(WINDOWS_DIST): $(WINDOWS_FILES) altos-windows.nsi Instdrv/NSIS/Includes/java.nsh
        -rm -f $@
        makensis -Oaltos-windows.log "-XOutFile $@" "-DVERSION=$(VERSION)" altos-windows.nsi || (cat altos-windows.log && exit 1)
+       jsign --keystore $(CODEKEYDIR)/altus_metrum,_llc.p12 --alias 1 \
+               --storetype PKCS12 --storepass `cat $(CODEKEYDIR)/password` \
+               --tsaurl http://ts.ssl.com --tsmode RFC3161 $@
+