Import Debian changes 1.12-2.1 master
authorgregor herrmann <gregoa@debian.org>
Sun, 19 Jul 2015 14:53:16 +0000 (16:53 +0200)
committerBdale Garbee <bdale@gag.com>
Fri, 1 Feb 2019 20:30:12 +0000 (13:30 -0700)
uaputl (1.12-2.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix "ftbfs with GCC-5": apply patch from Brett Johnson:
    build with "-std=gnu89"
    (Closes: #778152)

debian/changelog
debian/gbp.conf [new file with mode: 0644]
debian/patches/gcc5.patch [new file with mode: 0644]
debian/patches/series [new file with mode: 0644]

index b13cf9c9d810e162c4f2fa709131f80c77c1e537..db2e2bd30b1c4d6015756e8f3ea0975928f2a655 100644 (file)
@@ -1,3 +1,12 @@
+uaputl (1.12-2.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Fix "ftbfs with GCC-5": apply patch from Brett Johnson:
+    build with "-std=gnu89"
+    (Closes: #778152)
+
+ -- gregor herrmann <gregoa@debian.org>  Sun, 19 Jul 2015 16:53:16 +0200
+
 uaputl (1.12-2) unstable; urgency=low
 
   * work around Makefile's inappropriate use of ../.., which breask builds in
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644 (file)
index 0000000..1d94740
--- /dev/null
@@ -0,0 +1,46 @@
+# Configuration file for git-buildpackage and friends
+
+[DEFAULT]
+# the default build command:
+#builder = debuild -i\.git/ -I.git
+# the default clean command:
+#cleaner = debuild clean
+# the default branch for upstream sources:
+upstream-branch = upstream
+# the default branch for the debian patch:
+debian-branch = master
+# the default tag formats used:
+#upstream-tag = upstream/%(version)s
+#debian-tag = debian/%(version)s
+# use pristine-tar:
+pristine-tar = True
+
+# Options only affecting git-buildpackage
+[git-buildpackage]
+#upstream-branch = dfsgclean
+# uncomment this to automatically GPG sign tags
+#sign-tags = True
+# keyid to GPG sign tags with
+#keyid = 0xdeadbeef
+# push to a remote repository after a successful tag: 
+posttag = git push --mirror
+# use this for more svn-buildpackage like behaviour:
+export-dir = ../build-area/uaputl/
+#tarball-dir = ../tarballs/
+
+# Options only affecting git-import-orig
+[git-import-orig]
+#upstream-branch = newupstream
+#debian-branch = dfsgclean
+#filter = .svn
+
+# Options only affecting git-import-dsc
+[git-import-dsc]
+#upstream-branch = svn-upstream
+#filter = [ 'CVS', '.cvsignore' ]
+
+# Options only affecting git-dch
+[git-dch]
+#git-log = --no-merges
+#snapshot-number = snapshot + 1
+
diff --git a/debian/patches/gcc5.patch b/debian/patches/gcc5.patch
new file mode 100644 (file)
index 0000000..f2a5f97
--- /dev/null
@@ -0,0 +1,19 @@
+Description: fix build failure with GCC 5:
+ build with -std=gnu89
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/778152
+Author: Brett Johnson <brett@hp.com>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2015-07-19
+
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@
+ #CFLAGS += -DAP22 -fshort-enums
+-CFLAGS += -Wall
++CFLAGS += -Wall -std=gnu89
+ #ECHO = @
+ LIBS = -lrt
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644 (file)
index 0000000..a613132
--- /dev/null
@@ -0,0 +1 @@
+gcc5.patch