Import Debian changes 1.12-2.1
[debian/uaputl] / debian / patches / gcc5.patch
diff --git a/debian/patches/gcc5.patch b/debian/patches/gcc5.patch
new file mode 100644 (file)
index 0000000..f2a5f97
--- /dev/null
@@ -0,0 +1,19 @@
+Description: fix build failure with GCC 5:
+ build with -std=gnu89
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/778152
+Author: Brett Johnson <brett@hp.com>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2015-07-19
+
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@
+ #CFLAGS += -DAP22 -fshort-enums
+-CFLAGS += -Wall
++CFLAGS += -Wall -std=gnu89
+ #ECHO = @
+ LIBS = -lrt