tests: new test listed04 for --one-file-system --listed-incremental
authorPaul Eggert <eggert@cs.ucla.edu>
Tue, 23 Nov 2010 01:58:55 +0000 (17:58 -0800)
committerBdale Garbee <bdale@gag.com>
Tue, 7 Dec 2010 03:33:12 +0000 (20:33 -0700)
* tests/Makefile.am (TESTSUITE_AT): Add listed04.at.
* tests/listed04.at: New file.
* tests/testsuite.at: Include it.

tests/Makefile.am
tests/listed04.at [new file with mode: 0644]
tests/testsuite.at

index 12e8c1b2007526f0ecd3b0d6e80fd141adebaf97..d1bd80746c222b6261c03d23730498293ec91865 100644 (file)
@@ -110,6 +110,7 @@ TESTSUITE_AT = \
  listed01.at\
  listed02.at\
  listed03.at\
+ listed04.at\
  long01.at\
  longv7.at\
  lustar01.at\
diff --git a/tests/listed04.at b/tests/listed04.at
new file mode 100644 (file)
index 0000000..239998d
--- /dev/null
@@ -0,0 +1,47 @@
+# Process this file with autom4te to create testsuite. -*- Autotest -*-
+
+# Test suite for GNU tar.
+# Copyright (C) 2010 Free Software Foundation, Inc.
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+# This checks for the bug reported by Martin Weigel
+# <http://lists.gnu.org/archive/html/bug-tar/2010-11/msg00071.html>.
+# The test is derived from the ideas in Jean-Louis Martineau's followup email
+# <http://lists.gnu.org/archive/html/bug-tar/2010-11/msg00087.html>.
+
+AT_SETUP([--listed-incremental and --one-file-system])
+AT_KEYWORDS([listed incremental listed04])
+
+AT_TAR_CHECK([
+
+mkdir dir
+echo a >dir/a
+echo b >dir/b
+
+tar --one-file-system -cvf archive.tar -g archive.incr dir || exit
+tar -tf archive.tar || exit
+],
+[0],
+[dir/
+dir/a
+dir/b
+dir/
+dir/a
+dir/b
+],
+[tar: dir: Directory is new
+],[],[],[gnu])
+
+AT_CLEANUP
index d18b16e58e3ec2bc4d63c5466e649ab0d6cca2a4..30b738a95172fd0d83d55b4c8039c44eeba84edd 100644 (file)
@@ -174,6 +174,7 @@ m4_include([incr02.at])
 m4_include([listed01.at])
 m4_include([listed02.at])
 m4_include([listed03.at])
+m4_include([listed04.at])
 m4_include([incr03.at])
 m4_include([incr04.at])
 m4_include([incr05.at])