cleanups before upload debian/1.25-1
authorBdale Garbee <bdale@gag.com>
Wed, 10 Nov 2010 23:22:17 +0000 (16:22 -0700)
committerBdale Garbee <bdale@gag.com>
Wed, 10 Nov 2010 23:22:17 +0000 (16:22 -0700)
debian/changelog
debian/control
src/list.c

index 758ceda2cc992c1f56a4017d80f1c3f639b0e333..28792cd5c339d1a7cdc63ae2982b10977d9638c4 100644 (file)
@@ -1,8 +1,10 @@
 tar (1.25-1) unstable; urgency=low
 
-  * new upstream version, closes: #602184, #602209, #602413
+  * new upstream version, closes: #602184, #602209, #602413, #575298
   * Add Vcs-Git, Vcs-Browser fields to debian/control using patch from
     Simon McVittie's 1.24-1.1 NMU, closes: #602639, #602709
+  * stop patching src/list.c since it now does more harm than good,
+    and add a Breaks against old dpkg versions, closes: #522858
 
  -- Bdale Garbee <bdale@gag.com>  Wed, 10 Nov 2010 15:45:09 -0700
 
index 65a3f13ef5fe0ba276f3161285caaa3a071c7b35..acd3fac55c38d749520c9c8699769c4feebe0cba 100644 (file)
@@ -14,6 +14,7 @@ Pre-Depends: ${shlibs:Depends}, ${misc:Depends}
 Essential: yes
 Conflicts: cpio (<= 2.4.2-38)
 Replaces: cpio (<< 2.4.2-39)
+Breaks: dpkg-dev (<< 1.14.26)
 Suggests: bzip2, ncompress, xz-utils
 Description: GNU version of the tar archiving utility
  Tar is a program for packaging a set of files as a single archive in tar
index 68f511506dd83d7453c904ab795151953a218fe2..a70f0d38298919dda7bba95df4492cb1618f33fa 100644 (file)
@@ -218,17 +218,9 @@ read_and (void (*do_something) (void))
                                    read_header_auto);
              if (status == HEADER_ZERO_BLOCK)
                break;
-             /* 
-              * According to POSIX tar specs, this is wrong, but on the web
-              * there are some tar specs that can trigger this, and some tar
-              * implementations create tars according to that spec.  For now,
-              * let's not be pedantic about issuing the warning.
-              */
-#if 0         
              WARNOPT (WARN_ALONE_ZERO_BLOCK,
                       (0, 0, _("A lone zero block at %s"),
                        STRINGIFY_BIGINT (current_block_ordinal (), buf)));
-#endif
              break;
            }
          status = prev_status;