patch for tarman handling of multi-line descriptions debian/1.27.1-2
authorBdale Garbee <bdale@gag.com>
Sat, 22 Mar 2014 21:55:23 +0000 (15:55 -0600)
committerBdale Garbee <bdale@gag.com>
Sat, 22 Mar 2014 21:55:23 +0000 (15:55 -0600)
debian/changelog
debian/tarman

index 1ab1b56f0b8619a10d79940fbc56adfe0594cc62..f3816b35b32294dc76bb61e4232ce08fd8df7d0c 100644 (file)
@@ -2,8 +2,10 @@ tar (1.27.1-2) unstable; urgency=low
 
   * patch from David Gilman adds watch file with signature verification, 
     closes: #742351
+  * patch from David Gilman fixes problem with multi-line descriptions,
+    closes: #593149
 
- -- Bdale Garbee <bdale@gag.com>  Sat, 22 Mar 2014 13:31:09 -0600
+ -- Bdale Garbee <bdale@gag.com>  Sat, 22 Mar 2014 15:55:03 -0600
 
 tar (1.27.1-1) unstable; urgency=low
 
index 3ef257dc5a915c657d2eb739e8a88e6c50eebc5b..70169311191018dfb5dc1ea131b86b509a2798ea 100644 (file)
@@ -94,6 +94,15 @@ while (<>) {
                                        $$lastoperation{'description'} .= $c3[1];
                                }
                        }
+                       if (!$nflag && !/\}/) {
+                               while (<>) {
+                                       my @extended_desc = split('"', $_);
+                                       $$lastoperation{'description'} .= $extended_desc[1];
+                                       if (/\}/) {
+                                               last;
+                                       }
+                               }
+                       }
                }
        }
        if ($mode == 3 ) {