add a tar-scripts package to contain --enable-backup-scripts content
authorBdale Garbee <bdale@gag.com>
Sat, 21 Sep 2013 16:25:34 +0000 (10:25 -0600)
committerBdale Garbee <bdale@gag.com>
Sat, 21 Sep 2013 16:25:34 +0000 (10:25 -0600)
debian/changelog
debian/control
debian/rules
debian/tar-scripts.dirs [new file with mode: 0644]

index c10331cced06704983c9d429b1bb4ea825072f33..d8e905108c1ca7158449593becc0e54ef22e0225 100644 (file)
@@ -1,3 +1,10 @@
+tar (1.26+dfsg-9) unstable; urgency=low
+
+  * add a tar-scripts package containing the --enable-backup-scripts content,
+    which conflicts with files in at least the dump package, closes: #293671
+
+ -- Bdale Garbee <bdale@gag.com>  Sat, 21 Sep 2013 09:44:48 -0600
+
 tar (1.26+dfsg-8) unstable; urgency=low
 
   * cherry-pick upstream commit at Pino Toscano's suggestion to fix FTBFS
index db8b6cb00fed297f539296e063859462ede7f1f3..32068cbd5b811c36dc63909998f686b0250ae5f3 100644 (file)
@@ -16,10 +16,19 @@ Essential: yes
 Conflicts: cpio (<= 2.4.2-38)
 Replaces: cpio (<< 2.4.2-39)
 Breaks: dpkg-dev (<< 1.14.26)
-Suggests: bzip2, ncompress, xz-utils
+Suggests: bzip2, ncompress, xz-utils, tar-scripts
 Description: GNU version of the tar archiving utility
  Tar is a program for packaging a set of files as a single archive in tar
  format.  The function it performs is conceptually similar to cpio, and to
  things like PKZIP in the DOS world.  It is heavily used by the Debian package
  management system, and is useful for performing system backups and exchanging
  sets of files with others.
+
+Package: tar-scripts
+Architecture: any
+Multi-Arch: foreign
+Depends: ${shlibs:Depends}, ${misc:Depends}, tar
+Conflicts: dump
+Description: optional scripts for GNU version of the tar archiving utility
+ This package provides the backup, restore, backup.sh, and dump-remind
+ scripts that are mentioned in the tar documentation. 
index 0b85fbf7fffe78cd42f44953baa4a8a3a968e881..fe0fc0a3f41c59556eda6808ca65b3ecac60af58 100755 (executable)
@@ -19,6 +19,7 @@ configure-stamp:
        RSH="/usr/bin/rsh" CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure \
                --prefix=/usr \
                --libexecdir=/usr/sbin \
+               --enable-backup-scripts \
                --with-lzma=xz \
                $(CONFARGS) 
        touch configure-stamp
@@ -38,7 +39,6 @@ ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
          echo "Sorry, but the test suite is not designed to be run as root."; \
          exit 1 ;\
        fi
-       (cd tests ; $(MAKE) clean)
        $(MAKE) check
 endif
 endif
@@ -65,6 +65,10 @@ install: build
        mv debian/tar/usr/sbin/rmt debian/tar/usr/sbin/rmt-tar
        install -m 755 debian/tarcat debian/tar/usr/sbin/tarcat
 
+       mv debian/tar/usr/sbin/backup* debian/tar-scripts/usr/sbin/
+       mv debian/tar/usr/sbin/restore debian/tar-scripts/usr/sbin/
+       mv debian/tar/usr/sbin/dump-remind debian/tar-scripts/usr/sbin/
+
 # Build architecture-independent files here.
 binary-indep: build install
 
diff --git a/debian/tar-scripts.dirs b/debian/tar-scripts.dirs
new file mode 100644 (file)
index 0000000..236670a
--- /dev/null
@@ -0,0 +1 @@
+usr/sbin